none
Máquina virtual reinicia ao criar checkpoint RRS feed

  • Pergunta

  • Boa tarde.

    Possui um cluster de virtualização composto de dois host Windows Server 2012 R2 Datacenter.

    Temos uma máquina virtual do SCCM, que é Windows Server 2016, é uma vm de 2ª geração, onde todos os discos são iscsi.

    O que ocorre é que sempre que eu crio um check point do servidor o mesmo simplesmente reinicializa e não cria o checkpoint, sendo necessário reiniciar o processo durante o boot.

    Fiz a análise dos logs de eventos do servidor e encontro muito erro genérico, e nos logs de eventos do cluster, reporta eventos de resource apenas, mas não acho nada que seja pertinente ao reboot o servidor.

    Antes que alguém pergunte, a LUN onde esse servidor está é do tipo CSV e possui 550GB de espaço e para o que é feito, normalmente não precisa de muito, pois são checkpoints temporários.

    Alguém já viu esse problema?


    João Fracassi Graduado em Análise e Desenvolvimento de Sistemas Analista de Suporte MCP | MCSA

    segunda-feira, 12 de novembro de 2018 18:02

Respostas

  • Bom dia,

    Por falta de retorno essa thread está sendo encerrada.

    Caso necessário, sinta-se livre para reabrir a thread (desmarcando como resposta) ou se achar mais conveniente, abrir uma nova thread.

    Atenciosamente,

    Igor F. Kunrath

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    Technet Community Support

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    • Marcado como Resposta IgorFKModerator segunda-feira, 3 de dezembro de 2018 11:36
    segunda-feira, 3 de dezembro de 2018 11:36
    Moderador

Todas as Respostas

  • Bom dia João Fracassi, tudo bem?

    Este problema ocorre em uma VM em específico ou ocorre em todas as VMs no seu servidor de virtualização? 

    Você pode seguir dicas sugeridas nesta thread para tentar obter mais alguma informação sobre este cenário:

    https://social.technet.microsoft.com/Forums/windows/en-US/ab09f8a1-2dbe-4614-8ec2-2428170ce73e/creating-checkpoint-causes-vm-to-restart?forum=winserverhyperv 

    Espero que ajude. Atenciosamente, 


    Igor F. Kunrath

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    Technet Community Support

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    segunda-feira, 19 de novembro de 2018 13:02
    Moderador
  • Boa tarde.

    Esse problema ocorre com uma vm em especifico.

    VM - Windows Server 2016 - 2ª geração.

    HOST - Windows Server 2012 R2 (Hyper-V).

    Todas as outras vms aparentemente estão nomais.

    Vou olhar a dica da otra thread.


    João Fracassi Graduado em Análise e Desenvolvimento de Sistemas Analista de Suporte MCP | MCSA

    terça-feira, 20 de novembro de 2018 16:06
  • Bom dia João Fracassi, tudo bem?

    Checou a thread citada? Achou alguma informação útil para seu caso lá?

    Atenciosamente, 


    Igor F. Kunrath

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    Technet Community Support

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    segunda-feira, 26 de novembro de 2018 11:55
    Moderador
  • Olá João,

    Antes de efetuar o checkpoint, tente reiniciar o serviço de VSS do host físico e da VM também por desencargo. Se funcionar e a VM não reiniciar, pode ser que alguma tarefa está presa no serviço, pois já ocorreu isso comigo.

    Espero que ajude e nos posicione.


    Vinicius Mozart || MVP - Cloud and Datacenter Management || vinicius.mozart@terra.com.br || http://www.wenz.com.br || Skype:vinicius.mozart || www.wenzcursos.com.br



    segunda-feira, 26 de novembro de 2018 22:57
  • Boa noite Igor,

    Achei interessante a thread mensionado por você, pois eu achei outras referências na internet que batem com essas informações.

    Eu reiniciei o serviço do VSS dentro do guest (vm) e no host do Hyper-V eu desabilitei o Integration Service > Checkpoint (volume backup), mas não tive exito ainda.

    Eu analisei os logs de eventos do guest e do host e não achei muita informação útil para o problema, mesmo verificando pela faixa de horários que ocorreram.

    Um fato interessante, que ao excluir o snapshot, durante o processo de merge não ocorre o problema.

    Seguimos na luta.

    O próximo passo é fazer o que o Vinicius abaixo mensiona, que é reiniciar o serviço de VSS no host.


    João Fracassi Graduado em Análise e Desenvolvimento de Sistemas Analista de Suporte MCP | MCSA

    segunda-feira, 26 de novembro de 2018 23:04
  • Oi Vinicius, tudo bem cara.

    É um prazer poder falar contigo, então  seguinte.

    Eu vou fazer esse procedimento de reiniciar o serviço de VSS no host do Hyper-V.

    Ao reiniciar esse serviço a algum impacto no ambiente e nas vms?


    João Fracassi Graduado em Análise e Desenvolvimento de Sistemas Analista de Suporte MCP | MCSA

    segunda-feira, 26 de novembro de 2018 23:06
  • Olá João,

    Prazer falar contigo também e obrigado pelo carinho. 

    Geralmente tudo que estiver relacionado a backups, serviços de pastas de copia de sombra podem ser afetados, mas geralmente o restart é bem rápido e não ocasiona dados ao ambiente. Claro, deve-se rodar e evitar horários de backups agendados. Fora isso, tranquilo.


    Vinicius Mozart || MVP - Cloud and Datacenter Management || vinicius.mozart@terra.com.br || http://www.wenz.com.br || Skype:vinicius.mozart || www.wenzcursos.com.br

    segunda-feira, 26 de novembro de 2018 23:35
  • Bom dia Vinicius.

    Eu reiniciei o serviço do vss no host de hyper-v onde está a vm hospedada.

    Agora vou monitorar a criação de vms para ver se o problema volta a ocorrer.

    Mas falando do serviço do vss, eu notei, que o mesmo está como manual e muitas vezes esse serviço está parado, então acabo iniciando o mesmo. É normal isso? Se não, pode estar ai mesmo o problema.

    Infelizmente o ambiente cresceu tanto que não tenho como migrar essa vm de host, devido a memória insuficiente para tamanha demanda, o que complica, verificar se é um problema no host ou na vm, pois é um cluster HA, que não tenho HA.

    Muito obrigado por enquanto.


    João Fracassi Graduado em Análise e Desenvolvimento de Sistemas Analista de Suporte MCP | MCSA

    terça-feira, 27 de novembro de 2018 11:35
  • Olá João,

    Normal, o estado do serviço é manual e não inciado. Ele apenas é chamado quando tem tarefas agendadas para ele. O conceito do serviço é exatamente assim.

    Espero que ajude.


    Vinicius Mozart || MVP - Cloud and Datacenter Management || vinicius.mozart@terra.com.br || http://www.wenz.com.br || Skype:vinicius.mozart || www.wenzcursos.com.br

    terça-feira, 27 de novembro de 2018 16:00
  • Bom dia,

    Por falta de retorno essa thread está sendo encerrada.

    Caso necessário, sinta-se livre para reabrir a thread (desmarcando como resposta) ou se achar mais conveniente, abrir uma nova thread.

    Atenciosamente,

    Igor F. Kunrath

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    Technet Community Support

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    • Marcado como Resposta IgorFKModerator segunda-feira, 3 de dezembro de 2018 11:36
    segunda-feira, 3 de dezembro de 2018 11:36
    Moderador