none
SQL-Server negando novas conexões RRS feed

  • Pergunta

  •  

    Senhores,

     

     

    O banco passa o dia funcionando, mas em determinado momento (fechamento de vendas, etc) o servidor começa a negar conexões de terminais que tentam conectar... o servidor tem 4 GB de RAM, QUAD-CORE, etc... o processamento dele não sai de 5%... como posso analisar isso? sp_who? tem outras? onde vejo limite de usúarios?

     

    Abraço,

    quinta-feira, 3 de julho de 2008 20:28

Respostas

  • Welkson,

     

    Este detalhe que voê havia se esquecido com certeza é muito importante, e possivelmente era o causador deste problemas, pois esta limitando o seu servidor a trabalhar com uma quantidade de acesso por usuário.

    sexta-feira, 4 de julho de 2008 11:39
    Moderador

Todas as Respostas

  • Muito boa noite Welkson

    Ah... me explique:

    1. O terminal tenta conectar no Terminal Service pelo Conexão de área de trabalho remota?

    2. Qual seria a mensagem? Você tem algum log de erro?

    3. Nesse horario mais pessoal tentam conectar ou esse erro é mostrado quando elas já estão conectadas?

     

    Não sei se analisei a pergunta errado... mas se fiz isso me desculpe

     

     

     

    quinta-feira, 3 de julho de 2008 23:50
  • Welkson,

     

    Primeiramente qual é a versão do Windows Server que você esta utilizando?

     

    Isso esta ocorrendo após quantas conexões estarem ativas?

    sexta-feira, 4 de julho de 2008 10:39
    Moderador
  • Bom dia Romulo!

     

    1- A conexão é direta, não usa TS. É um aplicativo comercial desenvolvido em MS Visual Foxpro.

     

    2- Access denied, etc... algo do tipo... realmente agora você me pegou... na hora do da agonia, o cliente ligando, só fiz reiniciar o servidor e tudo voltou ao normal... agora esse procedimento de processamento alto está sendo feito a noite e não tive mais o problema... mas pode voltar, não sei.

     

    3- Quem está conectado fica, os novos é que não conseguem.

     

    Acabei esquecendo de postar as versões.

     

    Windows 2003 Enterprise SP2

    SQL-Server 2005 SP2 (BUILD 3200)

     

    Como falei no email, é uma super máquina... o processamento no máximo chega a 5%... não tenho mais que 20 usuários simultâneos, não tem motivo pra negar...

     

    Tem um detalhe que acabei esquecendo de comentar que é importante. Um dos técnicos da loja que instalou o Windows 2003, e a instalação não foi do modo normal, foi usando aqueles CDs de pré-instalação do Windows da DELL... no momento da instalação ele errou e colocou a licença "PER USER"... até postei a pergunta no technet sobre SERVER para ver se tinha como reverter.. falaram que não... mas tentei, deu certo, coloquei PER SERVER e a quantidade de terminais... aparentemente tá ok! isso fiz ontem a tarde... vou ver se mais alguém reclama... não sei se essa configuração que estava errada influencia na quantidade de usuários do SQL... ou quantidade de conexões TCP na rede... etc.

     

    Obrigado pela ajuda.

     

     

    sexta-feira, 4 de julho de 2008 11:34
  • Bom dia Junior!

     

    Na mensagem que respondi ao Romulo tem mais detalhes.

     

    Como falei, na hora da pressão, só fiz reiniciar o servidor... não cheguei a ver esses detalhes... aconteceu 2 vezes, não se repetiu mais... fiz o procedimento de alteração de modo de licença conforme detalhado na respostaao Romulo... pode ser que resolva... vou ficar analisando.

     

    Na hora que abri esse tópico vi também o fórum sobre SQL do MSDN, aparentemente lá tá mais ativo que aqui... postei a mesma pergunta lá... (sei que o local correto é aqui).. o Gustavo Maia me indicou ver as seguintes estatísticas:

     

    MSSQLServer:General Statistics:User Connections
    MSSQLServer:General Statistics:Logical Connections
    MSSQLServer:General Statistics:Logins/sec
    MSSQLServer:General Statistics:Logout/sec

     

    Vou esperar o problema se repetir (espero que não se repita), e analiso com mais detalhes.

     

    Abraço,

    sexta-feira, 4 de julho de 2008 11:37
  • Welkson,

     

    Este detalhe que voê havia se esquecido com certeza é muito importante, e possivelmente era o causador deste problemas, pois esta limitando o seu servidor a trabalhar com uma quantidade de acesso por usuário.

    sexta-feira, 4 de julho de 2008 11:39
    Moderador
  • Obrigado a todos pela resposta!

     

    Já marquei as respostas como útil.

     

    Abraço,

     

    sexta-feira, 4 de julho de 2008 12:07
  • Welkson,

     

    Obrigado pelo retorno.

    sexta-feira, 4 de julho de 2008 12:32
    Moderador