none
Problemas com o Outlook Anywhere RRS feed

  • Pergunta

  • Oi,

     

    Estou com problemas em habilitar o serviço do Outlook Anywhere (antigo RPC over HTTP).
    O meu OWA funciona perfeitamente. A minha configuração é a seguinte:
    - Servidor Exchange 2007 (64 bits) rodando em cima do Windows Server 2008 (64 bits);
      Nome do servidor: myserver.mydomain.com.br
    - Servidor ISA 2006 rodando em cima de um Windows Server 2003 (32 bits);
      Publicação do Exchange: webmail.mydomain.com.br

    A seguir descrevo como gerei o meu certificado:
    [PS] C:\New-ExchangeCertificate -GenerateRequest -domainname webmail.mydomain.com.br,myserver,myserver.mydomain.com.br,mailhost2.mydomain.com.br,autodiscover.mydomain.com.br -FriendlyName "Webmail Certificate" -privatekeyexportableEmbarrassedtrue -path c:\cert_myserver.txt
    [PS] C:\Import-ExchangeCertificate -path c:\cert-myserver.cer
    [PS] C:\enable-ExchangeCertificate -thumbprint BB714A3BBC7B321B8FAAB0421F4EF803AB9F9500 -services "IIS,IMAP,POP"


    Saída de alguns comandos de testes:
    [PS] C:\Windows\System32>Get-ClientAccessServer | fl
    Name                           : MYSERVER
    OutlookAnywhereEnabled         : True
    AutoDiscoverServiceCN          : myserver
    AutoDiscoverServiceClassName   : ms-Exchange-AutoDiscover-Service
    AutoDiscoverServiceInternalUri :

                            https://myserver.mydomain.com.br/Autodiscover/Autodiscover.xml
    AutoDiscoverServiceGuid        : 77378f46-2c66-4aa9-a6a6-3e7a48b19596
    AutoDiscoverSiteScope          : {Default-First-Site-Name}
    IsValid                        : True
    OriginatingServer              : myserver.mydomain.com.br
    ExchangeVersion                : 0.1 (8.0.535.0)
    DistinguishedName              : CN=myserver,CN=Servers,CN=Exchange Administrative 

                                     Group (FYDIBOHF23SPDLT),CN=Administrative

                                     Groups,CN=MYDOMAIN,CN=Microsoft Exchange,

                                     CN=Services,CN=Configuration,DC=mydomain,DC=com,DC=br
    Identity                       : myserver
    Guid                           : fa6366ac-6824-4d0e-dede-4fe89a8c284c
    ObjectCategory                 : mydomain.com.br/Configuration/Schema/ms-Exch-Exc
                                     hange-Server
    ObjectClass                    : {top, server, msExchExchangeServer}
    WhenChanged                    : 8/30/2008 12:01:09 AM
    WhenCreated                    : 8/29/2008 9:30:06 PM


    [PS] C:\Windows\System32>Test-MapiConnectivity
    MailboxServer      Database           Result    Latency(MS) Error
    -------------      --------           ------    ----------- -----
    MYSERVER           Mailbox Database   Success            13


    [PS] C:\Windows\System32>Test-OutlookWebServices
         Id                       Type Message
         --                       ---- -------
       1003                Information About to test AutoDisc...
       1007                Information Testing server bavaria...
       1019                Information Found a valid AutoDisc...
       1006                Information The Autodiscover servi...
       1016                    Success [EXCH]-Successfully co...
       1015                    Success [EXCH]-Successfully co...
       1014                    Success [EXCH]-Successfully co...
       1016                Information [EXPR]-The AS is not c...
       1015                Information [EXPR]-The OAB is not ...
       1014                Information [EXPR]-The UM is not c...
       1017                    Success [EXPR]-Successfully co...
       1006                    Success The Autodiscover servi...

     

    Examinando os serviços habilitados reparei no seguinte:
    Remote Procedure Call (RPC)            Started   Automatic
    Remote Procedure Call (RPC) Locator    -------   Manual
    RPC/HTTP Load Balancing Service        -------   Manual

     

    Não sei se isso está correto ou não.

     

    Em relação ao resto não vejo nada de errado, mas o outlook anywhere
    não funciona Sad
    Se rodar o comando "outlook /rpcdiag" dentro da minha rede apontando
    para o ISA server (webmail.mydomain.com.br) mostra que minha conexão
    foi TCPIP e não HTTP(S) para o meu servidor myserver.mydomain.com.br.
    Fora da minha rede não funciona nada Sad

    O que está errado e como posso consertar?

     

    Um abraço,
    Bibo

    sexta-feira, 10 de outubro de 2008 11:49

Respostas

  • tem uma caixa aqui em cima que permite procurar no histórido do forum.

     

    Aqui vem a situaçao se tu tem um certificado chamado xx.com.br tem que verificar se a tua maquina interna pinga xx.com.br e é o exchange e nao o ISA.

     

    Se nao conseguir troca o hosts file da tua maquina para xx.com.br apontando para o ip interno do exchange, ai configura o cliente outlook para conectar em redes rapidas via http as well. Ai abre o Outlook com /rpcdiag ou ainda botao direito e olha as comunicacao, vai estar https (digo isso pq nao tem muio o que errar no exchange 2007.

     

     

     

    sexta-feira, 10 de outubro de 2008 16:48
  • Opa Bibbo,

     

    blz? Testa que derrepente tuas duvidas já sao respondidas Smile , o nome nao importa contando que o outlook anywhere e o certificado tenham omesmo certificado e estejam instalados.

     

    faz o teste acredito que vai trafegar https internamente, mas garante que a configuracao do outlook está jogando para o server interno.

     

     

     

    sexta-feira, 10 de outubro de 2008 17:42
  • Oi,

     

    Reparei que o outlook só se conecta via HTTPS quando ele confia no certificado. Eu fiz dois testes e analisando o resultado pelo "outlook /rpcdiag" reparei o seguinte:

    1- máquina no dominio se conectando diretamente ao Exchange: conectou via HTTPS;

    2- máquina fora do dominio se conectando diretamente ao Exchange: só se conecta via TCPIP. Depois que importei o certificado do meu CA (que fica com o meu AD) aí sim ele se conectou via HTTPS.

     

    []´s,

    Bibo

     

     

     

     

    segunda-feira, 13 de outubro de 2008 18:28
  • Oi,

     

    Apenas para fechar, o que eu estava confundindo é que apesar de externamente o meu servidor exchange ser acessado pelo endereço do ISA (webmail...) eu tinha que colocar no item "Microsoft Exchange Server" o nome do meu servidor exchange (myserver...) e nào o nome do ISA (webmail....). Este nome (webmail...) só deveria estar na configuração do "Exchange Proxy Settings".

     

    Obrigado pela ajuda,

     

    Um abraço,

    Bibo

     

     

    sábado, 18 de outubro de 2008 16:29

Todas as Respostas

  •  

    Ola bibo,

     

    Chegou a olhar o histórico? O Mapi-connectivity nao vai te ajduar em nada neste caso, primeiro marca para usar o rpc over http em redes rapidas, se connectar http internamente tu sabe que o problemna nao é exchange, ai tem o forum de isa para te ajudar (provavel).

     

    sexta-feira, 10 de outubro de 2008 12:08
  •  

    Oi Anderson,

     

    Histórico??? Aonde posso verificar isso?

    Eu estou tentando separar o problema em duas partes:

    1- acessando diretamente o mey servidor (myserver.mydomain.com.br);

    2- acessar via ISA Server 2006.

     

    Eu configurei o meu outlook para acessar diretamente via rpc/http no meu servidor (myserver.mydomain.com.br) e usando o "outlook /rpcdiag" mostra que na verdade ele se conectou via TCPIP e não HTTPS como deveria.

    Acho que o problema ainda está no Exchange.

     

    Um abraço,

    Bibo

     

    sexta-feira, 10 de outubro de 2008 16:42
  • tem uma caixa aqui em cima que permite procurar no histórido do forum.

     

    Aqui vem a situaçao se tu tem um certificado chamado xx.com.br tem que verificar se a tua maquina interna pinga xx.com.br e é o exchange e nao o ISA.

     

    Se nao conseguir troca o hosts file da tua maquina para xx.com.br apontando para o ip interno do exchange, ai configura o cliente outlook para conectar em redes rapidas via http as well. Ai abre o Outlook com /rpcdiag ou ainda botao direito e olha as comunicacao, vai estar https (digo isso pq nao tem muio o que errar no exchange 2007.

     

     

     

    sexta-feira, 10 de outubro de 2008 16:48
  • Ok vou testar.

     

    Mas fiquei com uma dúvida, o certificado que gerei tem o nome do ISA (webmail.mydomain.com.br), o nome do servidor exchange (myserver.mydomain.com.br) e outros DNS alternativos. Nesse caso o certificado vale para as duas máquinas ISA e Exchange. Com isso o Outlook Anywhere não deveria estar funcionando? Ou o que vale é o primeiro nome da lista? O meu DNS está configurado para: webmail alias do ISA e myserver o servidor Exchange.

     

    Um abraço,

    Bibo

     

     

    sexta-feira, 10 de outubro de 2008 17:17
  • Opa Bibbo,

     

    blz? Testa que derrepente tuas duvidas já sao respondidas Smile , o nome nao importa contando que o outlook anywhere e o certificado tenham omesmo certificado e estejam instalados.

     

    faz o teste acredito que vai trafegar https internamente, mas garante que a configuracao do outlook está jogando para o server interno.

     

     

     

    sexta-feira, 10 de outubro de 2008 17:42
  • Oi,

     

    Internamente funcionou, nem precisei mudar o hosts Smile

     

    Agora vou testar externamente.

     

    Um abraço,

    Bibo

     

     

    segunda-feira, 13 de outubro de 2008 15:48
  • Ola Bibbo,

     

    Se internamente funcionou então agora basicamente é validar firewall.

     

    Abs.

     

    segunda-feira, 13 de outubro de 2008 16:14
  • Oi,

     

    Reparei que o outlook só se conecta via HTTPS quando ele confia no certificado. Eu fiz dois testes e analisando o resultado pelo "outlook /rpcdiag" reparei o seguinte:

    1- máquina no dominio se conectando diretamente ao Exchange: conectou via HTTPS;

    2- máquina fora do dominio se conectando diretamente ao Exchange: só se conecta via TCPIP. Depois que importei o certificado do meu CA (que fica com o meu AD) aí sim ele se conectou via HTTPS.

     

    []´s,

    Bibo

     

     

     

     

    segunda-feira, 13 de outubro de 2008 18:28
  • Ola Bibbo,

     

    Correto, é exatamente assim que funciona.

     

    Abs.

     

    segunda-feira, 13 de outubro de 2008 18:33
  • Oi,

     

    Apenas para fechar, o que eu estava confundindo é que apesar de externamente o meu servidor exchange ser acessado pelo endereço do ISA (webmail...) eu tinha que colocar no item "Microsoft Exchange Server" o nome do meu servidor exchange (myserver...) e nào o nome do ISA (webmail....). Este nome (webmail...) só deveria estar na configuração do "Exchange Proxy Settings".

     

    Obrigado pela ajuda,

     

    Um abraço,

    Bibo

     

     

    sábado, 18 de outubro de 2008 16:29
  •  

    Ola Bibbo,

     

    marca os posts que te ajudaram a chegar na soluçao tb, mas o nome do isa só aparece na configuraçao do rpc over http, nao no servidor de exchange (mapi).

     

     

    sábado, 18 de outubro de 2008 18:25
  • Oi Anderson,

     

    Feito. Eu não sabia que podia marcar mais de uma.

     

    Obrigado pela força,

    Bibo

     

     

    terça-feira, 21 de outubro de 2008 11:48