none
LOCALPORT de impressão desaparece do server TS RRS feed

  • Discussão Geral

  • Estou com um problema no TS do windows server 2016 e 2019, já testei nos dois. Tenho algumas impressoras instaladas por localport, que estão compartilhadas em maquinas com Windows 10 ligadas via VPN.

    O que acontece é que essas portas desaparecem na lista de portas das propriedades da impressora e no gerenciador de impressão do MMC, assim a impressora para de imprimir. Porém se eu tento adicionar de novo a porta, ele da erro falando que a porta já existe. quando vejo no Regedit as portas estão lá.

    já recriei o servidor com windows server 2016 e 2019, atualizados e registrados corretamente e os erros continuam a acontecer nas duas versões.

    não tenho ideia do que pode estar causando isso, alguém tem alguma luz?

    terça-feira, 11 de agosto de 2020 12:24

Todas as Respostas

  • Olá Cleisson,

     

    Obrigada por participar da Comunidade TechNet.

     

    Com relação a sua consulta, nessas versões do Windows Server (2016 e 2019) as configurações de RDP são controladas na Diretiva de Grupo.

     

    Inicie o ” gpedit.msc “.

    Navegue para ” Configuração do computador “> ” Modelos administrativos “> ” Componentes do Windows “> ” Serviços da área de trabalho remota “> ” Host da sessão da área de trabalho remota “.

    Expanda ” Redirecionamento de impressora “.

    Verifique se “ Não permitir redirecionamento de impressora cliente ” está definido como “ Não configurado ” ou “ Desativado ”. Outra configuração que você pode querer verificar é a ” Redirecionar apenas a impressora cliente padrão “. Essa política também deve ser definida como ” Não configurado ” ou ” Desativado ” se você desejar que mais do que apenas a impressora padrão esteja disponível para uso.

     

    Verifique também se os drivers estão atualizados e instalados no servidor:

    Verifique se os drivers da impressora que você está tentando usar estão instalados no computador ao qual você está se conectando. Se os drivers não estiverem instalados no computador ao qual você está se conectando, a impressora não aparecerá.

    Abaixo te deixo mais informação e uma thread similar ao assunto relatado na pergunta, espero que te ajude.

     

    https://social.technet.microsoft.com/Forums/pt-BR/00bf5ea3-2b03-4af5-b9d1-6cc7bdc83b53/problemas-com-impresso-via-terminal-service?forum=winsrv2008pt

     

    https://support.microsoft.com/pt-br/help/302361/printers-that-use-ports-that-do-not-begin-with-com-lpt-or-usb-are-not

     

    Sinta-se a vontade para consultar qualquer dúvida referente aos produtos Microsoft. Será um prazer ajudar-te.

     

    Obrigada.

     

    Camila Brito

    ____________________________________________________________________________

    Por favor lembre-se de "Marcar como resposta" as respostas que solucionaram seu problema, é uma forma comum de reconhecer aquelas pessoas que te ajudaram, e faz com que seja mais fácil para os outros visitantes encontrar a solução depois.

     

    Microsoft oferece esse serviço de forma gratuita, com a finalidade de ajudar os usuários e ampliar a base de dados de conhecimentos relacionados com os produtos e tecnologias de Microsoft.

     

    Este conteúdo é proporcionado "tal qual" e não implica nenhuma responsabilidade por parte de Microsoft.

    quarta-feira, 12 de agosto de 2020 19:08
    Moderador
  • Oi camila obrigado pela resposta.

    eu conferi os itens e estão desativados. não estou usando a impressora redirecionada pela sessão.

    o cenário é o seguinte:

    - na maquina do cliente tem uma impressora instalada via USB, e esta está compartilhada. esta maquina faz uma VPN para o servidor de TS.

    - No servidor instalo como impressora local com LOCAL PORT. apontando para \\ip_da_vpn\compartilhamento.  

    Quando acabo de configurar a porta de impressão fica listada nas propriedades da impressora.  um tempo depois quando entro nas propriedades dessa mesma impressora, a porta não esta na lista mais.  e se eu tento adicionar a mesma porta, recebo notificação de que a porta já existe.

    Quando vou verificar no REGEDIT, a porta está exibindo como configurada na impressora, mas a impressora não imprime.

    o que estou fazendo por hora é mudar o nome do compartilhamento e criando nova porta. mas preciso solucionar.

     

    quinta-feira, 3 de setembro de 2020 18:06