none
Comparação de colunas retornando um valor caso sejam campos iguais, RRS feed

  • Pergunta

  • Bom Dia

    Necessito, comparar duas colunas númericas entre planilhas porém uma dessas colunas é menor do que a outra o resultado desta comparação deve aparecer na planilha um.

    Exemplo:

    Planilha a       Planilha b      Colunax Planilha a

    10                10                        ok

    11                23

    12                50             

    13               13                        ok

    14               14                       ok

    15              20

    16              30

    17              17                      ok

     

    Tentei utilizar uma função lógica porém com a quantidade de números em diferentes palnilhas a função retornou erro.

    Por gentileza algúem poderia me ajudar ?

    sábado, 17 de novembro de 2012 14:41

Respostas

  • @Omar

    Cole essa fórmula na célula B1. Em seguida, com a célula B1 selecionada, pressione Ctrl+C.

    Então, selecione, por exemplo, o intervalo B2:B10 e pressione Ctrl+C. Observe que o Excel irá ajustar automaticamente as referências para as outras linhas e então a fórmula funcionará para todas essas linhas.


    Felipe Costa Gualberto - http://www.ambienteoffice.com.br

    segunda-feira, 19 de novembro de 2012 20:31

Todas as Respostas

  • Estimado Omar Lopes:

         Tenta isto:

    = SE(Sheet1!A1=Sheet2!A1;"OK";"")

    Nota: Os dados estão na coluna "A", nas dois folhas. Cola esta função na fila um.

    Atte.

    Rafael

    domingo, 18 de novembro de 2012 14:56
  • Bom Dia

    Gostaria de agradecer sua ajuda, foi de grande auxílio porém a fórmula apenas realiza a ação na primeira linha as demais linhas assume que não houve conferência.

    = SE(Sheet1!A2=Sheet2!A2;"S";"N")

    Gostaria de incluir algum parametro que indicasse que a consulta deve continuar na linha de baixo.

    Obrigado.

    Atenciosamente.

    segunda-feira, 19 de novembro de 2012 12:46
  • Bom Dia

    Gostaria de agradecer sua ajuda, foi de grande auxílio porém a fórmula apenas realiza a ação na primeira linha as demais linhas assume que não houve conferência.

    = SE(Sheet1!A2=Sheet2!A2;"S";"N")

    Gostaria de incluir algum parametro que indicasse que a consulta deve continuar na linha de baixo.

    Obrigado.

    Atenciosamente.


    segunda-feira, 19 de novembro de 2012 17:50
  • @Omar

    Cole essa fórmula na célula B1. Em seguida, com a célula B1 selecionada, pressione Ctrl+C.

    Então, selecione, por exemplo, o intervalo B2:B10 e pressione Ctrl+C. Observe que o Excel irá ajustar automaticamente as referências para as outras linhas e então a fórmula funcionará para todas essas linhas.


    Felipe Costa Gualberto - http://www.ambienteoffice.com.br

    segunda-feira, 19 de novembro de 2012 20:31
  • Olá Omar,

    Você pode usar a seguinte função:  =SE(A1=Plan2!A1;"ok";"N")

    Explicação:

    =SE(A1 (valor da primeira planilha) = Plan2!A1 (É o valor da segunda planilha que será comparado com a célula A1 da primeira planilha) ; "OK" (caso o valor for igual) ; "N" (caso o valor não for igual))

    Fazendo dessa forma você pode usar a alça de preenchimento do Excel para copiar os resultados para o restante dos valores.

    segunda-feira, 26 de novembro de 2012 17:34