none
Servidores virtualizados com baixo desempenho RRS feed

  • Pergunta

  • Senhores,

    Meu cliente usava um servidor de arquivos e aplicações improvisado, era um micro montado com CPU Pentium dual core, rodando windows server 2008 e tinha um desempenho razoável. O cliente adquiriu um server de linha, com processador Xeon quad Core, 8 GB de memória, e 2 volumes raid 0, sendo um para C e outro para D, e Dual Giga Lan.

    Como a licença do Windows Server 2012 R2 da direito a 2 virtualizações licenciadas, resolvemos implementar o seguinte cenário:

    Hyper-V Server 2012 R2 como Host, 2 VMs uma rodando Server 2012 R2 como Domain Controles e a segunda com Server 2012 R2 rodando Data Server e Aplicações, com os seguintes detalhes:

    AD: Memória: 3072 mb (Memória Dinâmica ativada), Rede: Externa em Switch Gigabit, Disco VHDX,

    Data Server: 4092 MB (Memória Dinâmica Ativada), Rede Externa em Switch Gigabit, 2 Disco VHDX (1 para sistema, outro para dados)

    Porém o desempenho ficou horrível, alguém sabe me dizer o que fiz errado, tentei usar desativar o recurso de memória dinâmica, tentei mudar o disco de dados para um disco físico via direct attach, mas, ainda assim o desempenho não melhorou.

    Gostaria de sugestões sobre o que poderia fazer para melhorar o desempenho dos servers virtuais, ou o diagnostico de que o meu server tem hardware insuficiente para virtualizar 2 servers para uma pequena empresa com menos de 10 micros.


    Leandro Redivo Aracruz/ ES

    sexta-feira, 20 de junho de 2014 13:09

Respostas

  • Leandro.

    Veja abaixo:

    http://www.andersonpatricio.org/configurando-nic-teaming-no-windows-server-2012/


    Att, Paulo Rocha MCP | MCDST | MCSA Server 2012

    domingo, 22 de junho de 2014 16:59
  • Boa Tarde,

    Use o Monitor de Recursos para validar quem está causando problemas de desempenho, se possível use uma placa de rede só para esse servidor de aplicação e monitore.

    só um detalhe, você está usando Raid-0 mesmo, ou está usando mirror de discos?
    sexta-feira, 20 de junho de 2014 19:48
  • Leandro.

    Não me parece ser problema de Hardware, ainda mais se são menos de 10 micros.

    Como o colega Jamerson mencionou, era bom utilizar o Monitor de Recursos (perfmon.exe) para monitorar o desempenho.

    Você configurou o espaço em disco das .vhdx para ser fixo ou dinâmico? O dinâmico é consideravelmente mais lento do que o fixo.

    Em relação às placas de rede, configure um NIC team.

    Opte também por uma instalação Core que deverá melhorar bastante o desempenho.


    Att, Paulo Rocha MCP | MCDST | MCSA Server 2012

    sábado, 21 de junho de 2014 16:40

Todas as Respostas

  • Bom dia,

    Primeiro, você pode considerar o uso de particionamento dos discos do servidor, separe o sistema operacional do Hyper-V do local onde as Máquinas Virtuais serão hospedadas, 2 GB de RAM para o controlador de domínio deve ser suficiente para ele rodar com bom desempenho se só a função ADDS está instalada, aumente a quantidade de processadores para a máquinas de aplicações e use o monitor de recursos para ver o que está causando o mau desempenho se ainda acontecer se é o acesso a disco, processamento, ou pouca memória RAM

    sexta-feira, 20 de junho de 2014 17:38
  • Bom dia,

    Primeiro, você pode considerar o uso de particionamento dos discos do servidor, separe o sistema operacional do Hyper-V do local onde as Máquinas Virtuais serão hospedadas, 2 GB de RAM para o controlador de domínio deve ser suficiente para ele rodar com bom desempenho se só a função ADDS está instalada, aumente a quantidade de processadores para a máquinas de aplicações e use o monitor de recursos para ver o que está causando o mau desempenho se ainda acontecer se é o acesso a disco, processamento, ou pouca memória RAM

    O Hyper-v server está numa partição isolada de 60 gb, as maquinas virtuais e dos dados estão em partições separadas.

    O ADDS está sozinho em uma VM, sem aplicações ou dados rodando em conjunto.

    O DATASERVER esse está em uma vm com 2 VHDX, 1 para sistema, outro para dados.

    Não poderia ser a configuração de placas de rede que está gerando gargalo?

     

    Leandro Redivo Aracruz/ ES

    sexta-feira, 20 de junho de 2014 17:43
  • Boa Tarde,

    Use o Monitor de Recursos para validar quem está causando problemas de desempenho, se possível use uma placa de rede só para esse servidor de aplicação e monitore.

    só um detalhe, você está usando Raid-0 mesmo, ou está usando mirror de discos?
    sexta-feira, 20 de junho de 2014 19:48
  • Boa Tarde,

    Use o Monitor de Recursos para validar quem está causando problemas de desempenho, se possível use uma placa de rede só para esse servidor de aplicação e monitore.

    só um detalhe, você está usando Raid-0 mesmo, ou está usando mirror de discos?
    Desculpe o equivoco estou com 2 volumes raid 1, um espelhamento menor onde esta a a partição do Hyper-v e uma segunda partição onde estão os discos virtuais de C dos 2 servidores VM, e um segundo espelhamento maior onde está o VHD de dados.

    Leandro Redivo Aracruz/ ES

    sexta-feira, 20 de junho de 2014 21:32
  • Leandro.

    Não me parece ser problema de Hardware, ainda mais se são menos de 10 micros.

    Como o colega Jamerson mencionou, era bom utilizar o Monitor de Recursos (perfmon.exe) para monitorar o desempenho.

    Você configurou o espaço em disco das .vhdx para ser fixo ou dinâmico? O dinâmico é consideravelmente mais lento do que o fixo.

    Em relação às placas de rede, configure um NIC team.

    Opte também por uma instalação Core que deverá melhorar bastante o desempenho.


    Att, Paulo Rocha MCP | MCDST | MCSA Server 2012

    sábado, 21 de junho de 2014 16:40
  • PauloTem algum link de material sobre a criação deste NIC Team?

    Leandro Redivo Aracruz/ ES

    sábado, 21 de junho de 2014 16:53
  • Leandro.

    Veja abaixo:

    http://www.andersonpatricio.org/configurando-nic-teaming-no-windows-server-2012/


    Att, Paulo Rocha MCP | MCDST | MCSA Server 2012

    domingo, 22 de junho de 2014 16:59
  • Normalmente é rede o problema, não era pra acontecer isso, tecnicamente é simples montar um server com VMs e achar que tudo vai ser fácil, aí vem esses problemas pra atrapalhar.

    Em questão Hardware 8gb é fácil dar uma paginação, mas se o problema não for discos lentos que dá até medo. Aqui com SSD, 16gb Ram e placa dedicada dava muita lentidão no Sped em VMs XP, com 2gb fixo de RAM e rede era lenta do mesmo jeito PRA TRANSFERÊNCIA de dados. Mesmo sendo SSD as vezes travava o remoto que pessoal usava, desisti de usar XP com SPED. Mas verifica se os discos não estão a 100% tempo todo.

    ___________________

    André Novello - Blog - MCP MCTS Server e Desktop Virtualization - MVP 2014 Hyper-V 

    terça-feira, 24 de junho de 2014 12:34
  • Leandro,

    Tenta usar uma configuração de discos mais eficiente na parte dos discos de VMs que pode lhe ajudar, eu geralmente uso Raid-5, já que o mirror tem demora na escrita por escrever nos dois discos.

    quarta-feira, 25 de junho de 2014 14:08
  • BELEZA

    Jamerson F Costa Silva  ao usar uma raid 5 não fica mais lento a gravação, pois tenho servidor PowerEdge R630

    6 dis 300 15 k tenho raid 1  dois disco uma raid 10 5 maquinas virtual uma das maquinas tem um consumo melhor o que vc acha


    Isaias

    domingo, 16 de outubro de 2016 12:23