none
Erro em campo calculado do Project Server 2010 RRS feed

  • Pergunta

  • Pessoal,

    criei um campo calculado do tipo número, chamado SomaPrazo, por exemplo.

    SomaPrazo = [Nível da Estrutura de Tópicos]

    Entretanto no PWA aparece sempre 0 no campo X, independente do nível, conforme figura abaixo.

    Interessante que o mesmo projeto aberto pelo project pro apresenta os resultados corretamente, conforme figura abaixo.

    Alguém já passou por isso?

    Sabe como resolver?

    Obrigado.


    Paulo Alves Jr. PMP, MBA, ITILv3, MCTS
    http://www.pejota.net
    Twitter: @pejota81

    terça-feira, 27 de novembro de 2012 12:31

Todas as Respostas

  • Fiz uma simulação em um arquivo do project pro desconectado do server e também ficou correto, conforme figura abaixo.

    O que me leva a crer que é um bug do project server.

    Será que é isso mesmo?


    Paulo Alves Jr. PMP, MBA, ITILv3, MCTS
    http://www.pejota.net
    Twitter: @pejota81

    terça-feira, 27 de novembro de 2012 12:33
  • Olá Paulo, boa tarde.

    Você chegou a verificar no campo do Project Server 2010 onde esta fórmula está armazenada senão ocorreu nenhum erro na estrutura da fórmula?

    Verifique estas opções:

    Tentou republicar novamente o cronograma?

    Você está com os services packs do Project Professional 2010 e Project Server 2010 devidamente instalados?

    Espero ter ajudado.


    Hezequias Vasconcelos

    terça-feira, 27 de novembro de 2012 14:34
    Moderador
  • Olá, Hezequias.

    É independente das configurações, porque funciona no Project Professional com as mesmas configurações que estão marcadas no Server.

    Estou com o CU de Junho. Vou atualizar com o de Outubro pra ver se resolve.


    Paulo Alves Jr. PMP, MBA, ITILv3, MCTS
    http://www.pejota.net
    Twitter: @pejota81

    terça-feira, 27 de novembro de 2012 15:52
  • Hezequias,

    instalei o Update de Outubro/2012 e continua com o mesmo comportamento.

    Alguma pista do que fazer?

    Obrigado.


    Paulo Alves Jr. PMP, MBA, ITILv3, MCTS
    http://www.pejota.net
    Twitter: @pejota81

    segunda-feira, 3 de dezembro de 2012 18:16
  • Olá Paulo, boa tarde.

    As configurações recomendadas pela Microsoft para o cálculo de tarefas resumo no Project professional 2010 é:

    Arquivo - Opções - Cronograma - Cálculo. Verifique se esta opção encontra-se ativado.

    Existe uma chave de registro no Project que era utilizada no MS-Project 2007 onde a chave de registro era utilizada para corrigir o problema, tente adaptar a sua necessidade e veja se funciona. O material abaixo descreve o procedimento.

    Referência Microsoft:

    http://blogs.msdn.com/b/project/archive/2007/12/06/display-the-project-summary-task-by-default.aspx

    Não tive tempo hábil para testar então minha recomendação é fazer um teste em ambiente de desenvolvimento ou laboratório.

    No Kb de Junho de 2012 ele já corrigiu um problema relacionado a tarefas resumo do Project Server 2010, conforme descrito no hotfix.

    http://support.microsoft.com/kb/2598375

    http://support.microsoft.com/kb/312379

    Outro ponto que você pode verificar é ver nos logs do visualizador de eventos do servidor de aplicação se é registrado algum log de erro relacionado a este problema.

    O sistema da fila está publicando os projetos normalmente?

    Caso sua empresa possua um contrato de suporte junto a Microsoft tente abrir um chamado para verificar o problema:

    http://support.microsoft.com/contactus/?ws=support

    As tarefas estão utilizando o modo de tarefa automático ou manual? Verifique está configuração tanto no Project Professional quanto no Project Server ambas as opções precisam estar com o tipo automático.

    http://technet.microsoft.com/en-us/library/gg982960(v=office.14).aspx

    Espero ter ajudado.


    Hezequias Vasconcelos

    segunda-feira, 3 de dezembro de 2012 18:54
    Moderador
  • Olá, Hezequias.

    Obrigado pelo seu tempo, mas infelizmente nada resolveu.

    Vou abrir o chamado na Microsoft.

    Creio que o problema é específico com o campo [Nível de Estrutura de Tópicos], porque fiz teste com outros campos do tipo número e o erro não apareceu.

    Só para constar como lições aprendidas:

    - No Project professional não aparece o bug;

    - Realmente o kb de junho corrige o problema da tarefa resumo, mas neste caso o bug é em todas as linhas;

    - O visualizador não apresenta nenhum erro relacionado a isso;

    - As tarefas estão em modo automático.


    Paulo Alves Jr. PMP, MBA, ITILv3, MCTS
    http://www.pejota.net
    Twitter: @pejota81

    segunda-feira, 3 de dezembro de 2012 19:41
  • Olá Paulo, bom dia.

    Conseguiu resolver o problema?

    Poderia compartilhar conosco a solução.


    Hezequias Vasconcelos

    quarta-feira, 27 de fevereiro de 2013 14:39
    Moderador