none
Acesso aos Reports sem ADM RRS feed

  • Pergunta

  • A situação é a seguinte:

    Tenho um ambiente Windows Server 2008 R2 e SQL Server 2008 R2 com Reporting Services instalado, sem usar o IIS.

     

    Consigo acessar os reports (http://server_name/reports e http://server_name/reportserver) perfeitamente, dentro ou fora do servidor, somente se a conta do usuário for Administrator da máquina do servidor. Caso contrário, retorna o erro:

     

    O usuário 'TERRA\user' não tem as permissões necessárias. Verifique se foram concedidas permissões suficientes e se as restrições do UAC (Controle de Conta de Usuário) do Windows foram atendidas.

     

    O objetivo é de os usuários acessarem de suas máquinas, com as contas de domínio normais (sem ser ADM), os reports publicados no servidor do SSRS.

     

    Qualquer ajuda será bem vinda.

     

    sexta-feira, 3 de dezembro de 2010 14:09

Respostas

  • Pessoal,

    Eu resolvi o problema, no meu caso, alterando a conta do serviço SQL Server Reporting Services (MSSQLSERVER) para Network Service.

    Além disso, adicionei os logins necessários dentro da opção "Segurança", nos reports publicados no Report Manager.

     

    Att, Sr. JOB

     

    • Marcado como Resposta Mr. Job sexta-feira, 7 de janeiro de 2011 19:47
    • Não Marcado como Resposta Mr. Job sexta-feira, 7 de janeiro de 2011 19:48
    • Marcado como Resposta Mr. Job sexta-feira, 7 de janeiro de 2011 19:48
    sexta-feira, 7 de janeiro de 2011 18:59

Todas as Respostas

  • Mr.Job,

    Você deseja liberar estes ferramentas de gerenciamento para seus usuários de domínio?

    Neste caso terá que configurar o IIS para liberar acesso a este diretório virtual, bem como, liberar as permissões de acesso ao próprio diretório existente fisicamente em seu servidor.


    Pedro Antonio Galvão Junior [MVP | Microsoft Evangelist | Microsoft Partner | Engenheiro de Softwares | Especialista em Banco de Dados | SorBR.Net | Professor Universitário | MSIT.com]
    sexta-feira, 3 de dezembro de 2010 18:37
  • Galvão,

    A ideia é liberar acesso a estes usuários somente para abrir / executar os reports.

    Consigo configurar o IIS com os diretórios virtuais já criados ou devo criar outros?

    Valeu...

     

     

     

     

     

    segunda-feira, 6 de dezembro de 2010 02:11
  • Mr.Job,

    Consegui sim configurar para os diretórios já criados.


    Pedro Antonio Galvão Junior [MVP | Microsoft Evangelist | Microsoft Partner | Engenheiro de Softwares | Especialista em Banco de Dados | SorBR.Net | Professor Universitário | MSIT.com]
    terça-feira, 7 de dezembro de 2010 18:41
  • Tá dando o mesmo erro

     

    O usuário 'User' não tem as permissões necessárias. Verifique se foram concedidas permissões suficientes e se as restrições do UAC (Controle de Conta de Usuário) do Windows foram atendidas.

     

    Este user é um usuário local da máquina.


    cleyde andrade
    quarta-feira, 15 de dezembro de 2010 17:10
  • Olá,

    como resolveste a situação? É que está-me a acontecer o mesmo.

    • Marcado como Resposta Mr. Job sexta-feira, 7 de janeiro de 2011 18:59
    • Não Marcado como Resposta Mr. Job sexta-feira, 7 de janeiro de 2011 19:47
    terça-feira, 4 de janeiro de 2011 17:11
  • Pessoal,

    Eu resolvi o problema, no meu caso, alterando a conta do serviço SQL Server Reporting Services (MSSQLSERVER) para Network Service.

    Além disso, adicionei os logins necessários dentro da opção "Segurança", nos reports publicados no Report Manager.

     

    Att, Sr. JOB

     

    • Marcado como Resposta Mr. Job sexta-feira, 7 de janeiro de 2011 19:47
    • Não Marcado como Resposta Mr. Job sexta-feira, 7 de janeiro de 2011 19:48
    • Marcado como Resposta Mr. Job sexta-feira, 7 de janeiro de 2011 19:48
    sexta-feira, 7 de janeiro de 2011 18:59
  • Prezados, está ocorrendo a mesma coisa comigo, já liberei o user na pasta que está o relatório, já add o mesmo no report e mesmo assim o report só roda quando digitado usuários adm. Está aparecendo o erro abaixo...ah já dei permissão no data source tb...caso alguém tenha alguma dica...desde já agradeço.

    • An error has occurred during report processing. (rsProcessingAborted)
      • Cannot create a connection to data source 'DataSource1'. (rsErrorOpeningConnection)
        • For more information about this error navigate to the report server on the local server machine, or enable remote errors

    weslesson
    domingo, 20 de março de 2011 03:40
  • Contribuindo na resposta, além do perfil na pasta criada para o relatório, é necessário perfil de "BROWSE" na pasta raiz, para que os usuários possam ver e navegar nas pastas dos relatórios.

    Recomento atribuir este perfil por grupo de AD, ou caso de ser um relatório publico pode ser atribuido para "dominio\Domain Users"

     

     

    Att,

    Alex

    segunda-feira, 24 de outubro de 2011 17:34
  • Boa noite,

    Tive o mesmo problema nessa versão R2 .

    So conseguia acesso com os users que eram administradores locais do servidor de banco de dados.

    Para resolver, abra o internet explorer entre na URL http://srvdereports/Reports na pagina principal clique em gerenciar pasta e adicione o  grupo DOMAIN\Usuários Autenticados que o problema é resolvido.

    Aguardo resposta,

    Att,

    sexta-feira, 24 de fevereiro de 2012 01:12
  • porque da este erro??

    O nome de usuário ou de grupo 'DOMAIN\Users' não foi reconhecido. (rsUnknownUserName) Obter Ajuda Online
    Página Inicial
    segunda-feira, 5 de março de 2012 14:49
  • Nao aparece nada. eu faço o deploy normalmente, mas depois quando abro o relatório, não aparece nada!!!

     Depis se fizer gurdar em pdf no segundo, aparece o reltario nesse mesmo pdf...

    como resolver?

    quarta-feira, 7 de março de 2012 12:25
  • TheAkaBroken,

    Se você estiver usando o Google Chrome tente com o Monzilla ou o Internet Explorer.

    quinta-feira, 18 de outubro de 2012 18:50
  • Verifique se o Agent do SQL Server está rodando na máquina.

    Se não, reinicie o Agent no "Services.smc".

    Eu fiz isso na máquina cliente e funcinou. 

    sábado, 19 de julho de 2014 23:51