none
Instalação do Framework 2.0 modo silencioso RRS feed

  • Pergunta

  • Alguém pode me ajudar?Coloque no program todas as linhas como /quiet /silence /q:a /c:"install /l /q"
    o status fica waiting e nada alguém sabe como me ajudar?
    quarta-feira, 16 de setembro de 2009 18:18

Respostas

  • Ola Carlos, posso dar uma dica?? testa antes em uma estação abre o commando e faz teste com os parametros.. da um *.exe /? e ve que que ele retorna... depois que voce tiver conseguido instalar silenciosamente de maneira certa o FrameWork ai voce passa o script pro sccm através de um programa com os parametros necessários. Abraço
    quarta-feira, 16 de setembro de 2009 20:45
  • Bom dia,

    como foi falado anteriormente, teste a linha de comando antes...

    qdo vc usa o /l, ele cria o arquivo netfx.log em %temp%, da 1 olhada nele pra ver o que pode estar acontecendo...

    pode ser ateh problema com os pre-requisitos.

    espero ter ajudado,
    Raphael - MCP/MCSA Security/MCSE Security/MCTS/MCITP/MCT - http://www.dotnetwork.com.br
    quinta-feira, 17 de setembro de 2009 08:09
    Moderador
  • Correto, o melhor jeito de mandar um pacote é testar a linha de comando antes. Mas o que eu estou achando estranho é estar em "Waiting". Se a linha estivesse errada ou solicitasse interação do usuário (next, next), o pacote ficaria em "Running" pois o executável estaria rodando.

    Eu acredito que o "Waiting" é devido á alguma configuração do pacote ou advertisement, como por exemplo dele estar configurado para rodar "Apenas quando o usuário estiver logado". Isso sim irá deixar o status como "Waiting", pois as condições ideais serão aguardadas para rodar o executável.

    Portanto, além de validar os parâmetros de instalação, verifique se:

     - As condições de execução estão de acordo. http://technet.microsoft.com/en-us/library/bb633096.aspx - Para 97% dos pacotes é usada a opção "Whether or not a user is logged on"

     - Configure um horário para o pacote rodar, não espere a ação do usuário. Caso tenha feito, garanta que a execução NÃO tenha sido programada para LOGON ou LOGOFF. Isso também causaria um "Waiting". - http://technet.microsoft.com/en-us/library/bb694124.aspx

    Não testei tudo isso, mas só acho que se fosse a linha (ou apenas ela) o pacote estaria como "Not Started", "Running" ou "Failed".

    []s
    Wesley Fernandes - ConfigMgr MVP - Blog: http://wesleey.spaces.live.com
    quinta-feira, 17 de setembro de 2009 13:30
    Moderador
  • Quando se quer uma instalação em modo silencioso não basta adicionar apenas o comando QUIET ou qualquer outro que o torne silencioso, você tem que prover também uma resposta automática para tudo que o programa pergunta durante a instalação, geralmente são demais argumentos em / ou até um arquivo de respostas. Sugestões:

     

    ·         Geralmente procuro no site do fabricante, pois isso está diretamente ligado ao software e não ao SCCM

    ·         Procuro por referências aqui http://www.appdeploy.com/

     

    Espero que isso ajude.

    Abraços e boa sorte,

     

    Cleber Marques

    Microsoft MVP & MCT | Charter Member: SCVMM & MDOP
    Projeto MOF Brasil: Simplificando o Gerenciamento de Serviços de TI
    Meu Blog | MOF.com.br | CleberMarques.com | CanalSystemCenter.com.br
    sexta-feira, 18 de setembro de 2009 15:45
    Moderador

Todas as Respostas

  • Você definiu alguma interação ou colocou o advertisement como mandatório?

    []s
    Wesley Fernandes - ConfigMgr MVP - Blog: http://wesleey.spaces.live.com
    quarta-feira, 16 de setembro de 2009 18:58
    Moderador
  • Opa Wesley não sei como fazer,vc pode me explicar melhor.mais qual linha de comando funciona?Voce sabe?
    quarta-feira, 16 de setembro de 2009 19:05
  • Ola Carlos, posso dar uma dica?? testa antes em uma estação abre o commando e faz teste com os parametros.. da um *.exe /? e ve que que ele retorna... depois que voce tiver conseguido instalar silenciosamente de maneira certa o FrameWork ai voce passa o script pro sccm através de um programa com os parametros necessários. Abraço
    quarta-feira, 16 de setembro de 2009 20:45
  • Bom dia,

    como foi falado anteriormente, teste a linha de comando antes...

    qdo vc usa o /l, ele cria o arquivo netfx.log em %temp%, da 1 olhada nele pra ver o que pode estar acontecendo...

    pode ser ateh problema com os pre-requisitos.

    espero ter ajudado,
    Raphael - MCP/MCSA Security/MCSE Security/MCTS/MCITP/MCT - http://www.dotnetwork.com.br
    quinta-feira, 17 de setembro de 2009 08:09
    Moderador
  • Correto, o melhor jeito de mandar um pacote é testar a linha de comando antes. Mas o que eu estou achando estranho é estar em "Waiting". Se a linha estivesse errada ou solicitasse interação do usuário (next, next), o pacote ficaria em "Running" pois o executável estaria rodando.

    Eu acredito que o "Waiting" é devido á alguma configuração do pacote ou advertisement, como por exemplo dele estar configurado para rodar "Apenas quando o usuário estiver logado". Isso sim irá deixar o status como "Waiting", pois as condições ideais serão aguardadas para rodar o executável.

    Portanto, além de validar os parâmetros de instalação, verifique se:

     - As condições de execução estão de acordo. http://technet.microsoft.com/en-us/library/bb633096.aspx - Para 97% dos pacotes é usada a opção "Whether or not a user is logged on"

     - Configure um horário para o pacote rodar, não espere a ação do usuário. Caso tenha feito, garanta que a execução NÃO tenha sido programada para LOGON ou LOGOFF. Isso também causaria um "Waiting". - http://technet.microsoft.com/en-us/library/bb694124.aspx

    Não testei tudo isso, mas só acho que se fosse a linha (ou apenas ela) o pacote estaria como "Not Started", "Running" ou "Failed".

    []s
    Wesley Fernandes - ConfigMgr MVP - Blog: http://wesleey.spaces.live.com
    quinta-feira, 17 de setembro de 2009 13:30
    Moderador
  • Quando se quer uma instalação em modo silencioso não basta adicionar apenas o comando QUIET ou qualquer outro que o torne silencioso, você tem que prover também uma resposta automática para tudo que o programa pergunta durante a instalação, geralmente são demais argumentos em / ou até um arquivo de respostas. Sugestões:

     

    ·         Geralmente procuro no site do fabricante, pois isso está diretamente ligado ao software e não ao SCCM

    ·         Procuro por referências aqui http://www.appdeploy.com/

     

    Espero que isso ajude.

    Abraços e boa sorte,

     

    Cleber Marques

    Microsoft MVP & MCT | Charter Member: SCVMM & MDOP
    Projeto MOF Brasil: Simplificando o Gerenciamento de Serviços de TI
    Meu Blog | MOF.com.br | CleberMarques.com | CanalSystemCenter.com.br
    sexta-feira, 18 de setembro de 2009 15:45
    Moderador
  • Pessoal, como ficamos por aqui com esta questão? Já temos algum status sobre se o problema foi resolvido ou não? Se sim, classifiquem o tópico, por favor.

     

    Abraços,

     

    Cleber Marques

    Microsoft MVP & MCT | Charter Member: SCVMM & MDOP
    Projeto MOF Brasil: Simplificando o Gerenciamento de Serviços de TI
    Meu Blog | MOF.com.br | CleberMarques.com | CanalSystemCenter.com.br
    quarta-feira, 7 de outubro de 2009 11:27
    Moderador
  • Estou marcando este tópico como respondido para manter a organização do fórum, caso for necessário tirar alguma dúvida relacionada sugiro a abertura de um novo post. J

     

    Abraços,

     

    Cleber Marques

    Microsoft MVP & MCT | Charter Member: SCVMM & MDOP
    Projeto MOF Brasil: Simplificando o Gerenciamento de Serviços de TI
    Meu Blog | MOF.com.br | CleberMarques.com | CanalSystemCenter.com.br
    quarta-feira, 7 de outubro de 2009 11:27
    Moderador