none
Erro Windows Installer RRS feed

  • Pergunta

  • Galera, Boa Noite. Estou tentando instalar o WSUS em um Servidor Windows Server 2003 Standart Edition e obtenho o erro:

    "There is a problem with this windows installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor"

    Ele me gera 02 logs de erro... Não mais o que fazer...

    Já fiz um Downgrade do sys para tentar realizar a instalação do Windows Installer em uma versão anterior...

    Já tentei instalar outra versão do WSUS. O servidor está em dia com as atualizações.

    Quando tento desinstalar o Windows Installer (msiexec -x) Obtenho o erro:

    This installation package could not be opened. Verify that the package existis and that you can access it, or contact the application vendor to verify that this is a valid windows installer package

    ** Já parei/iniciei o serviço (services.msc) / O Usuario é administrador.

     

     

    -- Alguma sugestão?



    sábado, 13 de agosto de 2011 23:16

Respostas

  • Gerson,

    A parte de falha na instalação do "wYukon" refere-se ao Windows Intrernal Database, onde fica atachada a base do WSUS.

    Tem algum Windows Internal Database instalado neste server ou consegue enxergá-lo no Windows Install Cleanup ?

    Se tiver, faça a remoção e tente novamente.

    Obrigado.


    Paul Haro - Microsoft Certified Professional
    • Marcado como Resposta Gerson Santos terça-feira, 16 de agosto de 2011 14:10
    terça-feira, 16 de agosto de 2011 12:10

Todas as Respostas

  • Amigo,

    O erro é apresentado ao tentar instalar qualquer aplicação, ou só com o WSUS ?

    Obrigado.


    Paul Haro - Microsoft Certified Professional
    segunda-feira, 15 de agosto de 2011 12:13
  • Olá Paul, somente durante a instalação do WSUS.

     

     

    No aguardo....

     

    Obrigado,



    segunda-feira, 15 de agosto de 2011 12:42
  • Faça o download do "Windows Install Cleanup".

    Execute e verifique na lista se existe alguma referência à instalação do WSUS.

    Em caso positivo, selecione o WSUS e remova-o através da ferramenta.

    Execute a instalação novamente e poste o resultado.

    Obrigado.


    Paul Haro - Microsoft Certified Professional
    segunda-feira, 15 de agosto de 2011 15:14
  • [EDITADO]

    Paul,

    Consegui rodar o  Windows Install Cleanup após reinstalação do Windows Installer 4.5....

     

    Não há nada relacionado ao WSUS na lista, vou tentar reinstalar novamente...

    Ao reinstalar, o WSUS obtive os erro abaixo no log:

    2011-08-15 13:19:34  Success   MWUSSetup          Validating pre-requisites...
    2011-08-15 13:19:34  Error     MWUSSetup          Failed to determine if an higher version of WSUS is installed.
    Assuming it is not... (Error 0x80070002: The system cannot find the file specified.)
    2011-08-15 13:19:34  Error     MWUSSetup          WSUS is outdated. But this will not block setup (Error 0x00000000: The operation completed successfully.)
    2011-08-15 13:19:47  Success   MWUSSetup          Initializing installation details
    2011-08-15 13:19:47  Success   MWUSSetup          Skipping Asp.Net install since not running on win2k3...
    2011-08-15 13:19:47  Error     MWUSSetup          wYukon install attempted on unsupported platform (Error 0x80004005: Unspecified error)
    2011-08-15 13:19:47  Error     MWUSSetup          CInstallDriver::PerformSetup: Installation of wYukon failed (Error 0x80004005: Unspecified error)
    2011-08-15 13:19:47  Error     MWUSSetup          CSetupDriver::LaunchSetup: Setup failed (Error 0x80004005: Unspecified error)


    Obrigado pela ajuda até o momento...

     


    segunda-feira, 15 de agosto de 2011 16:00
  • Gersontsc,

     

    Conforme o log apresentado, pode ser N coisas, mas verifique 2...

     

    Ativação do Windows + Acesso a Internet.

     

    []s

     


    Erick Albuquerque | Microsoft MVP
    MVP Profile | Twitter | Linkedin | http://iisbrasil.wordpress.com
    segunda-feira, 15 de agosto de 2011 21:53
    Moderador
  • Srs, Boa Noite.

    O Windows está ativado e o servidor está com acesso total a internet.

    ****

    Somente complementando... subi uma VM ontem, na mesma configuração, realizei a instalação do WSUS e tudo funcionou perfeitamente...

    O problema persiste no servidor.

    att,



    terça-feira, 16 de agosto de 2011 03:58
  • Gerson,

    A parte de falha na instalação do "wYukon" refere-se ao Windows Intrernal Database, onde fica atachada a base do WSUS.

    Tem algum Windows Internal Database instalado neste server ou consegue enxergá-lo no Windows Install Cleanup ?

    Se tiver, faça a remoção e tente novamente.

    Obrigado.


    Paul Haro - Microsoft Certified Professional
    • Marcado como Resposta Gerson Santos terça-feira, 16 de agosto de 2011 14:10
    terça-feira, 16 de agosto de 2011 12:10
  • Paul, Bom Dia...

    Usei o comando:

    "C:WINDOWSsystem32> lodctr /R"

    Realizei a reinstalação do Windows Installer... e limpeza do sistema (pela milesima vez).

    Após feito os procedimentos acima consegui instalar o WSUS ....

     

    Ao tentar atualizá-lo para a verão 3.0 tive mais dor de cabeça....

     

    2011-08-16 09:36:09  Error     MWUSSetup          wYukon install attempted on unsupported platform (Error 0x80004005: Unspecified error)
    2011-08-16 09:36:09  Error     MWUSSetup          CUpgradeDriver::PerformSetup: Installation of wYukon failed (Error 0x80004005: Unspecified error)
    2011-08-16 09:36:09  Error     MWUSSetup          CSetupDriver::LaunchSetup: Setup failed (Error 0x80004005: Unspecified error)

    ---

    Mesmo removendo o Windows Internal Database pelo Windows Install Cleanup o erro persiste...

     

    Realizando a reinstalação novamente....

     

    Obrigado desde já.

    Abs,


    terça-feira, 16 de agosto de 2011 12:36
  • Amigos, a primeira parte do problema foi resolvido... rs

    Consegui realizar a instalação do WSUS 2.0!

     

    Porém estou com dificuldades na atualização do mesmo....

     

    Alguem com disponibilidade para me ajudar? rs....

     

    Caso sim, contato: gerson.tsc@gmail.com (email/msn)

     

    Obrigado a todos!

     

    Att,

     

     

    terça-feira, 16 de agosto de 2011 14:10
  • Gerson, vc está com dificuldades para configuração?

     

    De qualquer forma estou movendo está thread para o fórum de Wsus.

     

    []s


    Erick Albuquerque | Microsoft MVP
    MVP Profile | Twitter | Linkedin | http://iisbrasil.wordpress.com
    terça-feira, 16 de agosto de 2011 14:12
    Moderador
  • Erick, Bom dia....

    Em questão, a configuração já está ok...

    Somente obtenho o erro ao tentar realizar a atualização do mesmo para a versão 3.0...

     

    Devo criar um novo tópico ou posso postar aqui mesmo??


    Obrigado,

     

    terça-feira, 16 de agosto de 2011 14:18
  • Seria melhor!

     

    []s


    Erick Albuquerque | Microsoft MVP
    MVP Profile | Twitter | Linkedin | http://iisbrasil.wordpress.com
    terça-feira, 16 de agosto de 2011 14:20
    Moderador
  • Vou criar um novo tópico!

    Obrigado pela ajuda!

     

     

    abs,

    terça-feira, 16 de agosto de 2011 14:21