none
Windows Update parou (Erro 0x80070006) RRS feed

  • Pergunta

  • Boa tarde pessoal..

    Tenho uma VM do Server 2016 Datacenter em produção sendo DC2 secundário, e a mesma começou a aparecer este erro quando tento entrar no Windows Update vejam:

    Tentei algumas coisas antes de postar aqui no fórum, como:

    SFC / SCANNOW -> sendo que a saída disto foi que ele não conseguiu corrigir em totalidade os arquivos corrompidos.

    Tentei ir painel de controle / soluções de problemas / sistema e segurança e Windows update e:

    Mesmo assim o erro no Windows Update segue. Tentei agora o comando Dism como :

    Dism /Online /Cleanup-Image /CheckHealth

    Dism /Online /Cleanup-Image /ScanHealth

    Dism /Online /Cleanup-Image /RestoreHealth

    E não obtive sucesso, alias, os dois últimos comandos acima, travam e nem começa a verificar, muito menos aparece porcentagem e isso achei estranho vejam:

    Imagino que o problema pode estar por aí mesmo mas não consigo resolver. Sei que tem como restaurar o install.win da imagem baixada do Windows mas não sei como fazer..

    Alguém tem alguma luz? 

    Att

    terça-feira, 5 de junho de 2018 19:46

Respostas

  • Outra possível solução seria reconfigurar os privilégios no WUA, para que ele possa chamar um método chamado ZwOpenProcess(). Experimente executar este comando curtinho e reiniciar o servidor:

    sc privs wuauserv SeAssignPrimaryTokenPrivilege/SeAuditPrivilege/SeBackupPrivilege/SeChangeNotifyPrivilege/SeCreateGlobalPrivilege/SeCreatePagefilePrivilege/SeCreatePermanentPrivilege/SeCreateSymbolicLinkPrivilege/SeDebugPrivilege/SeImpersonatePrivilege/SeIncreaseBasePriorityPrivilege/SeIncreaseQuotaPrivilege/SeIncreaseWorkingSetPrivilege/SeLoadDriverPrivilege/SeLockMemoryPrivilege/SeManageVolumePrivilege/SeProfileSingleProcessPrivilege/SeRestorePrivilege/SeSecurityPrivilege/SeShutdownPrivilege/SeSystemEnvironmentPrivilege/SeSystemProfilePrivilege/SeSystemtimePrivilege/SeTakeOwnershipPrivilege/SeTcbPrivilege/SeTimeZonePrivilege/SeUndockPrivilege

    Testei em uma vm WS2016 e o retorno foi "[SC] ChangeServiceConfig2 SUCCESS".

    Olá amigo.

    Eu copiei e colei exatamente este comando curtinho bem como vc falou (rsrsr) e o retorno não computou veja:

    Execute o comando curtinho no CMD
    • Marcado como Resposta IgorFKModerator segunda-feira, 11 de junho de 2018 19:26
    segunda-feira, 11 de junho de 2018 17:30
    Moderador

Todas as Respostas

  • Olá Marcelo!

    Isto pode estar acontecendo devido ao fato do WUA estar rodando no seu próprio SVCHOST.exe, uma possível forma de contornar isso seria move-lo novamente para um svchost compartilhado. Para isso, experimente executar o comando sc config wuauserv type= share, reiniciar o sistema e realizar o processo novamente.

    Att, 


    quarta-feira, 6 de junho de 2018 13:54
    Moderador
  • Olá Marcelo!

    Isto pode estar acontecendo devido ao fato do WUA estar rodando no seu próprio SVCHOST.exe, uma possível forma de contornar isso seria nove-lo novamente para um svchost compartilhado. Para isso, experimente executar o comando sc config wuauserv type= share, reiniciar o sistema e realizar o processo novamente.

    Att, 

    Olá amigo Igor.

    Executei o comando (sc config wuauserv type= share) como super admin e reiniciei o servidor.

    Não notei nada de diferente ou seja, ainda segue persiste o erro 0x080070006 no update do Windows Server

    sexta-feira, 8 de junho de 2018 14:48
  • Outra possível solução seria reconfigurar os privilégios no WUA, para que ele possa chamar um método chamado ZwOpenProcess(). Experimente executar este comando curtinho e reiniciar o servidor:

    sc privs wuauserv SeAssignPrimaryTokenPrivilege/SeAuditPrivilege/SeBackupPrivilege/SeChangeNotifyPrivilege/SeCreateGlobalPrivilege/SeCreatePagefilePrivilege/SeCreatePermanentPrivilege/SeCreateSymbolicLinkPrivilege/SeDebugPrivilege/SeImpersonatePrivilege/SeIncreaseBasePriorityPrivilege/SeIncreaseQuotaPrivilege/SeIncreaseWorkingSetPrivilege/SeLoadDriverPrivilege/SeLockMemoryPrivilege/SeManageVolumePrivilege/SeProfileSingleProcessPrivilege/SeRestorePrivilege/SeSecurityPrivilege/SeShutdownPrivilege/SeSystemEnvironmentPrivilege/SeSystemProfilePrivilege/SeSystemtimePrivilege/SeTakeOwnershipPrivilege/SeTcbPrivilege/SeTimeZonePrivilege/SeUndockPrivilege

    Testei em uma vm WS2016 e o retorno foi "[SC] ChangeServiceConfig2 SUCCESS".

    • Sugerido como Resposta Rosemberg Porto domingo, 10 de fevereiro de 2019 15:03
    sexta-feira, 8 de junho de 2018 17:20
    Moderador
  • Outra possível solução seria reconfigurar os privilégios no WUA, para que ele possa chamar um método chamado ZwOpenProcess(). Experimente executar este comando curtinho e reiniciar o servidor:

    sc privs wuauserv SeAssignPrimaryTokenPrivilege/SeAuditPrivilege/SeBackupPrivilege/SeChangeNotifyPrivilege/SeCreateGlobalPrivilege/SeCreatePagefilePrivilege/SeCreatePermanentPrivilege/SeCreateSymbolicLinkPrivilege/SeDebugPrivilege/SeImpersonatePrivilege/SeIncreaseBasePriorityPrivilege/SeIncreaseQuotaPrivilege/SeIncreaseWorkingSetPrivilege/SeLoadDriverPrivilege/SeLockMemoryPrivilege/SeManageVolumePrivilege/SeProfileSingleProcessPrivilege/SeRestorePrivilege/SeSecurityPrivilege/SeShutdownPrivilege/SeSystemEnvironmentPrivilege/SeSystemProfilePrivilege/SeSystemtimePrivilege/SeTakeOwnershipPrivilege/SeTcbPrivilege/SeTimeZonePrivilege/SeUndockPrivilege

    Testei em uma vm WS2016 e o retorno foi "[SC] ChangeServiceConfig2 SUCCESS".

    Olá amigo.

    Eu copiei e colei exatamente este comando curtinho bem como vc falou (rsrsr) e o retorno não computou veja:

    domingo, 10 de junho de 2018 00:12
  • Outra possível solução seria reconfigurar os privilégios no WUA, para que ele possa chamar um método chamado ZwOpenProcess(). Experimente executar este comando curtinho e reiniciar o servidor:

    sc privs wuauserv SeAssignPrimaryTokenPrivilege/SeAuditPrivilege/SeBackupPrivilege/SeChangeNotifyPrivilege/SeCreateGlobalPrivilege/SeCreatePagefilePrivilege/SeCreatePermanentPrivilege/SeCreateSymbolicLinkPrivilege/SeDebugPrivilege/SeImpersonatePrivilege/SeIncreaseBasePriorityPrivilege/SeIncreaseQuotaPrivilege/SeIncreaseWorkingSetPrivilege/SeLoadDriverPrivilege/SeLockMemoryPrivilege/SeManageVolumePrivilege/SeProfileSingleProcessPrivilege/SeRestorePrivilege/SeSecurityPrivilege/SeShutdownPrivilege/SeSystemEnvironmentPrivilege/SeSystemProfilePrivilege/SeSystemtimePrivilege/SeTakeOwnershipPrivilege/SeTcbPrivilege/SeTimeZonePrivilege/SeUndockPrivilege

    Testei em uma vm WS2016 e o retorno foi "[SC] ChangeServiceConfig2 SUCCESS".

    Olá amigo.

    Eu copiei e colei exatamente este comando curtinho bem como vc falou (rsrsr) e o retorno não computou veja:

    Execute o comando curtinho no CMD
    • Marcado como Resposta IgorFKModerator segunda-feira, 11 de junho de 2018 19:26
    segunda-feira, 11 de junho de 2018 17:30
    Moderador
  • Execute o comando curtinho no CMD

    Olá amigo,

    Executei no CMD como super admin e o retorno foi este:

    "[SC] ChangeServiceConfig2 SUCCESS"

    Reiniciei o servidor e o windows update voltou a funcionar.

    Apenas mais duas dúvida. Este comando serve para qualquer Windows que estiver com problemas no Update ou somente neste meu cenário pois foi salvador hiem!

    Segunda dúvida:

    Reparei que depois que executei este comando que vc me passou, o problema que tinha antes de sobrecarga nos serviços dentro do TASK MANAGER sumiu, alias, criei um post aqui neste fórum mas foi fechado por ninguém interagir, veja:

    https://social.technet.microsoft.com/Forums/pt-BR/f3d68d55-04d3-448e-b1dc-d5ef041fe718/sobrecarga-de-servios-no-task-manager?forum=w8serverpt#2891487a-567a-493c-a932-52df914bf2b4

    Este problema acima que relato no link, estava acontecendo neste servidor 2016 DC secundário até então resolvido (até este momento), e ainda persiste no DC1 2012 r2 sendo que no 2012 R2, o update funciona normalmente. Pergunto, se eu executar este mesmo comando no 2012 r2 será que este (HOST DE SERVIÇO no TASK MANAGER) se ajeitará que nem foi no 2016 ? Eu sei que não tem haver com este o tópico mas me chamou atenção entendeu amigo? 

    2016 agora após o comando:

    2012 R2 com a sobrecarga:


    segunda-feira, 11 de junho de 2018 18:43
  • Que bom que resolvemos seu problema!!

    Sobre aplicar o comando no 2012, toda a tentativa é válida!

    segunda-feira, 11 de junho de 2018 19:25
    Moderador
  • Que bom que resolvemos seu problema!!

    Sobre aplicar o comando no 2012, toda a tentativa é válida!


    Me responda uma coisa. O que este comando exatamente faz ?
    segunda-feira, 11 de junho de 2018 20:11