none
Migrar de servidor Exchange 2007 para 2007 RRS feed

  • Pergunta

  • Bom dia galera!

    Preciso migrar o servidor de Exchange 2007 que está rodando sobre Windows 2003 R2 x64 English para outro servidor Windows 2003 R2 x64 English com Exchange 2007 também.

    Então basicamente seria passar os papéis do srv-corcorreio1 para srv-rcorreio2, pois o srv-correio1 é quem tem os papéis de envio e transporte de mensagens, no 2 tenho todas as mailbox (que já migrei do 1 para o 2) e o serviço de OWA também está no 2 pois o windows do 1 está com IIS corrompido (por isso a migração, quero deixar tanto os mailbox, OWA e serviço de entrega tudo centralizado em um único servidor de correio) como era antes, pois estou fazendo a migração porque o 1 deu problema no IIS (atualização de windows corrompeu DLLs do .NET framework) e com isso o OWA parou de funcionar.

    Alguém tem um link de um tutorial, pesquisei vários mas achei tutorais para coisas semelhantes como "Remover o primeiro Exchange do Domíno", "Adicionar função ao Exchange 2007", "Remover função do Exchange 2007", "Removendo uma organização do Exchange", "Migrando Exchange 2007 para 2010", mas nada parecido com o meu cenário, que é desativar um servidor e passar os papéis para o outro mas da mesma versão.

    Valeu...!

    segunda-feira, 20 de maio de 2013 14:06

Respostas

  • Daniel,

    Pelo que entendi, você tem os Serviços de CAS e Mailbox no segundo servidor, e o serviço de HUB transport ainda no servidor 1.

    Se for esse o seu caso, você deve fazer o seguinte:

    • Instalar o HUB Transport no servidor 02;
    • Verificar os Send Connectors para que o servidor 02 também envie mensagens;
    • Configurar os Receive Connectors no servidor 02 para que fiquem como estava no servidor 01, caso tenha relay configurado, etc.
    • Verificar aplicações internas que façam relay no servidor 01, para que passem a fazer no servidor 02;
    • Mudar o seu MX ou Publicação do Firewall, dependendo de como está sua configuração, para que os e-mails cheguem no servidor 02 e não mais no 01;
    • Desligar/Desativar o Servidor 01.

    O último passo eu deixaria o servidor desligado, ou os serviços do Exchange parados para verificar se nada mais relativos aos outros papéis ainda estão nele, e depois de um período de testes eu desinstalaria o Exchange.

    Att,

    Aloísio Lacerda

    • Marcado como Resposta Daniel-BHZ segunda-feira, 20 de maio de 2013 18:57
    segunda-feira, 20 de maio de 2013 15:53

Todas as Respostas

  • Daniel,

    Pelo que entendi, você tem os Serviços de CAS e Mailbox no segundo servidor, e o serviço de HUB transport ainda no servidor 1.

    Se for esse o seu caso, você deve fazer o seguinte:

    • Instalar o HUB Transport no servidor 02;
    • Verificar os Send Connectors para que o servidor 02 também envie mensagens;
    • Configurar os Receive Connectors no servidor 02 para que fiquem como estava no servidor 01, caso tenha relay configurado, etc.
    • Verificar aplicações internas que façam relay no servidor 01, para que passem a fazer no servidor 02;
    • Mudar o seu MX ou Publicação do Firewall, dependendo de como está sua configuração, para que os e-mails cheguem no servidor 02 e não mais no 01;
    • Desligar/Desativar o Servidor 01.

    O último passo eu deixaria o servidor desligado, ou os serviços do Exchange parados para verificar se nada mais relativos aos outros papéis ainda estão nele, e depois de um período de testes eu desinstalaria o Exchange.

    Att,

    Aloísio Lacerda

    • Marcado como Resposta Daniel-BHZ segunda-feira, 20 de maio de 2013 18:57
    segunda-feira, 20 de maio de 2013 15:53
  • Daniel,

    Pelo que entendi, você tem os Serviços de CAS e Mailbox no segundo servidor, e o serviço de HUB transport ainda no servidor 1.

    Se for esse o seu caso, você deve fazer o seguinte:

    • Instalar o HUB Transport no servidor 02;
    • Verificar os Send Connectors para que o servidor 02 também envie mensagens;
    • Configurar os Receive Connectors no servidor 02 para que fiquem como estava no servidor 01, caso tenha relay configurado, etc.
    • Verificar aplicações internas que façam relay no servidor 01, para que passem a fazer no servidor 02;
    • Mudar o seu MX ou Publicação do Firewall, dependendo de como está sua configuração, para que os e-mails cheguem no servidor 02 e não mais no 01;
    • Desligar/Desativar o Servidor 01.

    O último passo eu deixaria o servidor desligado, ou os serviços do Exchange parados para verificar se nada mais relativos aos outros papéis ainda estão nele, e depois de um período de testes eu desinstalaria o Exchange.

    Att,

    Aloísio Lacerda

    Fala Aloíso blz...

    Como meu ambiente é todo virtualizado, fiz os procedimentos informados por você em um ambiente de teste e utilizando "Rede privada" e consegui passar os papéis necessários para que o srv-correio2 fazer o envio e recebimento dos e-mails com sucesso, pois ingressei um VM com windows 7 para simular o cliente e enviei recebi e-mails com sucesso (somente internos para e-mails externos vou ter que fazer na produção depois).

    Outra questão:

    Antes do IIS dar problema no serviodor1 o HTTPS  já não estava funcionando, pois com o problema no IIS o certificado que fica nele também deu problema, só que importei/instalei o certificado no servidor2 e quando digito mail.meudominio.com.br ele não está redirecionando para https://mail.meudominio.com.br como era antes, ele fica no http://mail.meudominio.com.br. O problema disso são os smartphones, tablets que deve ser desmarcado o SSL e fora que toda hora abre uma tela de autenticação e depois outra falando que o certificado não é válido ai clicando em sim/não ou cancelar a mensagem some e o outlook funciona normalmente para quem usa o Exchange via Outlook, no caso o 2007 o que irrita muito a diretoria que toda usa Outlook, quem usa via OWA como eu estas telas nao aparecem.

    Nem se eu marcar a opção de requerer o SSL no ISS ele vai para HTTPS, sendo que antes esta opção não era marcada e ele ja redirecionava para HTTPS, a opção é achada indo na console do IIS / Web Sites / Default Web Sites / OWA clicar em propriedades / Directory Security / Secure Communications / Edit / Required Secure Channel (SSL). OBS: antes quando o SSL funcionava quando agente atualizava algum roll-up do exchange ele marcava esta opção por default só que causava impacto para os usuário deixar esta opção marcada pois todos tinha que clicar naquele botão "Continuar" quando acessavam o e-mail via OWA pelo Internet Explorer, então nos já desmarcávamos sempre que aplicavamos um novo roll-up, e ele redirecionava automaticamente quando digitavam no browser "mail.meudominio.com.br" para "https://mail.meudomini.com.br" ou seja o SSL esta habilitado.

    Obs: O certificado está valido ate final de 2014.

    Se precisar de mais algum detalhe sobre meu ambiente me fale que posto aqui.

    Valeu abraço!

    segunda-feira, 20 de maio de 2013 18:57
  • Daniel,

    Quanto ao certificado, você deve importar o certificado no Exchange usando o assistente, ou via linha de comando.

    É muito importante verificar na configuração do CAS as URLs do OWA e dos outros serviços, no caso o nome do certificado deve ser igual ao nome da URL que você colocar lá.

    Em relação ao redirecionamento, a forma mais simples de fazer é no próprio IIS, utilizar o URL Redirection, só deve ficar atento para não redirecionar de todas as subpastas, senão o acesso de outras pastas pode ficar comprometido, como do autodiscover por exemplo.

    Att,

    Aloísio

    segunda-feira, 20 de maio de 2013 19:08
  • Aloisio,

    O certificado já está importado e quando mando exibir o mesmo em "console do IIS / Web Sites / Default Web Sites / OWA clicar em propriedades / Directory Security / Secure Communications / View Certificate" no campo "Issued to:" está "Issued to: mail.meudomini.com.br" seria isso mesmo, ele está importado com o nome público do MX da organização, que é a URL que todos utilizam para se conectar no OWA correto?

    Em relação ao "URL Redirection" não achei onde faço, a não ser na propriedade de cada virtual directory como o OWA, OAB e outros na aba "Virtual Directory" tem uma opção "A redirection to a URL" que é a opção que aponta onde estão os arquivos do OWA local na máquina.

    Então queria saber como faço o redirecionamento de todos menos do autodiscover.

    Uma outra dúvida é que acho que não está indo para HTTPS pois nas propriedades da aba "Directory Security / Authentication and access control  / Edit " do OWA, OAB e autodiscover as opções do modo de autenticação está setado para "Basic authentication (password is sent in clear text), tanto que quando desmarco esta opção nestes virtuais directories ele avisa que a autenticação irá exigir o SSL que é o que eu quero, onde o site passa para HTTPS automaticamente, por isso acho q está relacionado a esta permissão e não a redirecionamento via "URL Redirection". O problema é que quando fico marcando e desmarcando estas opções de autenticação nestes virtuais directories da pau no IIS, quando tento acessar via browser da "440 login timeout" ai achei um procedimento que manda remover os virtuais directories e cria-los de novo e realmente funcionou, mas nao conseguir forçar o certificado ainda...

    Recriar os virtual Directory:  http://support.microsoft.com/kb/941201?ppud=4&wa=wsignin1.0

    Valeu abraço!

    segunda-feira, 20 de maio de 2013 21:25
  • Somente complementando o que preciso.

    Creio que eu devo deixar a
    Flag "SSL Enable" em "True" mas para isso preciso fazer à partir do IIS
    mas não achei a opção que ele exibe e manda ir pelo IIS, quando marco a
    opção "Required client certificates"

    terça-feira, 21 de maio de 2013 14:40
  • Creio
    que este parametro "ClientCertAuth" seja na aba "Directory Security" /
    Authentication and access control / Edit" no meu servidor está marcado
    conforme o print abaixo a opção "Basic authentication" que até informa
    entre parenteses que a senha nao tem criptografia e etc. O que ocorre é
    que quando desmarco esta opção e marco a primeira "Integrated windows
    authentication" e restaro o IIS ele volta a marcar a caixa como o print
    abaixo, creio que por isso a FLAG "SSL Enable" não fica "True" dentro da
    console do Exchange.

    Não sei também se devo alterar esta configuração como fiz acima
    no nivel de autenticação nos diretorios virtuais como OWA, autodiscover
    ou na raiz do Default Web Site?

    Valeu!

    terça-feira, 21 de maio de 2013 14:40