none
ISA + IIS + SSL + SHAREPOINT - PRECISO DE AJUDA! RRS feed

  • Pergunta

  • Olá,

     

    Estou com um problema para configurar acesso externo ao meu portal Sharepoint 2007.. (uma central de documentos e Project server) com um certificado que compramos em uma entidade certificadora (COMODO)

     

    Bom meu ambiente é o seguinte:

     

    tenho um servidor, o qual vou chamalo de SERVIDOR-01.

     

    No SERVIDOR-01:  

     

    - AD controlando o dominio

    - Sharepoint 2007

    - Project Server

    - IIS

    - e algumas outras aplicações (SISTEMA etc.)

     

    OBS: esse servidor possui um IP apenas da rede interna, não válido na internet (ex. 192.168.0.2)

    #########################################################################################

    SERVIDOR-02:

    - ISA SERVER 2006 ENTERPRISE

     

    OBS: Possui 2 placas de rede, sendo uma com ip valido na internet, e outra com ip interno apenas(ex. 192.168.0.1). Este servidor só roda o ISA server, e trabalha como firewall.

     

    Criei uma regra no ISA(SERVIDOR-02) para publicar esse site Sharepoint que se encontra no SERVIDOR-01 na porta 8080......>>>>   instalei o certificado no servidor 01 e exportei para o isa. selecionei no OUVINTE DA WEB para ele utilizar o certificado.  até ai blz! configurei para direcionar para o servidor-01 e blz mas nao funciona? da falha na autenticação...

     

    O que eu fiz de errado heim?

    Alguem pode me dar umas dicas de como fazer isso? um passo a passo.. eu nao manjo mto de SSL e estou começando ao pouco tempo com ISA

     

    Desde já agradeço..

     

     

    Fabio!

    sexta-feira, 10 de agosto de 2007 14:53

Todas as Respostas

  •  

    Aparenta ser problema na parte de autenticacao do ISA ou IIS.

    1) O que voce tem marcado na guia Autenticacao da regra do ISA em questao?

     

    2) Como o iis esta configurado na parte de autenticacao ? (para o site em questao)

    domingo, 12 de agosto de 2007 13:22
  •  

    Olá,

     

    Bom,  respondendo...

     

    No Isa server, na parte de Ouvinte da web na parte de autenticação:

     

    Autenticação de formulário HTML

    Integrado (Active Directory)

     

    em avançado >  Permitir autenticação de cliente via HTTP

     

    E lá embaixo coloquei o nome do dominio.

     

     

    No IIS:

     

    Na parte de Segurança de diretório, a unica parte q está com o check box habilitado é:

    Aceitar certificados do cliente

     

     

    Só isso...

     

    Na hora que tento logar pelo endereço externo, aparece o cadeadinho no navegador.. e qdo passo o mouse em cima vejo que o certificado está certo...   mas ai qdo coloco o usuario e senha errado ele retorna: Não foi possível fazer logon no ISA Server. Verifique se o nome de domínio, o nome de usuário e a senha estão corretos e tente novamente.

     

    E quando eu coloco o usuario e senha certo ele vai para uma pagina:

     

    A página não pode ser exibida

     

    Informações Técnicas (para a equipe de suporte)

    • Código de Erro: 500 Erro Interno do Servidor. O logon na rede falhou. (1790)

    é issoo...

     

    desde já agradeço a atenção!

     

    t+

     

    segunda-feira, 13 de agosto de 2007 12:46
  • Ola , como vai Fabio....

    já resolveu seu problema......

     

    se não.... procure algo na internet sobre instalação de sharepoint em um DC, pq tem algumas coisa q devem ser modificadas para q os mesmo funcionem corretamente...

     

    abraços..............

    domingo, 2 de dezembro de 2007 15:13