none
Erro na Replicação Hyper-V RRS feed

  • Pergunta

  • Olá!

    Estou enfrentando um problema com a replicação do Hyper-V. Tenho dois hosts alocando máquinas virtuais, um replicando para o outro e vice-versa. Está aparecendo o seguinte erro no log do Gerenciador de Servidores Hyper-V:

    "O Hyper-V não pôde autenticar o servidor de réplica SERVER01 usando autenticação Kerberos. Erro: O KDC não oferece suporte ao tipo de criptografia solicitado. (0x80090342)" .

    O detalhe é que ao reiniciar a máquina física eu consigo reiniciar a replicação das VM's sem problemas, mas após 1 ou 2 dias o erro volta a acontecer. Tenho dois DC Windows Server 2012 R2 e um DC Windows Server 2008 R2, o DC com o 2008 R2 continha as FSMO's, transferi para um DC com 2012 R2, achando que isso poderia está relacionado ao problema, mas sem sucesso. Alguém já passou por isso, ou tem ideia do que possa ser?

    quarta-feira, 6 de maio de 2015 13:45

Respostas

Todas as Respostas

  • Boa tarde Everton,

    Segue esses links que podem lhe ajudar.

    https://technet.microsoft.com/pt-br/Library/jj134153.aspx

    http://blogs.technet.com/b/virtualization/archive/2013/02/14/hyper-v-replica-kerberos-error.aspx

    Abraços


    Matheus Leopardi Mello Canelada Campos

    Esse conteúdo e fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    TechNet Community Support

    Por favor, lembre-se de Marcar como Resposta as respostas que resolveram o seu problema. Essa e uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    • Marcado como Resposta Everton A. Souza sexta-feira, 8 de maio de 2015 14:36
    • Não Marcado como Resposta Everton A. Souza segunda-feira, 11 de maio de 2015 13:53
    quinta-feira, 7 de maio de 2015 17:00
  • Ola Everton,

    Esse erro era típico quando migravamos o Windows 2003 para um Windows 2008 R2 e existe até um hotfix para resolver. Creio que você deve fazer um teste com o DCDIAG em seu domínio e verificar se existem problemas na replicação e criptografia.

    Outros comando:

    - dcdiag

    - dcgiag /tes:dns

    - dcdiag /CheckSecurityError


    Espero que ajude.


    Vinicius Mozart || MVP - Group Policy || vinicius.mozart@terra.com.br || http://www.wenz.com.br || Skype: vinicius.mozart


    quinta-feira, 7 de maio de 2015 17:33
  • Matheus, já havia feito o procedimento que é mencionado no segundo link que você compartilhou e aparentemente o problema foi resolvido, as máquinas já estão replicando há 1 dia sem parar, e não tive que reiniciar as máquinas físicas. O procedimento realizado foi acessar as propriedades dos computadores físicos no AD, aba Delegação, selecionei Confiar no computador para delegação apenas a serviços especificados e também selecioneiUsar apenas Kerberos, depois fui no botão adicionar e adicionei a máquina que recebe as réplicas e também adicionei os serviços cifs e Microsoft Virtual System Migration. Só não entendi por que não estava funcionando da forma como estava configurado anteriormente, sendo que estava marcado a opção Confiar no computador para delegação a qualquer serviço (Apenas Kerberos), imaginei que configurado dessa maneira já daria o acesso necessário para esses serviços. Mas está funcionando e agradeço sua ajuda e a do Vinicius.
    sexta-feira, 8 de maio de 2015 14:37
  • Olá Vinícius, o dcdiag passou em todos os testes, agora esses dois outros comandos que você passou está dando erro de Sintax, tanto p dcdiag /tes:dns como o dcdiag /CheckSecurityError. Mas o que você falou sobre migração do 2003 para o 2008 faz um pouco sentido para minha realidade, migrei do 2003 para o 2008 há uns dois anos atrás, e agora migrei para o 2012, mas não estou conseguindo resolver isso sendo que no dcdiag não me apresenta problemas.
    segunda-feira, 11 de maio de 2015 14:04
  • Ola Everton,

    Desculpe errei na digitação e o correto é : dcdiag /test:dns. Sobre o erro do 2003 para o 2008 era preciso utilizar o hotfix abaixo:

    https://support.microsoft.com/en-us/kb/978055/pt-br?wa=wsignin1.0

    Veja se consegue encontrar algo para o Windows Server 2012 referente a esse documento.

    Espero que ajude.



    Vinicius Mozart || MVP - Group Policy || vinicius.mozart@terra.com.br || http://www.wenz.com.br || Skype: vinicius.mozart

    segunda-feira, 11 de maio de 2015 14:20
  • Vinicius o test:dns também passou. Tenho três DC no meu ambiente, 2 Windows Server 2012 R2 e um DC Windows Server 2008 R2, baixei o hotfix para rodar no Windows Server 2008 R2, mas ao tentar instalar ele dá uma mensagem dizendo que essa atualização não pode ser instalada no computador. Outra coisa estranha é que fui nas propriedades das duas máquinas físicas novamente, na aba delegação e alterei a delegação para a que estava anteriormente Confiar no computador para delegação a qualquer serviço (Apenas Kerberos), e daí está replicando novamente, mas sei que daqui alguns dias vai parar novamente. Estou sem ideias.
    segunda-feira, 11 de maio de 2015 15:06