none
Erro em Arquivo Backup.Bat RRS feed

  • Pergunta

  • Backup usando o Xcopy
    Galera estou com um problemão... fiz uma arquivo bat para fazer backup da pasta meus documentos e do Ms outlook.... os arquivo dentro do meus documentos ele copia perfeito... mais na hora de copiar a pasta do ms outlook ele diz que arquivo não encontrado, eu já reveriei a net e não achei nada... o caminho da pasta está correto, sei tmb que são pastas ocultas....como posso solucionar isso.




    @echo off
    CLS
    ECHO. ************************************************** *************
    ECHO. BACKUP DIARIO
    ECHO. CENTERPLEX
    ECHO. ************************************************** *************
    ECHO.
    ECHO. Efetuando copia dos arquivos....aguarde!!!!
    ECHO.
    xcopy "%userprofile%\meus documentos" \\bilhete\raquel /d/s/c/q/y/z
    xcopy "%userprofile%\configurações locais\dados de aplicativos\microsoft\outlook" \\bilhete\raquel /d/s/c/q/y/z
    ECHO.
    ECHO. Backup efetuado com sucesso!
    ECHO.
    ECHO. ************************************************** **************
    ECHO. FIM DE BACKUP
    ECHO. ************************************************** **************
    ECHO.
    ECHO.
    ECHO. Pressione qualquer tecla para continuar...
    PAUSE>NUL


    O que eu estou errando para copiar o outlook????!!!
    quarta-feira, 16 de setembro de 2009 20:24

Respostas

  • Olá,

    Tente utilizar o caminho de destino entre Aspas também. Exemplo:


    xcopy "%userprofile%\meus documentos" "\\bilhete\raquel " /d/s/c/q/y/z

    xcopy "%userprofile%\configurações locais\dados de aplicativos\microsoft\outlook" "\\bilhete\raquel" /d/s/c/q/y/z


    Até mais,

    Jesiel

    Obs.: Se útil, classifique


    quarta-feira, 16 de setembro de 2009 20:48
  • Verifique se não é algum problema de codificação de caracteres diferente.
    Ative o ECHO, e verifique se o caminho aparece corretamente.

    A propósito: para esse tipo de script, o ROBOCOPY é bem mais robusto. Recomendo que você dê uma olhada, pois vai tornar sua rotina de backup bem menos propensa a erros.

    Um abraço!

    Thiago Hickmann - Analista de Infraestrutura de TI
    quinta-feira, 17 de setembro de 2009 05:23

Todas as Respostas

  • Olá,

    Tente utilizar o caminho de destino entre Aspas também. Exemplo:


    xcopy "%userprofile%\meus documentos" "\\bilhete\raquel " /d/s/c/q/y/z

    xcopy "%userprofile%\configurações locais\dados de aplicativos\microsoft\outlook" "\\bilhete\raquel" /d/s/c/q/y/z


    Até mais,

    Jesiel

    Obs.: Se útil, classifique


    quarta-feira, 16 de setembro de 2009 20:48
  • Verifique se não é algum problema de codificação de caracteres diferente.
    Ative o ECHO, e verifique se o caminho aparece corretamente.

    A propósito: para esse tipo de script, o ROBOCOPY é bem mais robusto. Recomendo que você dê uma olhada, pois vai tornar sua rotina de backup bem menos propensa a erros.

    Um abraço!

    Thiago Hickmann - Analista de Infraestrutura de TI
    quinta-feira, 17 de setembro de 2009 05:23