none
Clientes do Wsus não atualizam alterando o registro do Windows RRS feed

  • Pergunta

  • Pessoal,

    Tenho um Servidor exclusivo para o Wsus (Windows server 2003 R2).
    Este Servidor está com duas placas de rede, pois trabalho com duas redes. (Rede 1 não tem acesso a internet e a Rede2 que tem acesso a internet para baixar a atualizações.) Ambas as redes estão em dominios diferentes (Dominio Produção e Dominio de Office), o Servidor do Wsus se encontra no Dominio de Produção.

    Minha Duvida: Quero fazer atualizar alterando o registro de cada máquina e não por GPO. Porém nenhuma máquina aparece na Opção computers do WSUS. As máquinas pingam o servidor por Nome e Por IP normalmente. Para que as atualizações via Alterando Registro possam ser efetuadas é necessário que os PCS de toda a rede apareçam na Opção computers do WSUS ?

    Testei do Client Diagnostc em um PC e apresentou a seguinte mensagem:

    WSUS Client Diagnostics Tool

    Checking Machine State
            Checking for admin rights to run tool . . . . . . . . . PASS
            Automatic Updates Service is running. . . . . . . . . . PASS
            Background Intelligent Transfer Service is running. . . PASS
            Wuaueng.dll version 5.4.3790.2180 . . . . . . . . . . . PASS
                    This version is SUS 1.0

    Checking AU Settings
            AU Option is 2 : Notify Prior to Download . . . . . . . PASS
                    Option is from Control Panel

    Checking Proxy Configuration
            Checking for winhttp local machine Proxy settings . . . PASS
                    Winhttp local machine access type
                            <Direct Connection>
                    Winhttp local machine Proxy. . . . . . . . . .  NONE
                    Winhttp local machine ProxyBypass. . . . . . .  NONE
            Checking User IE Proxy settings . . . . . . . . . . . . PASS
                    User IE Proxy. . . . . . . . . . . . . . . . .  NONE
                    User IE ProxyByPass. . . . . . . . . . . . . .  NONE
                    User IE AutoConfig URL Proxy . . . . . . . . .  NONE
                    User IE AutoDetect
                    AutoDetect not in use

    Checking Connection to WSUS/SUS Server
                    WUServer = http://WSUSPROD
                    WUStatusServer = http://WSUSPROD
            UseWuServer is enabled. . . . . . . . . . . . . . . . . PASS
            Connection to server. . . . . . . . . . . . . . . . . . PASS
            SelfUpdate folder is present. . . . . . . . . . . . . . PASS

    Press Enter to Complete


    quinta-feira, 1 de outubro de 2009 15:42

Respostas

  • Matheus,

    Encontrei um problema na minha rede, de comunicação entre as Vlans, e consegui fazer com que se comuniquem atualizando o registro.
    Assim que eu tiver outro problema eu testarei o Código que você me passou, parece bem interressante.

    Se servir para alguem o código e testar favor postar a experiência.


    Valeu Matheus.
    • Marcado como Resposta Grande_Bart segunda-feira, 16 de novembro de 2009 18:15
    segunda-feira, 5 de outubro de 2009 13:54

Todas as Respostas

  • Caro,

    Eu utilizo um script quando ocorre algumas situações como essa, veja abaixo.

    Ele faz um limpeza na máquina e depois força uma sincronização, pelo menos em todos os casos onde não obtive sucesso nos testes, este funcionou perfeitamente.

    net stop wuauserv
    net stop bits
    REG DELETE HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate /v SusClientId /F
    REG DELETE "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update" /F
    REG DELETE HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate /v SusClientIdValidation /F
    c:
    cd\
    cd %systemroot%\SoftwareDistribution
    del *.* /S /Q
    rd %systemroot%\SoftwareDistribution /S /Q
    cd\
    proxycfg -d
    net start wuauserv
    net start bits
    gpupdate /force
    wuauclt /resetauthorization /detectnow
    Att
    Matheus Canela
    Analista de Segurança Windows
    MCT / MCSA / MCP / MCTS / MCDST / ITIL v2

    Caso a resposta for útil, favor responda e clica na seta verde abaixo da foto para votação
    quinta-feira, 1 de outubro de 2009 17:29
  • Matheus,

    Encontrei um problema na minha rede, de comunicação entre as Vlans, e consegui fazer com que se comuniquem atualizando o registro.
    Assim que eu tiver outro problema eu testarei o Código que você me passou, parece bem interressante.

    Se servir para alguem o código e testar favor postar a experiência.


    Valeu Matheus.
    • Marcado como Resposta Grande_Bart segunda-feira, 16 de novembro de 2009 18:15
    segunda-feira, 5 de outubro de 2009 13:54