none
Critica na instalação do EX2010 SP1 - Mailbox Role Failed RRS feed

  • Pergunta

  • Pessoal, durante a instalação do EX2010SP1, apareceu a critica abaixo alguem sabe o que pode ser?


    Mailbox Role
    Failed

    Error:
    The following error was generated when "$error.Clear(); 
              if ($RoleIsDatacenter -ne $true)
              {
                if (test-ExchangeServersWriteAccess -DomainController $RoleDomainController -ErrorAction SilentlyContinue)
                {
                  # upgrade the discovery mailboxes to R5 version, this will fix the RecipientDisplayType property of the discovery mailbox which was wrong in R4.
                  get-mailbox -RecipientTypeDetails DiscoveryMailbox -DomainController $RoleDomainController | where {$_.IsValid -eq $false} | set-mailbox -DomainController $RoleDomainController
                  $name = [Microsoft.Exchange.Management.RecipientTasks.EnableMailbox]::DiscoveryMailboxUniqueName;
                  $dispname = [Microsoft.Exchange.Management.RecipientTasks.EnableMailbox]::DiscoveryMailboxDisplayName;
                  $mbxs = @( get-mailbox -Filter {name -eq $name} -IgnoreDefaultScope -resultSize 1 );
                  if ( $mbxs.length -eq 0) 
                  {
                    $dbs = @(get-MailboxDatabase -Server:$RoleFqdnOrName -DomainController $RoleDomainController);
                    if($dbs.Length -ne 0) 
                    {
                      $mbxUser = @(get-user -Filter {name -eq $name} -IgnoreDefaultScope -ResultSize 1);
                      if ($mbxUser.Length -ne 0) 
                      {
                        enable-mailbox -Discovery -identity $mbxUser[0] -DisplayName $dispname -database $dbs[0].Identity;
                      }
                    }
                  }
                }
                else
                {
                  write-exchangesetuplog -info "Skipping creating Discovery Search Mailbox because of insufficient permission."
                }  
              }
            " was run: "Database is mandatory on UserMailbox. Property Name: Database".

    Database is mandatory on UserMailbox. Property Name: Database
    Click here for help... http://technet.microsoft.com/en-US/library/ms.exch.err.default(EXCHG.141).aspx?v=14.1.218.11&e=ms.exch.err.Ex88D115&l=0&cl=cp


    Fabiano Pires

    terça-feira, 14 de maio de 2013 14:01

Todas as Respostas

  • Fabiano,

    voce precisa primeiro preparar o AD pra receber o SP1, a propria mensagem mostra isso, o schema da DM está em R4, vc precisa estar em R5 pra instalar o SP1.

    1. roda isso: setup.com /ps

    2. isso: setup.com /preparead

    3. e isso: setup.com /pad

    E depois tenta instalar de novo.


    JATOBA - MCITP EMA 2010 / Caminhando para o MCSM Exchange 2010

    terça-feira, 14 de maio de 2013 22:55
    Moderador
  • eu rodei esses comandos o /ps estava dando erro, removi toda instalação limpei os grupos que foram criados no ad e reinstalei, agora deu certo.

    Só outra duvida,  meu servidor tem 2 unidades C e D,  qual é a melhor para instalar o Exchange? utilizar como padrao na unidade c: e criar os mailboxes na d: ou alterar o path de instalação tudo para o D:

    att,


    Fabiano Pires


    quarta-feira, 15 de maio de 2013 19:40
  • Boa tarde,

    Respondendo a pergunta sobre a instalação, você ira instalar seu Exchange no C:, mas, mover para a outra unidade os logs e outra unidade para o banco.


    Douglas Urbano

    quarta-feira, 15 de maio de 2013 20:49
  • Entao Douglas hoje eu fiz isso,  instalei no C: e movi os mailboxes para o d:  pois a unidade c: dediquei ao S.O. e instalaçao do Exchange,  sabe me dizer se essa é a melhor forma? ou seria melhor instalar o exchange direto no D: que é minha partição maior.

    abraço


    Fabiano Pires

    quarta-feira, 15 de maio de 2013 23:49