none
Replicação transacional. Erro RRS feed

  • Pergunta

  • Pessoal, estou configurando uma replicação merge no 2005 e, ao criar os scripts de assinatura, estou colocando o parâmetro @sync_type = 'none' pois eu tenho a mesma estrutura nos dois bancos, portanto gostaria que somente fosse gerado o snapshot para dados. Tudo funciona até eu inserir/deletar/atualizar um dado no banco que será replicado.  Ocorre o seguinte erro:

     

    Error messages:

    Could not find stored procedure 'sp_MSins_ADMINISTRADORAS_CARTAO'. (Source: MSSQLServer, Error number: 2812)
    Get help: http://help/2812

    Could not find stored procedure 'sp_MSins_ADMINISTRADORAS_CARTAO'. (Source: MSSQLServer, Error number: 2812)
    Get help: http://help/2812

    Minha dúvida é: essas procedures padrão são geradas no snapshot inicial? alguém pode me dar uma ajuda neste problema? Desde já agradeço. Até mais
    terça-feira, 26 de junho de 2007 14:07

Todas as Respostas

  • Leonardo,

     

    É necessário que o agent snapshot, seja inicializado pelo menos uma vez, para que esta stored procedure seja gerada.

    terça-feira, 26 de junho de 2007 14:09
    Moderador
  • Junior,

    O snapshot agent está rodando, mas o que eu estou achando estranho é que ele está finalizando com sucesso em uns dois segundos só. Você sabe pq ele pode estar se comportando desta forma?

    terça-feira, 26 de junho de 2007 14:54
  • Leonardo,

     

    Você já verificou o histórico de execução do agent snapshot?

     

    Ele não retorna nenhuma mensagem de erro?

    terça-feira, 26 de junho de 2007 16:41
    Moderador
  • Junior, a seguinte mensagem ocorre no status do snapshot agent:

    [0%] A snapshot was not generated because no subscriptions needed initialization.

    Você sabe pq isso ocorre?

    Engraçado é q as replicações merge o snapshot está sendo gerado, as únicas q não geram são as transacionais.

    terça-feira, 26 de junho de 2007 18:42
  •  

    Leonardo,

     

    Voce chegou a aplicar o SP2 e os fix´s posteriores? Me parece que esse problema que voce está tendo foi solucionado em um fix pós-SP2.

     

     

    terça-feira, 26 de junho de 2007 18:59
  • Burro, tinha que ser meu primo mesmo... burro mil vezes burro!
    sábado, 7 de julho de 2007 19:02
  • Hey porks, sai fora!!! vai pro forum do windows!!!hahahahahaha, ou melhor... cifraclub e treina aí pra eu te humilhar na vocal battle vai...hahahahahah
    quarta-feira, 11 de julho de 2007 17:42