none
Hospedar Site No Windows Small Bussines RRS feed

  • Pergunta

  • Olá boa tarde povo.
    Preciso hospedar um site da empresa  internamente no Windows Small Bussines server, alguém teria alguma manual de configuração para tal? á instalei o IIS e já possuo a pasta com o site no meu server. Alguém tem o procedimento?
    Abraos!!
    MCP/MCDST/MCTS/MCITP
    • Movido Thiago.Pereira terça-feira, 15 de setembro de 2009 18:48 post criado em área inadequada. (De:Windows Server 2003)
    terça-feira, 15 de setembro de 2009 18:36

Respostas

Todas as Respostas

  • Leandro,

    Leia as recomendações abaixo;

    Hosting an Internet Web site in SBS
    http://blogs.msdn.com/sbsdocsteam/archive/2005/08/15/451775.aspx

    Documentation by Task for Windows Small Business Server 2003
    http://www.microsoft.com/windowsserver2003/sbs/techinfo/productdoc/topic.mspx

    Publishing a Windows SharePoint Services Site on Windows Small Business Server 2003
    http://technet.microsoft.com/en-us/library/cc719928(WS.10).aspx

    Irei Mover sua Thread para a area correta.

    []`s
    Thiago Pereira | http://thiagoinfrat.spaces.live.com | http://www.winsec.org
    terça-feira, 15 de setembro de 2009 18:48
  • Leandro,

    O procedimento é o mesmo que um server com IIS, somente respeite os sites que o SBS cria que é de utilização do próprio SBS.

    Te aconselho a utilizar uma subpasta e colocar lá os arquivos.

    Veja que os procedimentos do SBS 2003 são diferentes do 2008

    Se for o SBS 2003 Premium, vc tem que fazer a publicação através do ISA Server.

    Grande Abraço!
    Jorge Vera - MCT/MCSA/MCITP/Small Business Specialist
    terça-feira, 15 de setembro de 2009 19:40
    Moderador
  • Blz.
    Já coloquiei em uma pasta separada e usei o assistente para criar o site , porém mandei redirecionar na pasta base para um endereço  http://www.teste.com.br  por exemplo mas não abre o site.
    O que devo fazer mais .
    MCP/MCDST/MCTS/MCITP
    terça-feira, 15 de setembro de 2009 23:07
  • Alguma dica , ja tentei acessar pelo  http://site    mas não abrea abre a tela da erro

    Erro de HTTP 403 - proibido
    MCP/MCDST/MCTS/MCITP
    quarta-feira, 16 de setembro de 2009 12:37
  • Leandro,

    Teu SBS é 2003 ou 2008?
    a versão é Premium ou é Standard?
    Jorge Vera - MCT/MCSA/MCITP/Small Business Specialist
    quarta-feira, 16 de setembro de 2009 13:50
    Moderador
  • Olá.
    A versão é Small Bussines 2003 Standard, o que está ocorrendo é o seguinte:

    Configurei o site conforme orientação indicando a pasta de armazenamento tudo certo, quando eu abro no navegador o caminho do site ele aparece erro Erro de HTTP 403 - proibido.
    Mas se eu abrir o site  por exemplo http://192.168.0.12:8080/mail.htm     ele abre a pagina do e-mail.
    Pelo que entendi ele não está abrindo sites ASP.
    Se eu colocar  http://192.168.0.12:8080/Default.aspx   ele não abre o site apresenta erro. Já verifiquei e o ASP.Net está instalado nos componentes do Windows, não sei se está faltando alguma configuração?

    Erro HTTP 404 - Arquivo ou diretório não encontrado.
    IIS (Serviços de Informações da Internet)




    MCP/MCDST/MCTS/MCITP
    quarta-feira, 16 de setembro de 2009 13:58
  • Leandro,

    Algumas situações para vc verificar:

    Verifique se nos serviços do IIS está habilitado o ASP e qual a versão;
    Sua aplicação é ASP.NET verifique a versão e atualizações de Service Packs;
    Deixe o default.aspx como primeira opççao em arquivos;
    Verifique as permissões de leitura, escrita nas propriedades do site;
    Verifique se não está marcado na segurança a autenticação integrada com o windows, deve estar em logon anonimo;

    De cabeça que eu lembro é isso, se tiver mais informações me passe.

    Grande Abraço!


    Jorge Vera - MCT/MCSA/MCITP/Small Business Specialist
    quarta-feira, 16 de setembro de 2009 14:14
    Moderador
  • Olá.
    Habilitei todos os serviços que estavam como proibido  no IIS.
    Todas as extensões CGI
    Todas As Extensoes ISAPI
    Conector de dados da internet.

    O erro que ocorre prmitindo estes serviços é:

     

    Erro de Servidor no Aplicativo '/'.

    Erro de configuração

    Descrição: Erro durante o processamento de um arquivo de configuração necessário para o serviço desta solicitação. Examine os detalhes específicos do erro e modifique esse arquivo de configuração apropriadamente.

    Mensagem de Erro do Analisador: Não foi possível carregar arquivo ou assembly 'System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' ou uma de suas dependências. O sistema não pode encontrar o arquivo especificado.

    Erro de Origem:

    Linha 41:     <compilation debug="true">
    Linha 42:       <assemblies>
    Linha 43:         <add assembly="System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
    Linha 44:         <add assembly="System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
    Linha 45:         <add assembly="System.Web.Extensions.Design, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>

    Arquivo de Origem: C:\Inetpub\Hidroexterno\web.config    Linha: 43

    Rastreamento do Carregamento de Assembly: As informações a seguir podem ser úteis para determinar por que o assembly 'System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' não pôde ser carregado.

    AVI: o log de ligações de assembly está desativado.
    Para ativar o log de  falhas de assembly, defina o valor do Registro [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) como 1.
    Observação: há alguma penalidade para o desempenho associada ao log de falha de ligação de assembly.
    Para desativar esse recurso, remova o valor do Registro [HKLM\Software\Microsoft\Fusion!EnableLog].
    


    Informações sobre a Versão: Microsoft .NET Framework Versão:2.0.50727.3082; Versão do ASP.NET:2.0.50727.3082

    Fiz as configuracoes que vc falou e continua a mesma coisa. A diferença é que ativando os serviços mencionado a cima apresenta este outro erro.

    MCP/MCDST/MCTS/MCITP
    quarta-feira, 16 de setembro de 2009 14:30
  • Olá Leandro,

    Realmente não é nada recomendável usar o SBS 2003 para hospedar o seu site externo. Porém, se você entende os riscos e mesmo assim quer fazê-lo, dá uma olhada nesse documento: http://technet.microsoft.com/pt-br/library/cc719840(en-us,WS.10).aspx

    Abraço
    MVP - Daniel Santos Blog: http://engdanielc.spaces.live.com/
    quarta-feira, 16 de setembro de 2009 22:10
    Moderador
  • Leandro,

    Pelo erro: Mensagem de Erro do Analisador: Não foi possível carregar arquivo ou assembly 'System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' ou uma de suas dependências. O sistema não pode encontrar o arquivo especificado.

    Ele não consegue achar o arquivo especificado, mas isso já muda de figura, mostra que teu IIS está respondendo as solicitações.

    Agora é alguma configuração específica de IIS com os recursos que você está utilizando para desenvolver, veja que se vc utilizar o defply do Visual Studio ele copia as DLLs para o servidor. Acredito que seja isso que esteja faltando.

    Grande Abraço!
    Jorge Vera - MCT/MCSA/MCITP/Small Business Specialist
    quinta-feira, 17 de setembro de 2009 11:39
    Moderador
  • Olá, estou com outro erro agora o que poderia ser?





    Mensagem de Erro do Analisador:
    Não foi possível carregar arquivo ou assembly 'System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' ou uma de suas dependências. O sistema não pode encontrar o arquivo especificado.

    Erro de Origem:

    Linha 41:     <compilation debug="true">
    Linha 42:       <assemblies>
    Linha 43:         <add assembly="System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
    Linha 44:         <add assembly="System.Design, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>
    Linha 45:         <add assembly="System.Web.Extensions.Design, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>

    Arquivo de Origem: C:\Inetpub\Hidroexterno\web.config    Linha: 43

    Rastreamento do Carregamento de Assembly: As informações a seguir podem ser úteis para determinar por que o assembly 'System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' não pôde ser carregado.

    === Informações sobre estado pré-ligação ===
    LOG: usuário = AUTORIDADE NT\SERVIÇO DE REDE
    LOG: DisplayName = System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35
     (Fully-specified)
    LOG: Appbase = file:///C:/Inetpub/Hidroexterno/
    LOG: PrivatePath inicial = C:\Inetpub\Hidroexterno\bin
    Chamando assembly: (Unknown).
    ===
    LOG: esta ligação começa no contexto de carregamento default.
    LOG: usando arquivo de configuração de aplicativo: C:\Inetpub\Hidroexterno\web.config
    LOG: usando arquivo de configuração de host: \\?\c:\windows\microsoft.net\framework\v2.0.50727\aspnet.config
    LOG: usando arquivo de configuração da máquina de c:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\config\machine.config.
    LOG: referência pós-diretiva: System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35
    LOG: tentando download de nova URL file:///c:/WINDOWS/Microsoft.NET/Framework/v2.0.50727/Temporary ASP.NET Files/root/c271de14/6bdadfdc/System.Web.Extensions.DLL.
    LOG: tentando download de nova URL file:///c:/WINDOWS/Microsoft.NET/Framework/v2.0.50727/Temporary ASP.NET Files/root/c271de14/6bdadfdc/System.Web.Extensions/System.Web.Extensions.DLL.
    LOG: tentando download de nova URL file:///C:/Inetpub/Hidroexterno/bin/System.Web.Extensions.DLL.
    LOG: tentando download de nova URL file:///C:/Inetpub/Hidroexterno/bin/System.Web.Extensions/System.Web.Extensions.DLL.
    LOG: tentando download de nova URL file:///c:/WINDOWS/Microsoft.NET/Framework/v2.0.50727/Temporary ASP.NET Files/root/c271de14/6bdadfdc/System.Web.Extensions.EXE.
    LOG: tentando download de nova URL file:///c:/WINDOWS/Microsoft.NET/Framework/v2.0.50727/Temporary ASP.NET Files/root/c271de14/6bdadfdc/System.Web.Extensions/System.Web.Extensions.EXE.
    LOG: tentando download de nova URL file:///C:/Inetpub/Hidroexterno/bin/System.Web.Extensions.EXE.
    LOG: tentando download de nova URL file:///C:/Inetpub/Hidroexterno/bin/System.Web.Extensions/System.Web.Extensions.EXE.
    

    MCP/MCDST/MCTS/MCITP
    quinta-feira, 17 de setembro de 2009 17:24
  • Leandro,


    Novamente vc não tem instalado no servidor esta tal de System.Web.Extensions.

    Conforme te falei, vc precisa verificar quais DLLs vc está utilizando e quais precisam esta no server.

    Grande Abraço!

    Jorge Vera - MCT/MCSA/MCITP/Small Business Specialist
    quinta-feira, 17 de setembro de 2009 20:48
    Moderador
  • Olá.
    Desculpe minha ignorância, ma como instalo esta  System.web.extensions e as dlls.
    MCP/MCDST/MCTS/MCITP
    sexta-feira, 18 de setembro de 2009 01:42
  • Leandro,

    veja esse fórum: http://forums.asp.net/p/1055304/1499963.aspx

    Abraço
    MVP - Daniel Santos Blog: http://engdanielc.spaces.live.com/
    sexta-feira, 18 de setembro de 2009 01:44
    Moderador
  • Blz Daniel.
    Mudou o erro agora pelo menos

    Detalhes da Exceção:

    System.Data.SqlClient.SqlException: Login failed for user 'hidr24'.

    Será que é só erro de user no  SQL?
    Porque ta dando erro na linha 42 que é esta.


    <add assembly="System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>

    MCP/MCDST/MCTS/MCITP
    sexta-feira, 18 de setembro de 2009 02:50
  • Opa,

    mais links: http://msdn.microsoft.com/en-us/library/24xy33d0.aspx

    http://weblogs.asp.net/coltk/archive/2003/07/10/9920.aspx

    Abraço
    MVP - Daniel Santos Blog: http://engdanielc.spaces.live.com/
    sexta-feira, 18 de setembro de 2009 17:06
    Moderador
  • Leandro,

    Esta tua questão é referente ao login no SQL Server verifica se teu usuário está criado no SQL server e se estiver verifica senha.

    Tenta fazer um teste com autenticação integrada no AD, depois muda para user do SQL.

    Grande Abraço!
    Jorge Vera - MCT/MCSA/MCITP/Small Business Specialist
    sábado, 19 de setembro de 2009 15:30
    Moderador