none
Erro Microsoft.Jet.OLEDB.4.0 RRS feed

  • Pergunta

  • Bom dia!

    Estou com um problema no meu Windows 7 e estou precisando da ajuda de vocês...

    Tenho um sistema em VB que importa uma planilha excel (excel 2007) para o banco de dados do servidor. Mas, ao executar essa operação recebo o erro "Run-Time error The OLE DB provider "Microsoft.Jet.OLEDB.4.0"has not been registered" (sou a administradora da máquina).

    Já vi problemas relacionados a esse provider em sistemas de 64 bits, mas não é o meu caso. Meu Windows 7 é de 32 bits. Alguém sabe o que pode ser?

    Obrigada,

    sexta-feira, 8 de abril de 2011 14:30

Respostas

Todas as Respostas

  • Nathalie,

    Existe um post falando do assunto.

    http://social.msdn.microsoft.com/Forums/pt-BR/520/thread/83edfd64-48d4-43c1-adb6-c5d59b848c37/

    Veja se te ajudo.

    Qualquer outra duvida estamos a disposição.

    Atenciosamente,


    Luiz Henrique Lima Campos
    Microsoft MCT,MCP,MCDST,MCSA,MCSA+M,MCTS e MCITP
    Visite o meu blog: http://luizhenriquelima.wordpress.com
    Me siga no Twitter: @luizlima
    **Ajude a melhorar o sistema de busca do fórum.Marque a(s) resposta(s) que foram úteis**
    sexta-feira, 8 de abril de 2011 15:18
    Moderador
  • Oi Luiz,

    obrigada pela resposta. Eu já tinha visto esse link, mas mudar a aplicação para usar SSIS não me parece uma alternativa. Isso pq ela funciona em todas as outras estações da empresa (com Windows XP).

    Esse driver não existe no Windows 7 de 32 bits? Pelo que tinha visto ele só não estaria disponível no 64 bits...

    segunda-feira, 11 de abril de 2011 12:26
  • Olá Nathalie123.

    O seu Windows 7 está com o SP1? Se não, faça a instalação do Service Pack 1, e veja se consegue usar a aplicação sem problemas.

     

    Abraço.

     


    Richard Juhasz - Microsoft LATAM Forum Support Engineer
    http://www.forumguys.com.br
    quarta-feira, 13 de abril de 2011 17:35
  • Oi Richard, o windows já está com o SP1 e o Office está com o SP mais recente. Mesmo assim não funciona o sistema.

     

    Obrigada,

    quarta-feira, 13 de abril de 2011 18:05
  • Olá Nathalie123.

    O ODBC está configurado na máquina? Tem máquina que funciona? Você está com a mesma versão do office na máquina que funciona e na máquina com problema?

     

     

    Abraço.

     


    Richard Juhasz - Microsoft LATAM Forum Support Engineer
    http://www.forumguys.com.br
    sexta-feira, 15 de abril de 2011 18:51
  • Olá Nathalie123.

    Alguma novidade sobre o problema?

     

    Abra;o.



    Richard Juhasz - Microsoft LATAM Forum Support Engineer
    http://www.forumguys.com.br
    • Sugerido como Resposta Abraão Marques terça-feira, 19 de abril de 2011 23:50
    • Não Sugerido como Resposta Abraão Marques terça-feira, 19 de abril de 2011 23:50
    terça-feira, 19 de abril de 2011 18:38
  • Oi Richard,

    desculpa a demora para te responder.Vamos as respostas...

     

    A versão do Office é a mesma utilizada em outras máquinas e o sistema funciona. Porém a grande alteração entre as máquinas é a versão do Windows. Essa é a 1a máquina com o Win 7.

     

    Sobre o ODBC,  ele não está configurado para esse sistema. Vou fazer o teste e posto a resposta assim que possível.

     

    Obrigada,

    quarta-feira, 20 de abril de 2011 12:42
  • Olá Nathalie.

    Sem problemas, só peço que deixe a thread atualizada a cada 24 horas, assim deixamos o fórum organizado.

    Qualquer dúvida, me avise.

     

    Abraço.

     


    Richard Juhasz - Microsoft LATAM Forum Support Engineer
    http://www.forumguys.com.br
    quarta-feira, 20 de abril de 2011 19:24
  • Novidades Nathalie?

    abs

    terça-feira, 26 de abril de 2011 10:29
    Moderador
  • Oi,

    fiz ontem a noite o  teste com o ODBC e não funcionou, o erro ficou o mesmo... Para não atrasar o trabalho da usuária da máquina, liberei um máquina com Windows XP  e o sistema funcionou sem erros nessa máquina.

    At,

    terça-feira, 26 de abril de 2011 12:36
  • Não sei se é o mesmo problema, mas quando o sistema tenta salvar informações em um banco access também ocorre um erro. A mensagem é outra:

    "Run-time error '-2147467259 (80004005)':
    As alterações solicitadas para a tabela não foram satisfatórias já que criaram valores duplicados no índice, chave primária ou relação.
    Altere os dados no campo ou cmapos que contêm os dados duplicados, remova o índice ou redefina o índice para possibilitar entradas duplicadas e tente novamente."

    Outra vez, o erro só acontece nessa máquina. As mesmas informações, em outra máquina, atualiza o banco access com sucesso. Investigando esse erro percebi que o arquivo ".ldb" aparece. O que me fez concluir que o erro ocorre quando tenta salvar as informações.

     

    Obrigada pela ajuda,

    terça-feira, 26 de abril de 2011 13:06