none
Windows Server 2012 Standard Desbloqueio de Portas RRS feed

  • Pergunta

  • Bom dia, quase 1 ano depois venho perguntar sobre o mesmo problema, mais em S.O diferente.

    Estou com um servidor com Windows Server 2012 Standard no qual tenho uma aplicação que roda o banco de dados em SQL Server 2012 também e está aplicação tem um módulo web.

    Neste momento o que preciso saber se há algum outro procedimento que tenho que fazer, pois já liberei as portas 1433 e as demais que utilizarei, no firewall do windows e no meu roteador e mesmo assim não consigo acessar o meu banco de dados remotamente e nem acessa a tela principal da aplicação web. Liberei também o acesso ao programa ddns que utilizo e mesmo assim não tenho acesso.

    Agradeço a atenção e aguardando ajuda.

    segunda-feira, 1 de dezembro de 2014 12:45

Respostas

  • Bom dia Nathan, desculpa pela demora no retorno do contato.

    Sim já fiz a configuração do NAT no router e também habilitei a DMZ como costumo fazer nos outros servidores que utilizo a mesma aplicação da mesma forma, onde somente este que está com o Windows Server 2012 não está me liberando as portas que preciso.

    Já realizei teste via comando NETSTAT -AN e ele só me retorna como se a porta 3389 estivesse liberada e estabelecendo conexão.

    Há mais alguma coisa que posso fazer para que consiga resolver este problema?

    Obrigado mais uma vez pela atenção.

    quarta-feira, 3 de dezembro de 2014 12:06
  • eu posso usar este comando também no Server 2012?

    netsh advfirewall firewall add rule name="Open Port 80" dir=in action=allow protocol=TCP localport=80

    @echo =========  SQL Server Ports  ===================
    @echo Enabling SQLServer default instance port 1433
    netsh advfirewall firewall add rule name="SQL Server" dir=in action=allow protocol=TCP localport=1433
    @echo Enabling Dedicated Admin Connection port 1434
    netsh advfirewall firewall add rule name="SQL Admin Connection" dir=in action=allow protocol=TCP localport=1434
    @echo Enabling Conventional SQL Server Service Broker port 4022
    netsh advfirewall firewall add rule name="SQL Service Broker" dir=in action=allow protocol=TCP localport=4022
    @echo Enabling Transact SQL/RPC port 135
    netsh advfirewall firewall add rule name="SQL Debugger/RPC" dir=in action=allow protocol=TCP localport=135
    @echo =========  Analysis Services Ports  ==============
    @echo Enabling SSAS Default Instance port 2383
    netsh advfirewall firewall add rule name="Analysis Services" dir=in action=allow protocol=TCP localport=2383
    @echo Enabling SQL Server Browser Service port 2382
    netsh advfirewall firewall add rule name="SQL Browser" dir=in action=allow protocol=TCP localport=2382

    @echo =========  Misc Applications  ==============
    @echo Enabling HTTP port 80
    netsh advfirewall firewall add rule name="HTTP" dir=in action=allow protocol=TCP localport=80
    @echo Enabling SSL port 443
    netsh advfirewall firewall add rule name="SSL" dir=in action=allow protocol=TCP localport=443
    @echo Enabling port for SQL Server Browser Service's 'Browse' Button
    netsh advfirewall firewall add rule name="SQL Browser" dir=in action=allow protocol=UDP localport=1434
    @echo Allowing multicast broadcast response on UDP (Browser Service Enumerations OK)
    netsh firewall set multicastbroadcastresponse ENABLE

    sexta-feira, 5 de dezembro de 2014 15:48
  • Nilton,

    Sim poder você até pode, mas se esta com dúvida, utilize a ferramenta gráfica do Firewall "wf.msc" para configurar todas as regras e demais exceções.


    Pedro Antonio Galvão Junior [MVP | Microsoft Evangelist | Microsoft Partner | Engenheiro de Softwares | Especialista em Banco de Dados | Professor Universitário | SoroCódigos] @JuniorGalvaoMVP | pedrogalvaojunior.wordpress.com

    sexta-feira, 5 de dezembro de 2014 15:53
    Moderador
  • Obrigado a todos pelas dicas, mais consegui resolver o problema.

    desabiltei o firewall do windows e direcionei o endereço do meu ddns para porta 81 e inseri após o endereço de acesso o caminho da pasta onde fica a aplicação web.

    Ex. endereco.ddns.me:81/nome da pasta da aplicação web

    Muito obrigado.

    terça-feira, 9 de dezembro de 2014 15:12

Todas as Respostas

  • Olá Nilton, como vai?

    Pelas configurações que descreveu, senti falta apenas do NAT no seu router de borda. Você realizou essa configuração?

    Apenas a liberação da porta não garante que, quando uma conexão externa chegar a seu router ela será direcionada ao seu BD na porta que deseja.

    Aguardo retorno


    Nathan Pinotti MCTS Infra | CCNA | CAPM | ITILv3

    segunda-feira, 1 de dezembro de 2014 12:51
  • Bom dia Nathan, desculpa pela demora no retorno do contato.

    Sim já fiz a configuração do NAT no router e também habilitei a DMZ como costumo fazer nos outros servidores que utilizo a mesma aplicação da mesma forma, onde somente este que está com o Windows Server 2012 não está me liberando as portas que preciso.

    Já realizei teste via comando NETSTAT -AN e ele só me retorna como se a porta 3389 estivesse liberada e estabelecendo conexão.

    Há mais alguma coisa que posso fazer para que consiga resolver este problema?

    Obrigado mais uma vez pela atenção.

    quarta-feira, 3 de dezembro de 2014 12:06
  • Nilton,

    Então, o que você vai ter que fazer é tentar configurar o seu Router e Firewall para fazer o encaminhamento das solicitações de rede para porta 1433 ao seu Servidor SQL Server.


    Pedro Antonio Galvão Junior [MVP | Microsoft Evangelist | Microsoft Partner | Engenheiro de Softwares | Especialista em Banco de Dados | Professor Universitário | SoroCódigos] @JuniorGalvaoMVP | pedrogalvaojunior.wordpress.com

    quarta-feira, 3 de dezembro de 2014 13:41
    Moderador
  • Olá Nilton.

    Já fez o famoso reset no router e checou as configurações? Infelizmente alguns equipamentos não funcionam tão bem para NAT.

    Como me garantiu que as demais configurações estão ok, esta seria nossa ultima tentativa.

    Abraço

    Se foi útil marque como resposta.


    Nathan Pinotti MCTS Infra | CCNA | CAPM | ITILv3

    quarta-feira, 3 de dezembro de 2014 18:03
  • Já fiz esse teste. tenho um router deste configurado da mesma forma com as mesmas portas, a única diferença o S.O que é um Windows Server 2003.
    sexta-feira, 5 de dezembro de 2014 14:24
  • eu posso usar este comando também no Server 2012?

    netsh advfirewall firewall add rule name="Open Port 80" dir=in action=allow protocol=TCP localport=80

    @echo =========  SQL Server Ports  ===================
    @echo Enabling SQLServer default instance port 1433
    netsh advfirewall firewall add rule name="SQL Server" dir=in action=allow protocol=TCP localport=1433
    @echo Enabling Dedicated Admin Connection port 1434
    netsh advfirewall firewall add rule name="SQL Admin Connection" dir=in action=allow protocol=TCP localport=1434
    @echo Enabling Conventional SQL Server Service Broker port 4022
    netsh advfirewall firewall add rule name="SQL Service Broker" dir=in action=allow protocol=TCP localport=4022
    @echo Enabling Transact SQL/RPC port 135
    netsh advfirewall firewall add rule name="SQL Debugger/RPC" dir=in action=allow protocol=TCP localport=135
    @echo =========  Analysis Services Ports  ==============
    @echo Enabling SSAS Default Instance port 2383
    netsh advfirewall firewall add rule name="Analysis Services" dir=in action=allow protocol=TCP localport=2383
    @echo Enabling SQL Server Browser Service port 2382
    netsh advfirewall firewall add rule name="SQL Browser" dir=in action=allow protocol=TCP localport=2382

    @echo =========  Misc Applications  ==============
    @echo Enabling HTTP port 80
    netsh advfirewall firewall add rule name="HTTP" dir=in action=allow protocol=TCP localport=80
    @echo Enabling SSL port 443
    netsh advfirewall firewall add rule name="SSL" dir=in action=allow protocol=TCP localport=443
    @echo Enabling port for SQL Server Browser Service's 'Browse' Button
    netsh advfirewall firewall add rule name="SQL Browser" dir=in action=allow protocol=UDP localport=1434
    @echo Allowing multicast broadcast response on UDP (Browser Service Enumerations OK)
    netsh firewall set multicastbroadcastresponse ENABLE

    sexta-feira, 5 de dezembro de 2014 15:48
  • Nilton,

    Sim poder você até pode, mas se esta com dúvida, utilize a ferramenta gráfica do Firewall "wf.msc" para configurar todas as regras e demais exceções.


    Pedro Antonio Galvão Junior [MVP | Microsoft Evangelist | Microsoft Partner | Engenheiro de Softwares | Especialista em Banco de Dados | Professor Universitário | SoroCódigos] @JuniorGalvaoMVP | pedrogalvaojunior.wordpress.com

    sexta-feira, 5 de dezembro de 2014 15:53
    Moderador
  • Obrigado. Mais ainda não estou conseguindo acessar nenhuma das portas abaixo:

    1433 / 443 / 81 etc.

    Esqueci de informar que não estou trabalhando em um domínio.

    Neste fim de semana fiz alguns testes e quando desabilitei o firewall testei as portas e elas foram abertas mais mesmo assim não consegui acessar a aplicação a qual estou direcionando para porta 81.

    Fiz todas as liberações que preciso no firewall do Windows e mesmo assim nada.

    Continuo Aguardando por ajuda.

    Obrigado.

    segunda-feira, 8 de dezembro de 2014 11:34
  • Obrigado a todos pelas dicas, mais consegui resolver o problema.

    desabiltei o firewall do windows e direcionei o endereço do meu ddns para porta 81 e inseri após o endereço de acesso o caminho da pasta onde fica a aplicação web.

    Ex. endereco.ddns.me:81/nome da pasta da aplicação web

    Muito obrigado.

    terça-feira, 9 de dezembro de 2014 15:12