none
Problema complicado com WSUS 3.0 SP2 RRS feed

  • Pergunta

  • Boa tarde caros colegas.

    Estou a mais ou menos 3 semanas tentando resolver um problema com o WSUS.
    Tenho um servidor Windows 2008 Ent. SP2 com AD nivel funcional Win 2008 e o WSUS instalado nele mesmo.

    Já instalei algumas vezes o WSUS em ambiente win 2003 e apenas seguindo as instruções do site http://www.guiamcse.com.br/artigos/Instalando_e_Configurando_o_WSUS_3_0.html instalei, as maquinas apareceram no WSUS, etc.

    Dessa vez em um abiente relativamente pequeno (16 estações) não consigo fazer as maquinas aparecerem no WSUS.

    Desabilitei o firewall das estações e do servidor.
    Rodei todos os scripts que achei na rede.
    No gpresult aparece as diretivas para o WSUS como vocês podem ver.

        Conjunto de diretivas resultante para o computador
        ---------------------------------------------------
    
            Instala‡äes de software
            -----------------------
                N/A
    
            Scripts de inicializa‡Æo
            ------------------------
                N/A
    
            Scripts de desligamento
            -----------------------
                N/A
    
            Diretivas de conta
            ------------------
                N/A
    
            Diretiva de auditoria
            ---------------------
                N/A
    
            Direitos do usu rio
            -------------------
                N/A
    
            Op‡äes de seguran‡a
            -------------------
                N/A
    
                N/A
    
            Configura‡äes de log de eventos
            -------------------------------
                N/A
    
            Grupos restritos
            ----------------
                N/A
    
            Servi‡os do sistema
            -------------------
                N/A
    
            Configura‡äes do Registro
            -------------------------
                N/A
    
            Configura‡äes do sistema de arquivos
            ------------------------------------
                N/A
    
            Diretivas de chave p£blica
            --------------------------
                N/A
    
            Modelos Administrativos
            -----------------------
                GPO: GPO PadrÆo
                    NomeChave:        Software\Policies\Microsoft\Windows\WindowsUpdate\AU\NoAutoRebootWithLoggedOnUsers
                    Valor:            1, 0, 0, 0
                    Estado:           Ativada
    
                GPO: GPO PadrÆo
                    NomeChave:        Software\Policies\Microsoft\Windows\WindowsUpdate\AU\IncludeRecommendedUpdates
                    Valor:            1, 0, 0, 0
                    Estado:           Ativada
    
                GPO: GPO PadrÆo
                    NomeChave:        Software\Policies\Microsoft\Windows\WindowsUpdate\AU\RebootRelaunchTimeout
                    Valor:            10, 0, 0, 0
                    Estado:           Ativada
    
                GPO: GPO PadrÆo
                    NomeChave:        Software\Policies\Microsoft\Windows\WindowsUpdate\AU\RebootWarningTimeoutEnabled
                    Valor:            1, 0, 0, 0
                    Estado:           Ativada
    
                GPO: GPO PadrÆo
                    NomeChave:        Software\Policies\Microsoft\Windows\WindowsUpdate\AU\RebootWarningTimeout
                    Valor:            5, 0, 0, 0
                    Estado:           Ativada
    
                GPO: GPO PadrÆo
                    NomeChave:        Software\Policies\Microsoft\Windows\WindowsUpdate\AU\RescheduleWaitTime
                    Valor:            1, 0, 0, 0
                    Estado:           Ativada
    
                GPO: GPO PadrÆo
                    NomeChave:        Software\Policies\Microsoft\Windows\WindowsUpdate\WUServer
                    Valor:            83, 0, 101, 0, 114, 0, 118, 0, 105, 0, 100, 0, 111, 0, 114, 0, 0, 0
                    Estado:           Ativada
    
                GPO: GPO PadrÆo
                    NomeChave:        Software\Policies\Microsoft\Windows\WindowsUpdate\AU\AutoInstallMinorUpdates
                    Valor:            1, 0, 0, 0
                    Estado:           Ativada
    
                GPO: GPO PadrÆo
                    NomeChave:        Software\Policies\Microsoft\Windows\WindowsUpdate\AU\AUOptions
                    Valor:            3, 0, 0, 0
                    Estado:           Ativada
    
                GPO: GPO PadrÆo
                    NomeChave:        Software\Policies\Microsoft\Windows\WindowsUpdate\AU\DetectionFrequencyEnabled
                    Valor:            1, 0, 0, 0
                    Estado:           Ativada
    
                GPO: GPO PadrÆo
                    NomeChave:        Software\Policies\Microsoft\Windows\WindowsUpdate\AU\DetectionFrequency
                    Valor:            3, 0, 0, 0
                    Estado:           Ativada
    
                GPO: GPO PadrÆo
                    NomeChave:        Software\Policies\Microsoft\Windows\WindowsUpdate\AU\NoAutoUpdate
                    Valor:            0, 0, 0, 0
                    Estado:           Ativada
    
                GPO: GPO PadrÆo
                    NomeChave:        Software\Policies\Microsoft\Windows\WindowsUpdate\AU\RebootRelaunchTimeoutEnabled
                    Valor:            1, 0, 0, 0
                    Estado:           Ativada
    
                GPO: GPO PadrÆo
                    NomeChave:        Software\Policies\Microsoft\Windows\WindowsUpdate\ElevateNonAdmins
                    Valor:            1, 0, 0, 0
                    Estado:           Ativada
    
                GPO: GPO PadrÆo
                    NomeChave:        Software\Policies\Microsoft\Windows\WindowsUpdate\WUStatusServer
                    Valor:            104, 0, 116, 0, 116, 0, 112, 0, 58, 0, 47, 0, 47, 0, 83, 0, 101, 0, 114, 0, 118, 0, 105, 0, 100, 0, 111, 0, 114, 0, 0, 0
                    Estado:           Ativada
    
                GPO: GPO PadrÆo
                    NomeChave:        Software\Policies\Microsoft\Windows\WindowsUpdate\AU\ScheduledInstallDay
                    Valor:            0, 0, 0, 0
                    Estado:           Ativada
    
                GPO: GPO PadrÆo
                    NomeChave:        Software\Policies\Microsoft\Windows\WindowsUpdate\AU\UseWUServer
                    Valor:            1, 0, 0, 0
                    Estado:           Ativada
    
                GPO: GPO PadrÆo
                    NomeChave:        Software\Policies\Microsoft\Windows\WindowsUpdate\AU\ScheduledInstallTime
                    Valor:            3, 0, 0, 0
                    Estado:           Ativada
    
                GPO: GPO PadrÆo
                    NomeChave:        Software\Policies\Microsoft\Windows\WindowsUpdate\AU\RescheduleWaitTimeEnabled
                    Valor:            1, 0, 0, 0
                    Estado:           Ativada
    



    Já desisntalei e reinstalei o WSUS e o IIS e nada até agora.

    Alguem tem alguma ideia do que eu possa fazer para solucionar isso?

    Agradeço muito a colaboração.

    sexta-feira, 16 de outubro de 2009 17:02

Respostas

  • Ricardo,

    No Windowsupdate.log ainda consta erro porem agora esta se referindo a porta que suas estaçoes usaram para se comunicar com o WSUS Server.

    Erro: GetConfig failure, error = 0x80244019, soap client error = 10, soap error code = 0, HTTP status code = 404

    Este erro aponta para a mesma configuraçào que estavamos fazendo antes HTTP://SERVIDOR porém de acordo com algumas pesquisas é necessário que adicione a porta sendo então;
    HTTP://SERVIDOR:8530

    Ambos os erros apontam para esta configuração.
    De uma olhada em;


    Confirm the port number in IIS and ensure it is included if it is not port 80. Example: "http://update.server.com:8530" . Remember to set the "update server" and the "statistics server" location.


    Após feito essa modificação rode um Gpupdate /force nas estações.

    wuauclt /detectnow /resetauthorization

    []`s


    Thiago Pereira | http://thiagoinfrat.spaces.live.com | http://www.winsec.org
    terça-feira, 27 de outubro de 2009 14:32
    Moderador

Todas as Respostas

  • Ricardo tudo bem?

    Este artigo que voce usou é muito bom para o começo e ajuda a dar uma base também, porém existem alguns outros pontos a serem considerados para o funcionamento do WSUS.

    - Valide se realmente as estações estão dentro da OU que voce criou a GPO.
    - valide se o serviço BITS esta automatico na estação.

    Se possível post aqui exatamente como voce configurou esta gpo.

    []`s
    Thiago Pereira | http://thiagoinfrat.spaces.live.com | http://www.winsec.org
    sexta-feira, 16 de outubro de 2009 18:09
    Moderador
  • Boa tarde Thiago.

    A minha maquina está com o BITS para ser iniciado automaticamente e o serviço está em execução, firewall desativado o sistema operacional é Windows 7 Pro.


    Gerei o relatorio da GPO disponibilizei no link.

    http://cid-d5d6fe440eea6572.skydrive.live.com/self.aspx/Publico/GPO%20Padr%c3%a3o.htm

    Att,

    Ricardo Lino Gonzalez
    sexta-feira, 16 de outubro de 2009 19:30
  • Alem deste relatorio, pode postar o Windowsupdate.log da maquina cliente aqui.
    Thiago Pereira | http://thiagoinfrat.spaces.live.com | http://www.winsec.org
    sexta-feira, 16 de outubro de 2009 19:32
    Moderador
  • Ricardo,

    A mensagem de erro apresentada no Log do Windows Update aponta para uma falha de configuração de GPO.

    " 2009-10-16 15:44:10:507 1028 aa4 PT WARNING: PTError: 0x80072ee6
    2009-10-16 15:44:10:507 1028 aa4 PT WARNING: Initialization failed for Protocol Talker Context: 0x80072ee6
    2009-10-16 15:44:10:507 1028 aa4 Report WARNING: Reporter failed to upload events with hr = 80072ee6.
    2009-10-16 15:57:25:560 1028 aa4 PT WARNING: PTError: 0x80072ee6
    2009-10-16 15:57:25:560 1028 aa4 PT WARNING: Initialization failed for Protocol Talker Context: 0x80072ee6
    2009-10-16 15:57:25:560 1028 aa4 Report WARNING: Reporter failed to upload events with hr = 80072ee6.
    2009-10-16 16:14:14:632 1028 928 PT WARNING: PTError: 0x80072ee6
    2009-10-16 16:14:14:632 1028 928 PT WARNING: Initialization failed for Protocol Talker Context: 0x80072ee6
    2009-10-16 16:14:14:632 1028 928 Report WARNING: Reporter failed to upload events with hr = 80072ee6.
    2009-10-16 16:19:11:304 1028 998 AU Windows Update is disabled by policy for user
    2009-10-16 16:19:21:008 1028 690 AU AU received policy change subscription event
    2009-10-16 16:25:50:681 1028 928 PT WARNING: PTError: 0x80072ee6
    2009-10-16 16:25:50:681 1028 928 PT WARNING: Initialization failed for Protocol Talker Context: 0x80072ee6
    2009-10-16 16:25:50:681 1028 928 Report WARNING: Reporter failed to upload events with hr = 80072ee6. "

    Na gpo onde voce coloca o nome do servidor faça da seguinte maneira HTTP://SERVIDOR.DOMINIO.COM aplique novamente e espere atualizar nas estações. (tenho quase certeza de que este é seu problema)

    Mas este erro pode ser outras causas tb, valide primeiro a passada acima e caso ainda sim não ajude valide este artigo;

    Troubleshooting Error 0x80072efd
    http://msmvps.com/blogs/Athif/articles/43174.aspx

    Qualquer duvida que tiver post aqui.

    []`s
    Thiago Pereira | http://thiagoinfrat.spaces.live.com | http://www.winsec.org
    sexta-feira, 16 de outubro de 2009 20:34
    Moderador
  • Bom dia Thiago,

    Vou fazer o teste entre hoje e amanhã, e te roporto aqui.
    Estou meio receoso com a questão do http://servidor.dominio.com pois já utilizei como http://ip-da-maquina e mesmo assim não estava respondendo.

    segunda-feira, 19 de outubro de 2009 10:54
  • Olá Thiago.

    Fiz todos os passos que você me passou, configurei a GPO http://servidor.dominio.com executei o script para forçar a atualização e mesmo assim dexei 1 dia esperando alguma estação comunicar.

    Como não tive resultado peguei o artigo que você me recomendou, executei tudo meno o proxycfg -d, pois não tem aqui nessa maquina esse comando.

    Utilizo o Windows 7 e já fiz uma pesquisa e nada.

    Att,

    Ricardo Lino Gonzalez
    terça-feira, 20 de outubro de 2009 11:48
  • Ricardo,

    Desta maquina Windows 7 voce consegue acessar todos os compartilhamentos no server WSUS?
    A resolução DNS esta oK?
    Windows 7 esta atualizado? recentemente sairam algumas atualizações para clientes Windows 7.
    Seu WSUS esta com SP2?

    Thiago Pereira | http://thiagoinfrat.spaces.live.com | http://www.winsec.org
    terça-feira, 20 de outubro de 2009 12:39
    Moderador
  • Atualizei o windows 7 hoje, 26 atualizações estavam pendentes hoje.
    Estive esperando até agora para ver se comunicava, mas nada ainda.

    Tenho 3 compartilhamentos WSUSTemp, WsusContent e UpdateServicesPackages, acredito que sejam somentes esses.

    O WSUS é o 3.0 SP2, também não há mais nenhuma atualização a ser feita no servidor.

    A resolução de nomes aparentemente está ok, pois a minha rede não apresenta nenhum tipo de problema.

    terça-feira, 20 de outubro de 2009 14:25
  • Ricardo,

    Todo o seu parque é composto por Windows 7? Alguma outa estação com SO diferente apresenta problemas? (XP,Vista)

    Se voce logar localmente nesta maquina e fazer o Windows Update através do site da Microsoft consegue ou tem algum erro?

    Thiago Pereira | http://thiagoinfrat.spaces.live.com | http://www.winsec.org
    terça-feira, 20 de outubro de 2009 15:01
    Moderador
  • Então como falei no começo, o parque aqui é misto, tenho windows XP, vista e 7.
    Se eu desabilito a regra e vou em qualquer maquina eu atualizo ele sem problema.

    Nenhuma maquina está aparecendo no WSUS.

    Como comentei no primeiro post, já fiz a instalação do WSUS pelo menos umas 8 vezes no windows 2003, sempre segindo o guia passo a passo de instalação e configuração tanto para clientes como para amigos que necessitavam de ajuda, nunca antes tive esse tipo de problema as instalações funcionavam de primeira.

    Agora com esse windows 2008 é que a coisa não funciona nada.

    GPO não acredito que seja, sempre configurei ela da mesma forma.
    A instalação do WSUS também não acredito que seja, pois executei ela como sempre.
    DNS também não, as aplicações estão funcionando, o AD está funcionando.

    Eu acredito que seja alguma coisa no Windows 2008 Server ou IIS 7, que são as unicas duas coisas que mudaram a forma como instalar/configurar.
    Há uma incompatilibidade do IIS 7 com o WSUS, tanto que deve-se intalar um modulo de compatibilidade do IIS 6 e no caso do Windows ele tem muito mais questões de segurança do que em versões anteriores como o firewall.

    O que você acha?
    terça-feira, 20 de outubro de 2009 16:03
  • Agora que voce mencionou de IIS que lembrei.
    Valide o diretório virtual se existe de acordo com este post: http://social.technet.microsoft.com/Forums/pt-BR/wsuspt/thread/af87452b-aa59-4941-8f10-0b8dcb230f2a

    Foi a resolução de desta Thread com o mesmo problema.

    []`s


    Thiago Pereira | http://thiagoinfrat.spaces.live.com | http://www.winsec.org
    terça-feira, 20 de outubro de 2009 16:26
    Moderador
  • Ola thiago,

    Cara queria te agradecer pela sua perseverança.

    Dei um olhada no IIS eu tenho o diretorio virtual com o nome Selfupdate e o caminha fisico C:\Program Files\Update Services\Selfupdate.

    A autenticação anonima está habilitada.
    Nunhum outro tipo de autenticação está habilitada.

    terça-feira, 20 de outubro de 2009 18:17
  • Complicado eim....!!!

    Vá em algumas máquinas clientes e veja a chave de registro: HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate e esta chave deve estar apontando para o teu WSUS. (caso nao post aqui)

    Se a opção acima estiver correta rode a ferramenta Client Diagnostic Tool que esta neste link: http://technet.microsoft.com/en-us/wsus/bb466192.aspx e rode no cliente e poste aqui o resultado.

    Vamos ver noque vai dar este post.

    []`s
    Thiago Pereira | http://thiagoinfrat.spaces.live.com | http://www.winsec.org
    terça-feira, 20 de outubro de 2009 18:51
    Moderador
  • Bom dia Thiago,

    Acho que chegamos ao problema.


    WSUS Client Diagnostics Tool

    Checking Machine State
     Checking for admin rights to run tool . . . . . . . . . PASS
     Automatic Updates Service is running. . . . . . . . . . PASS
     Background Intelligent Transfer Service is running. . . PASS
     Wuaueng.dll version 7.3.7600.16385. . . . . . . . . . . PASS
      This version is WSUS 2.0

    Checking AU Settings
     AU Option is 3 : Notify Prior to Install. . . . . . . . PASS
      Option is from Policy settings

    Checking Proxy Configuration
     Checking for winhttp local machine Proxy settings . . . PASS
      Winhttp local machine access type
       <Direct Connection>
      Winhttp local machine Proxy. . . . . . . . . .  PASS
      Winhttp local machine ProxyBypass. . . . . . .  PASS
     Checking User IE Proxy settings . . . . . . . . . . . . PASS
      User IE Proxy. . . . . . . . . . . . . . . . .  PASS
      User IE ProxyByPass. . . . . . . . . . . . . .  PASS
      User IE AutoConfig URL Proxy . . . . . . . . .  PASS
      User IE AutoDetect
      AutoDetect not in use

    Checking Connection to WSUS/SUS Server
      WUServer = 192.168.0.50
      WUStatusServer = http://192.168.0.50
     UseWuServer is enabled. . . . . . . . . . . . . . . . . PASS

    A URL não usa um protocolo reconhecido

    Esse é o resultado com -t onde ele cria o arquivo de log, na execução normal aparece mais uma mensagem que aqui não está descrita.

    VerfiWUServerURL<> failed with hr=0x80072ee6

    A URL não usa um protocolo reconhecido

    quarta-feira, 21 de outubro de 2009 11:31
  • Rodrigo,

    Tambem acho que chegamos na tua solução. Ao invés de colocar na GPO o IP da máquina, coloque HTTP://NOMEDOSERVIDOR.DOMINIO.COM entende e agora force a detecção dos clientes para teste.

    Depois que mudar isso no server execute um gpupdate /force no server e no cliente, rode a ferramenta novamente e veja se mudou para o formato acima. Espere uns 15 min e use o comando wuauclt.exe /detectnow 

    Feito isso elas irão comunicar.

    Post o resultado


    Thiago Pereira | http://thiagoinfrat.spaces.live.com | http://www.winsec.org
    quarta-feira, 21 de outubro de 2009 13:32
    Moderador
  • Olá Thiago,

    Ainda não foi isso.

    WSUS Client Diagnostics Tool

    Checking Machine State
     Checking for admin rights to run tool . . . . . . . . . PASS
     Automatic Updates Service is running. . . . . . . . . . PASS
     Background Intelligent Transfer Service is running. . . PASS
     Wuaueng.dll version 7.3.7600.16385. . . . . . . . . . . PASS
      This version is WSUS 2.0

    Checking AU Settings
     AU Option is 3 : Notify Prior to Install. . . . . . . . PASS
      Option is from Policy settings

    Checking Proxy Configuration
     Checking for winhttp local machine Proxy settings . . . PASS
      Winhttp local machine access type
       <Direct Connection>
      Winhttp local machine Proxy. . . . . . . . . .  PASS
      Winhttp local machine ProxyBypass. . . . . . .  PASS
     Checking User IE Proxy settings . . . . . . . . . . . . PASS
      User IE Proxy. . . . . . . . . . . . . . . . .  PASS
      User IE ProxyByPass. . . . . . . . . . . . . .  PASS
      User IE AutoConfig URL Proxy . . . . . . . . .  PASS
      User IE AutoDetect
      AutoDetect not in use

    Checking Connection to WSUS/SUS Server
      WUServer = SERVIDOR
      WUStatusServer = http://SERVIDOR.BRASIL.ICCS
     UseWuServer is enabled. . . . . . . . . . . . . . . . . PASS

    A URL não usa um protocolo reconhecido

    Mesma mensagem

    Será que não falta algum componente do IIS 7 para instalar?

    Inclui uma imagem do skydrive com todos os recursos que estão disponiveis no IIS 7
    http://cid-d5d6fe440eea6572.skydrive.live.com/self.aspx/Publico/IIS7%20Servi%c3%a7os%20de%20fun%c3%a7%c3%b5es.jpg

    Espero que ajude a achar esse problema.

    quarta-feira, 21 de outubro de 2009 15:10
  • Ricardo,

    Em qual porta voce instalou seu WSUS? 80 ou 8530? Se voce instalou o WSUS no website Default esta na porta 80, mas se criou um customizado esta na 8530.
    Pergunto isso pq se voce configurou em uma outra porta terá que indicar da seguinte forma http://WSUSServerName:portnumber

    Vou te pedir mais alguns testes;

    na gpo onde voce aponta o noem do WSUS Server coloca assim;

    HTTP://SERVERNAME veja se as estacoes sincronizam caso contrário tente HTTPS://SERVERNAME (coloque apenas o nome do servidor).

    No Aguardo. )


    Thiago Pereira | http://thiagoinfrat.spaces.live.com | http://www.winsec.org
    quarta-feira, 21 de outubro de 2009 18:55
    Moderador
  • Ola Thiago.

    Na sua primeira pergunta, não fiz nenhuma alteração na configuração da instalação do WSUS, ele está na porta 80 mesmo.
    Fiz algumas pesquisas na internet e segui alguns testes com o WSUS.

    http://servidor/SelfUpdate/wuident.cab 
    http://servidor.brasil.iccs/selfupdate/iuident.cab 
    http://servidor.brasil.iccs/iuident.cab
    http://servidor/iuident.cab

    com esses comandos eu consigo fazer o download do arquivo.

    se na indicação do servidor eu colocar a porta 8530 dá erro.

    na GPO já coloquei http://servidor agora como https ainda não tentei, mas vou tentar agora.

    quinta-feira, 22 de outubro de 2009 11:08
  • Eae Ricardo,

    Fez os testes?
    Thiago Pereira | http://thiagoinfrat.spaces.live.com | http://www.winsec.org
    quinta-feira, 22 de outubro de 2009 18:39
    Moderador
  • Fiz sim, mas nada ainda.
    Fiz também outras buscas na internet e outros testes.
    Primeiramente desisntalei o WSUS e reinstalei colocando ele na porta 8530, não funcionou também.

    achei essa thread onde fala sobre o erro, e como foi solucionado.
    http://social.technet.microsoft.com/Forums/pt-BR/wsuspt/thread/cbf9c127-8a6c-4be0-9225-a017a2718824

    Pelo menos o erro no WSUS Client Diagnostic Tool não é mais apresentado como você pode ver no log.

    O unico problema é que até agora as estações não apareceram no WSUS, vou aguardar mais um pouco e acompanhar.


    WSUS Client Diagnostics Tool

    Checking Machine State
     Checking for admin rights to run tool . . . . . . . . . PASS
     Automatic Updates Service is running. . . . . . . . . . PASS
     Background Intelligent Transfer Service is running. . . PASS
     Wuaueng.dll version 7.3.7600.16385. . . . . . . . . . . PASS
      This version is WSUS 2.0

    Checking AU Settings
     AU Option is 3 : Notify Prior to Install. . . . . . . . PASS
      Option is from Policy settings

    Checking Proxy Configuration
     Checking for winhttp local machine Proxy settings . . . PASS
      Winhttp local machine access type
       <Direct Connection>
      Winhttp local machine Proxy. . . . . . . . . .  PASS
      Winhttp local machine ProxyBypass. . . . . . .  PASS
     Checking User IE Proxy settings . . . . . . . . . . . . PASS
      User IE Proxy. . . . . . . . . . . . . . . . .  PASS
      User IE ProxyByPass. . . . . . . . . . . . . .  PASS
      User IE AutoConfig URL Proxy . . . . . . . . .  PASS
      User IE AutoDetect
      AutoDetect not in use

    Checking Connection to WSUS/SUS Server
      WUServer = http://SERVIDOR.BRASIL.ICCS
      WUStatusServer = http://SERVIDOR.BRASIL.ICCS
     UseWuServer is enabled. . . . . . . . . . . . . . . . . PASS
      Client is pointed to SUS 1.0 Server
     Connection to server. . . . . . . . . . . . . . . . . . PASS
     SelfUpdate folder is present. . . . . . . . . . . . . . PASS

    sexta-feira, 23 de outubro de 2009 11:25
  • Post novamente o windowsupdate.log para vermos se o erro saiu agora.
    Se ainda nao esta aparecendo provavelmente vai acusar outra coisa....!!

    Thiago Pereira | http://thiagoinfrat.spaces.live.com | http://www.winsec.org
    sexta-feira, 23 de outubro de 2009 19:51
    Moderador
  • Boa Tarde Srs,

    Ricardo pelo que li nesse post, me parece que está complicado de se resolver, mas vamos lá:
    Dê inicio verifica para mim se a GPO está ok, ou seja, se em "Painel de Controle\Sistema e Segurança\Windows Update" > "Alterar Configurações" está informando que as configurações estão gerenciadas pelo Administrador do Sistema.


    Vanderson dos Santos Cahet - MCSA 2003
    • Editado Vanderson Cahet segunda-feira, 26 de outubro de 2009 16:29 Ortografica
    segunda-feira, 26 de outubro de 2009 16:28
  • Olá Thiago,

    Segue o link do WindowsUpdate.log

    http://cid-d5d6fe440eea6572.skydrive.live.com/self.aspx/Publico/WindowsUpdate.log

    Muito obrigado, desculpe a demora em responder.
    terça-feira, 27 de outubro de 2009 11:27
  • Olá Vanderson,

    Segui os passos que você me passou, realmente aparece da forma como você descreveu.
    Não posso alterar nenhuma configuração e no topo aparece a mensagem "Algumas configurações são gerenciadas pelo administrador do sistema. Mais informações."

    Se eu vou em CMD gpresult me mostra que a GPO foi aplicada no computador e no usuario.
    terça-feira, 27 de outubro de 2009 11:37
  • Bom dia Ricardo,

    A GPO foi criada e está sendo aplicada, certo.
    Verifica agora se o nome do grupo criado no WSUS é identico ao especificado na GPO.

    Fico no Aguardo,
    Vanderson dos Santos Cahet - MCSA 2003
    terça-feira, 27 de outubro de 2009 14:05
  • Olá Vanderson,

    Bom na GPO não expecifiquei nenhum grupo deixei no modo não configurado, assim dessa forma eu terei que informar manualmente aos computadores qual grupo ele fará parte.

    terça-feira, 27 de outubro de 2009 14:22
  • Ricardo,

    No Windowsupdate.log ainda consta erro porem agora esta se referindo a porta que suas estaçoes usaram para se comunicar com o WSUS Server.

    Erro: GetConfig failure, error = 0x80244019, soap client error = 10, soap error code = 0, HTTP status code = 404

    Este erro aponta para a mesma configuraçào que estavamos fazendo antes HTTP://SERVIDOR porém de acordo com algumas pesquisas é necessário que adicione a porta sendo então;
    HTTP://SERVIDOR:8530

    Ambos os erros apontam para esta configuração.
    De uma olhada em;


    Confirm the port number in IIS and ensure it is included if it is not port 80. Example: "http://update.server.com:8530" . Remember to set the "update server" and the "statistics server" location.


    Após feito essa modificação rode um Gpupdate /force nas estações.

    wuauclt /detectnow /resetauthorization

    []`s


    Thiago Pereira | http://thiagoinfrat.spaces.live.com | http://www.winsec.org
    terça-feira, 27 de outubro de 2009 14:32
    Moderador
  • Ricardo,

    Faça o seguinte:
    Edite a GPO do WSUS "Propriedade de habilitar direcionamento no lado do cliente" para ativado e Coloque um nome (ex.: "nome da sua empresa").
    Depois vá no WSUS e em todos os computadores crie um grupo com nome identico ao criado no GPO.
    Vá depois em "Opções > Computadores" e verifique se está marcada a opção "Usar diretiva de grupo".

    Fico no Aguardo.
    Vanderson dos Santos Cahet - MCSA 2003
    terça-feira, 27 de outubro de 2009 14:47
  • Olá Thiago,

    O problema foi resulvido, coloquei em ambas as caixa de edição http://servidor:8530 e já começou a aparecer os computadores no WSUS.

    Gostaria de agradecer muito a sua colaboração e paciencia.

    Muito obrigado.
    Até mais.
    terça-feira, 27 de outubro de 2009 15:13
  • Aeeeeeeeeee.....o filho nasceu. = )

    Ricardo eu que fico feliz em lhe ajudar amigo e agora espero que este post possa ajudar outras pessoas com a mesma dúvida.

    Grande Abraço.

    Thiago Pereira | http://thiagoinfrat.spaces.live.com | http://www.winsec.org
    terça-feira, 27 de outubro de 2009 15:27
    Moderador
  • Nossa eu também espero.
    terça-feira, 27 de outubro de 2009 15:30