none
Acesso ao Receve Conector só encriptado para os clientes Outlook RRS feed

  • Pergunta

  • Boas a todos,

    Como poço forçar no Exchange Server 2007 os clientes do Outlook a só conseguirem aceder ao Receve Conector (SMTP) de forma encriptada (TLS) ?

    Por defeito o meu Exchange está a deixar os clientes Outlook aceder com e sem ligação encriptada, mas eu pretendia que foce só unicamente encriptada em TLS.

    Obrigados

    sábado, 20 de dezembro de 2008 20:18

Respostas

  • Obrigados Anderson e Rodrigo por me tentarem ajudar.

     

    Resolvi a situação removendo o visto da caixa “Integrated Windows Autentication” e mantive os vistos nas outras caixas excepto a última no Guia “Autentication” do “Reveive Conector  - Default”.

    Assim já consigo forçar os clientes do Outlook a só usarem uma ligação encriptada em TLS no envio das mensagens de correio.

    domingo, 21 de dezembro de 2008 12:22
  • Ola Apaxe,

     

    Marque os posts que te ajudaram a chegar na soluçao, desta forma tu tb ajuda o fórum. No teu caso nao te aconselho a fazer isto no default e sim usar um somente para o fluxo interno como eu havia falado anterior, primeiro para controlar relay externo e outro para que no futuro nao atrapalha a comunicacao entre futuros hub transports.

     

    Pelo que vi a única diferença foi que na guia que eu mencionei tu nao criaste um novo receive connector, somente alteraste o existente, correto?

     

    domingo, 21 de dezembro de 2008 13:11

Todas as Respostas

  • Ola Apaxe,

    O que exatamente você quer fazer?
    Veja esses dois artigos e se é isso que quer:
    http://www.msexchange.org/tutorials/Securing-SMTP-Message-Flow-between-different-Exchange-Server-2007-organizations.html
    http://technet.microsoft.com/en-us/library/bb430753.aspx

    Abs.
    sábado, 20 de dezembro de 2008 20:21
  • Olá Rodrigo Rodrigues, muito obrigado por ter respondido.

    No meu Exchange Server 2007 em “Server Configuration/ Hub Transport /Receve Conectors” tenho o meu “Receve Conector - Default” no Guia Authentication com vistos em tudo excepto no Externally Secured.

    Os clientes configurados no Outlook conseguem enviar Emails sem serem obrigados a usarem uma ligação encriptada em TLS.

    O que eu pretendia é que as contas que estão configuradas no Outlook fossem obrigadas  a só usarem uma ligação SMTP encriptada ao Exchange 2007.

    Não sei o que me está faltando configurar no Exchange para obrigar os clientes configurados no Outlook a só usarem unicamente uma ligação SMTP encriptada.

    sábado, 20 de dezembro de 2008 20:50
  • Ola Apaxe,

    Se for o que estou pensando, usar SMTP com TLS, essa configuração alem do Exchange 2007 deve ser feita no cliente Outlook, ou seja, tem que marcar nas opções avançadas para ele usar TLS. Você marcou isso?

    Abs.
    sábado, 20 de dezembro de 2008 21:25
  • Olá Rodrigo, mais uma vez obrigado,

     

    Sim, eu marquei nas opções avançadas das contas do Outlook para usarem o TLS e tudo funciona bem.

    O problema é que se tambem marcar as contas para não usarem o TLS os clientes tambem conseguem enviar Emails. Eu pretendia que isso não fosse possivel, ou seja, se alguma conta retirar o TLS nas opções avançadas que tive-se uma mensagem de erro no envio e fosse obrigada a voltar a usar o TLS no envio de mensagens.

     

    Por tal pergunto que configuração devo acrescentar no Exchange para obrigar os clientes do Outlook, no envio, a efecturem unica e exclusivamente de uma ligação encriptada?

    sábado, 20 de dezembro de 2008 23:35
  • Ola Apaxe,

     

    Configure um novo ip par ao hub transport, crie um receive connector e configure autenticacao somente TLS e somente usuarios autenticados se for o caso e configure os clientes para usar este novo IP.

     

    Mas cara, para que fazer esta novela toda se é só configurar rpc over http e outlook que já tem tal proteçao para recebimento e envio?

     

     

    domingo, 21 de dezembro de 2008 03:46
  • Obrigados Anderson e Rodrigo por me tentarem ajudar.

     

    Resolvi a situação removendo o visto da caixa “Integrated Windows Autentication” e mantive os vistos nas outras caixas excepto a última no Guia “Autentication” do “Reveive Conector  - Default”.

    Assim já consigo forçar os clientes do Outlook a só usarem uma ligação encriptada em TLS no envio das mensagens de correio.

    domingo, 21 de dezembro de 2008 12:22
  • Ola Apaxe,

     

    Marque os posts que te ajudaram a chegar na soluçao, desta forma tu tb ajuda o fórum. No teu caso nao te aconselho a fazer isto no default e sim usar um somente para o fluxo interno como eu havia falado anterior, primeiro para controlar relay externo e outro para que no futuro nao atrapalha a comunicacao entre futuros hub transports.

     

    Pelo que vi a única diferença foi que na guia que eu mencionei tu nao criaste um novo receive connector, somente alteraste o existente, correto?

     

    domingo, 21 de dezembro de 2008 13:11
  • Olá Anderson, mais uma vez obrigado.

     

    Sim, eu não crei mais nenhum receive connector, simplesmente alterei o existente (Default).

    Eui não criei mais nenhum receive connector porque tenho clientes internos e externos à rede acederem ao exchange.

     

    Em relação ao Relay, pelos teste que fiz o meu servidor não está aceitar Relay Anonimo.

     

    Pode-me indicar  a melhor configuração para este caso (clientes externos tambem acederem ao exchange via Outlook)?

    domingo, 21 de dezembro de 2008 13:35