none
Sharepoint Services 3.0 - HTTP status 401: Unauthorized. RRS feed

  • Pergunta

  • Boa tarde pessoal!

    Estou tendo esse problema já faz aproximadamente 1 semana, direto estou tentando realizar a integração do WSS 3.0 com Reporting Services, mas estou tendo problemas.

    Começemos:

    Anteriormente:

    Tinha o SQL Server 2005 Standard, o Reporting Services, o Sharepoint Services 3.0, o Add-in do Sharepoint todos no mesmo computador dentro de um domínio.

    Então a integração não foi muito difícil não, coloquei o banco de dados para Sharepoint Integration e configurei todos os 3 passos, com as contas locais no WEB SERVICE IDENTITY no (REPORTING SERVICES CONFIGURATION MANAGER)

    Até ai estava feliz!

    Mas como apresentei essa idéia para meu chefe, ele quer implementar em toda empresa então!!

    Então começando a pensar em colocar em PRODUÇÃO, instalei uma VM Windows Server 2003 já no domínio.

    Cenário Atual:

    Instalei o sharepoint services 3.0 no windows sever 2003 standard, instalei o add-in do mesmo, só que agora quero que o banco de dados consultado não seja local, mais sim dessa máquina do cenário anterior.

    O problemá é que como estou em um domínio, não posso mais rodar o WEB SERVICE IDENTITY do (REPORTING SERVICES CONFIGURATION MANAGER) com uma conta LOCAL, preciso agora passar outra conta, mas nenhuma conta funciona, então quando especifíco a minha conta do domínio que tem acesso ao banco de dados e ao conteúdo do WSS 3.0 não consigo tambêm, quando vou na máquina do windows server 2003 e tento acessar a parte de

    Definir padrões do servidor

     

    recebo o seguinte erro:

    Erro inesperado ao conectar-se ao servidor de relatórios. Verifique se esse servidor está disponível e configurado para o modo integrado do SharePoint. --> Server was unable to process request. ---> The request failed with HTTP status 401: Unauthorized.

    Gostaria de saber uma solução para isso, porque tenho que colocar o WSS 3.0 e o Add-in em um servidor de produção e conseguir conectar no banco de dados de produção que írá ficar em uma máquina diferente do WSS 3.0.

     

    Muito obrigado.

     

    sexta-feira, 9 de julho de 2010 20:47

Respostas

  • Olá Luan,

    Tudo bem?

    Tente o seguinte:

    http://support.microsoft.com/kb/896861/en-us

    Os passos são estes:

  • Clique Start, clique Run, digite regedit, e então clique OK.
  • No Editor de Registros, localize e então clique na seguinte chave de registro:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa

  • Clique com o botão direito em Lsa, então New, e então clique em DWORD Value.
  • Digite DisableLoopbackCheck, e então pressione ENTER.
  • Clique com botão direito em DisableLoopbackCheck, e então clique em Modify.
  • Na caixa Value data, digite 1, e então clique OK.
  • Saia do Editor de Registros, e reinicie o computador (em alguns casos, não é necessário reiniciar, eu não precisei.

    http://www.canalsharepoint.com.br/thiagosilva/Lists/Postagens/Post.aspx?ID=9


  • Thiago Silva SharePoint Specialist - Done IT http://www.doneit.com.br http://www.canalsharepoint.com.br
domingo, 8 de agosto de 2010 18:18