none
Planilha do Excel travando ao salvar RRS feed

  • Pergunta

  • Tenho uma planilha do Excel que esta em um servidor de rede.

    Esta planilha tem 03 MB e ao fazer alterações nela e tentar salvar, ocorre que aparece uma janela de salvando com uma barra verde e fica o tempo todo não salvando o arquivo.

    O office é 2007 e a planilha foi salva inicialmente para o formato xls.

    O usuário possui permissão na pasta, o office ja foi reparado, e a planilha esta travando também ao salvar a partir de outro micro.

    Notei que ao tentar salvar as alterações cria-se um arquivo temporário na unidade, porém a planilha fica como "salvando" mas não salva.

    Depois disso se eu  cancelo  o salvamento, o processo do Excel fica preso no windows e nao consegue-se matar processo sendo necessário desligar a maquina e religar novamente.

    Alguém pode me dar uma luz?

    quarta-feira, 25 de maio de 2011 00:21

Respostas

  • Isso só reforça mais ainda que o problema está na sua rede,

    Nao tem ferramenta microsft pra vc monitorar isso.

    Verifica seu servidro como está.

    Verifica cabeamento.

    Tenta colocar a planilha em algum compuador da rede e comaprtilahr a pasta de outro computador que nao o servidor, e vej ase o problema ocorre novamente,

    Verifique tbm firewall e antivirus do seu servidor.

     


    Diego Piffaretti- www.mundotecnologico.net
    • Marcado como Resposta Diego Piffaretti segunda-feira, 6 de junho de 2011 17:34
    sexta-feira, 3 de junho de 2011 16:40
  • Pessoal,

    Consegui achar a causa do problema.

    Tenho o symantec end point instalado nas estações, quando parei o serviço do symantec consegui continuar o salvamento normalmente.

    Ja estou em contato como suporte symantec para me auxiliarem a contornar o problema

    Obrigado a todos.

    • Marcado como Resposta Diego Piffaretti segunda-feira, 6 de junho de 2011 17:34
    segunda-feira, 6 de junho de 2011 17:03

Todas as Respostas

  • Experimente salvar no formato nativo do seu Excel 2007, isto é, .xlsx ou .xlsm.


    Felipe Costa Gualberto - http://www.ambienteoffice.com.br
    quarta-feira, 25 de maio de 2011 01:55
  • Salvei no formato nativo (xlsx) e o problema do travamento continuou.

     

    quarta-feira, 25 de maio de 2011 12:04
  • Crie um backup da Pasta de Trabalho.

    Abra o backup. Pressione F5, clique em Especial, selecione Objetos e clique em OK. Pressione delete para apagar todos os objetos.

    Em seguida, tente salvar de novo.

    *Nota: todos os shapes/formulários serão apagados.

    Funcionou?


    Felipe Costa Gualberto - http://www.ambienteoffice.com.br
    quarta-feira, 25 de maio de 2011 12:07
  • Fiz o teste mas ele nao encontrou nenhum objeto na planilha.

     

    Um detalhe interessante é o seguinte, fiz um teste copiando a planilha para outro servidor e neste outro servidor consegui salvá-la sem problemas.

    Sera que o windows server faz algum tratamento especifico em salvamento e arquivos temporários, sera que o problema pode estar ai?

    O interessante é que só ocorre com esta planilha de 03 MB.

    quarta-feira, 25 de maio de 2011 14:09
  • Última sugestão: copie a Planilha inteira e cole como valores numa Planilha em branco e tente salvar novamente.
    Felipe Costa Gualberto - http://www.ambienteoffice.com.br
    quarta-feira, 25 de maio de 2011 14:27
  • Ja tentei isso porém nao aparece nenhum objeto.

    O interessante é que coloquei a mesma planilha em outro servidor de rede e consegui salva-la normalmente.

    Sera que tem algum tratamento diferenciado do servidor para com arquivos temporários do excel?

    quarta-feira, 25 de maio de 2011 14:48
  • Um minuto. O que você tentou fazer, nessa minha última sugestão?

    É para você copiar valores, não tem relação com objetos.

    Você tentou colar como valores em uma nova Pasta de Trabalho em branco e depois salvar?


    Felipe Costa Gualberto - http://www.ambienteoffice.com.br
    quarta-feira, 25 de maio de 2011 15:47
  • São mais de 20 planilhas dentro de uma pasta de trabaho.

    Se eu fizer isso posso perder as formulas, nao posso.

    Ja copiei a planilha toda para outra planilha em branco e obtive o mesmo resultado, travamento no salvar.

    quarta-feira, 25 de maio de 2011 19:43
  • Sub CopiarPastaTrabalho()
    
      'Faça backup da Pasta original antes de rodar a macro.
    
      Dim l As Long
      Dim wb As Workbook
      Dim ws As Worksheet
      Dim wsOrigem As Worksheet
      Dim wsDestino As Worksheet
      
      Set wb = Workbooks.Add
      
      For Each wsOrigem In ThisWorkbook.Sheets
        Set wsDestino = wb.Sheets.Add(After:=wb.Sheets(wb.Sheets.Count))
        On Error Resume Next
        wsDestino.Name = wsOrigem.Name
        On Error GoTo 0
        wsOrigem.Cells.Copy
        wsDestino.Cells.PasteSpecial xlPasteValues
        wsDestino.Cells.PasteSpecial xlPasteFormulas
        'Rode a macro. Se funcionar e conseguir salvar a nova Pasta de Trabalho
        'gerada, rode novamente removendo o comentário do comando abaixo:
        'wsDestino.Cells.PasteSpecial xlPasteFormats
      Next wsOrigem
      
      Application.DisplayAlerts = False
      If wb.Sheets.Count > 1 Then
        For l = 1 To Application.SheetsInNewWorkbook
          wb.Sheets(1).Delete
        Next l
      End If
    End Sub

    Felipe Costa Gualberto - http://www.ambienteoffice.com.br
    quarta-feira, 25 de maio de 2011 21:26
  • OK!

    Uma dúvida, este codigo vba apenas copia as planilhas para um outro arquivo, ou ele faz algum outro tratamento diferente.

    quinta-feira, 26 de maio de 2011 12:36
  • O que significa OK? Deu certo?

    Esse código copia uma Pasta de Trabalho em outra, inclusive todas as Planilhas.

    No entanto, copia apenas Valores, Fórmulas e, se retirar o comentário do código, copiar formatos também. Qualquer outras coisas além disso não serão copiados.


    Felipe Costa Gualberto - http://www.ambienteoffice.com.br
    quinta-feira, 26 de maio de 2011 17:40
  • Pessoal,o problema agora é mais sério.

    Outra planilha em rede , localizada no mesmo server apresentou o travamento para salvar também.

    Meu desktop é windows 7 e o servidor windows sever 2008.

    O usuário tem permissão total na pasta.

    Ocorre o mesmo, ao tentar salvar. O Excel mostra a barrinha verde(salvando) e paralisa no  meio do processo. Fica então um arquivo tmp no server e o excel fica com o processo travado.

     

    sexta-feira, 27 de maio de 2011 12:15
  • Você não disse se a minha solução proposta resolveu o problema inicial.

    Além disso, qual é a diferença entre esse último problema apresentado e o primeiro?


    Felipe Costa Gualberto - http://www.ambienteoffice.com.br
    sexta-feira, 27 de maio de 2011 15:49
  • Ola Cris.

    Monitore a performace nos seus discos.

    Verifique se tudo esta OK no momento q ocorre esse travamento.

    Verifique tambem todos os arquivos pelos usuario no seu servidor (e possivel ver isso no gerenciamento do computador>pastas compartilhas>arquivos abertos) e veja se tem algum tipo de arquivo sendo aberto repetitivamente, pois ja vi casos de virus criarem mais de 500 conexoes do mesmo arquivo.. degradando a perfomace do seu servidor.

     

    Espero ter lhe ajudado.


    Enderson Valente Teixeira - Coordenador de Informática
    sexta-feira, 27 de maio de 2011 16:00
  • Existe uma ferramenta boa que eu possa monitorar a partir do cliente, para verificar o que esta ocorrendo? Nao tenho acesso ao server.

    terça-feira, 31 de maio de 2011 20:46
  • Boa noite! Isso está parecendo ser problemas com o registro do Office (especificamente com o excel). Tente restaurar para um ponto anterior a esse problema. Em paralelo a isso (caso não resolva0 desinstale e instale o Office novamente.

    Analista de Suporte - Administrador de Redes - Infra de TI
    quarta-feira, 1 de junho de 2011 02:04
  • Só uma colocação antes de efetuar este procedimento!

    04 estações de trabalho configuradas com o Windows 7 e office 2007 apresentaram este mesmo problema gravando dados no mesmo servidor.

    Em uma das máquinas cheguei a reparar o office porém o problema persistiu.

    Em um dos testes também o travamento do salvar ocorreu com um documento do word de 3 mb.

    O problema ocorre quando se abre um arquivo geralmente acima de 1 MB e após mais ou menos 03 salvamentos do arquivo, ele mostra a tela de "salvar" com a barra de evolução do salvamento paralisada no meio do processo.

    Será que isso pode ser algo do Windows 7 com relação ao salvamento em rede?

     

     


    quarta-feira, 1 de junho de 2011 11:46
  • Cris, verifica sua rede cara, pq aqui eu tneho docuentos enromes em rede muito mais pesados q 3 MB e nunca tive porblemas, vc relatou que o problema ocorre em outas máquinas tbm.

    Primeiro, faça um outro teste, tente copiar o conteudo desta planilha para um documento novo, pode ser que seu arquivo esteja corrompido tbm.

    E eu verificaria o estado da rede como está.

     


    Diego Piffaretti- www.mundotecnologico.net
    quarta-feira, 1 de junho de 2011 12:13
  • Antes de proceder uma observação!

    Ocorreu com arquivos do Word também em estações de trabalho diferentes! E ocorrem ao tentar salvar no mesmo servidor de arquivos (windows server 2008).

    Geralmente são com arquivos acima de 1MB.

    AS maquinas estao configuradas com Windows 7 e office2007.

    Será algum bug de rede do windows 7?

     

     

     

     

    quarta-feira, 1 de junho de 2011 14:50
  • nao achoq seja problma do windows 7, pois aki utilizo windows 7 nas maquinas e nunca tive problemas. Deve se rum problema na sua rede!

     


    Diego Piffaretti- www.mundotecnologico.net
    quarta-feira, 1 de junho de 2011 15:10
  • Alguma forma de monitorar no cliente.

    No windows temos varios logs de serviços e apicativos além dos tradicionais.

    Algum log ali me ajudaria a descobrir o que esta ocorrendo?

    quarta-feira, 1 de junho de 2011 19:26
  • O certo mesmo seria vc deixar um wireshark da vida rodando, pra ver se ta tendo muita perda de pacote, mais se quiser um teste mais amador e simplesão, mais q ja da pra quebrar algum galho, eh vc deixar um ping -t la no servidor, e ver se há perda de pacote, ou demora no ping, mais q 1ms.
    Diego Piffaretti- www.mundotecnologico.net
    quarta-feira, 1 de junho de 2011 20:24
  • O teste do ping eu ja fiz, deixei pingando e simulei o erro. No momento do erro, não ocorre perda de pacote. Parece estar tudo normal.

    Ha alguma ferramenta microsoft me ajudaria a depurar melhor este problema?

    quinta-feira, 2 de junho de 2011 11:59
  • Copia a planilha para o computador local, e salva para ver se o problema persiste.
    Diego Piffaretti- www.mundotecnologico.net
    quinta-feira, 2 de junho de 2011 12:06
  • ja fiz o teste do ping e nao notei perda de pacote antes e durante e depois da ocorrencia do problema.

    TEria algum recurso microsoft mesmo para gerenciar isso e tentar achar alguma pista?

    quinta-feira, 2 de junho de 2011 13:41
  • Primeiro faça  o teste que lhe sugeri. copia a planilha para o computador local. veja se ocorre o mesmo problema ao salvar

    Diego Piffaretti- www.mundotecnologico.net
    quinta-feira, 2 de junho de 2011 14:15
  •  O problema nao ocorre com a planilha sendo salva localmente.

    Ocorre apenas quando salvamos no servidor.

    sexta-feira, 3 de junho de 2011 16:36
  • Isso só reforça mais ainda que o problema está na sua rede,

    Nao tem ferramenta microsft pra vc monitorar isso.

    Verifica seu servidro como está.

    Verifica cabeamento.

    Tenta colocar a planilha em algum compuador da rede e comaprtilahr a pasta de outro computador que nao o servidor, e vej ase o problema ocorre novamente,

    Verifique tbm firewall e antivirus do seu servidor.

     


    Diego Piffaretti- www.mundotecnologico.net
    • Marcado como Resposta Diego Piffaretti segunda-feira, 6 de junho de 2011 17:34
    sexta-feira, 3 de junho de 2011 16:40
  • Pessoal,

    Consegui achar a causa do problema.

    Tenho o symantec end point instalado nas estações, quando parei o serviço do symantec consegui continuar o salvamento normalmente.

    Ja estou em contato como suporte symantec para me auxiliarem a contornar o problema

    Obrigado a todos.

    • Marcado como Resposta Diego Piffaretti segunda-feira, 6 de junho de 2011 17:34
    segunda-feira, 6 de junho de 2011 17:03
  • Olá Cris !!!

       Você conseguiu resolver essa questão ? esse caso é exatamente o problema que enfrentamos aqui com uma empresa, estações com Windows 7, Servidor Windows Server 2008 R2 Foundation 64 bits e Sysmantec end Point, desabilitei na estação o sysmantec end point mas aqui não resolveu, continuou com o mesmo comportamento, tudo já foi revisado inclusive o que se encontra nesse topico, atendo outra empresa que tem a mesma estrutura com sysmantec end point e não ocorre isso, qual a diferença entre as duas que observei, é que na que está dando problemas as Cals recentemente excederam e não sei se com isso essa versão do Windows Server faz com que essa situação ocorra !!!

    Faz tempo mas se ainda puder dar retorno, agradeço !!!

    quinta-feira, 10 de maio de 2012 16:17
  • Olá

    No meu caso foi resolvido após contato com o fornecedor da symantec e atualização da da versão do SEP.

    terça-feira, 16 de outubro de 2012 14:06
  • Boa noite!

    Sei que esse tópico é antigo, mas me ajudou em um problema parecido, tenho uma situação similar a postada por vocês, no meu cenário atual tenho 1 estação com Win 8.1, com office 2007 e um servidor com Win 2008 e um antivirus qualquer, quebrei a cabeça de toda forma pra resolver o problema do office demorando 1 minuto pra salvar arquivos em rede, tentei todo possível que o um bom analista de TI pode fazer, porém sem resultado, fazendo pesquisas pela internet e me deparei com esse problema do Symantec, o que fiz, fui até o servidor e desativei as funções do antivirus (obs. do servidor onde salva os arquivos) e funcionou perfeitamente.

    Boa noite, espero ter contribuído.

    Valdenir Jandosa

    segunda-feira, 29 de junho de 2015 00:17