none
Permissoes NTFS - HD Externo RRS feed

  • Pergunta

  • Boa tarde Pessoal.

    Sei que esse assunto já é bastante difundido em diversos fórums, mas não consegui encontrar uma saida para o problema.

    Nós temos na empresa 1 NAS e 1 HD externo, ambos de 4 TB.

    quando eu os formatei para efetuar todos os backups, eu decidi colocar o Administrador do Domínio como proporietário dessas unidades, pois não queria que ninguem acessace elas, isso ao fato de muitos usuários terem permissões administrador...

    Sendo assim, foi decidido que o HD externo deveria ser guardado em um local externo à empresa, mas quando espetei na minha máquina para minha surpresa, estava dando a tal da mensagem de acesso negado. Nem mesmo mudando o proprietário, não dava certo.

    Resolvi formatar de modo padrão esse HD e copiar tudo de novo do NAS para ele usando o robocopy.exe S:\ H:\ /E /ZB /COPYALL /R:0 /W:0 /V /ETA

    O que aconteceu foi que quando formatei esse HD o proprietário era o SYSTEM, mas conforme foi fazendo a cópia, mudou para o grupo de administradores do domínio.

    Gostaria da ajuda dos colegas para que eu possa reiniciar as permissões dessas 2 unidades para que se em caso meu servidor falhe eu possa pelo menos acessar de outro lugar. Existe risco de perder tudo? aí a coisa complicaria...

    qual é o proprietário padrão de HDs Externos? quero poder usar esse HD em qualquer PC.

    No aguardo pessoal!

    Espero que alguem possa ajudar.


    segunda-feira, 26 de dezembro de 2016 16:52

Respostas

  • Olá Filippe,

    pelo que entendo, você deseja resetar as permissões ao padrão para poder ter acesso. Caso minha interpretação esta incorreta, me avise.

    Bom, para voltar as permissões ao padrão, você precisa abrir o prompt de comando em modo administrador e executar os dois comandos abaixo na unidade de disco que você deseja. (Cuidado para não executar na unidade do sistema operacional)

    Para resetar a permissão das pastas:

    takeown /R /F *

    Para resetar a permissão dos arquivos:

    ICACLS * /T /Q /C /RESET

    Como boa prática, um backup prévio é imprescindível.

    Nos reporte o resultado.

    terça-feira, 27 de dezembro de 2016 12:06

Todas as Respostas

  • Olá Filippe,

    pelo que entendo, você deseja resetar as permissões ao padrão para poder ter acesso. Caso minha interpretação esta incorreta, me avise.

    Bom, para voltar as permissões ao padrão, você precisa abrir o prompt de comando em modo administrador e executar os dois comandos abaixo na unidade de disco que você deseja. (Cuidado para não executar na unidade do sistema operacional)

    Para resetar a permissão das pastas:

    takeown /R /F *

    Para resetar a permissão dos arquivos:

    ICACLS * /T /Q /C /RESET

    Como boa prática, um backup prévio é imprescindível.

    Nos reporte o resultado.

    terça-feira, 27 de dezembro de 2016 12:06
  • Bom dia,

    Por falta de retorno, esta thread será encerrada.

    Caso seja necessário, por gentileza, abra uma nova thread.

    Atenciosamente


    Guilherme Macedo S

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    TechNet Community Support

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    sexta-feira, 30 de dezembro de 2016 11:40
  • Boa tarde Inácio!

    Obrigado pelas respostas.

    Pelo que observei vejo que quando se formata um hd o Windows atribui o usuário Sistema ou System como proprietário para que possa ser utilizado em qualquer computador, certo?

    Em verdade, eu fiz esses 2 processos que vc cita em outro HD externo de testes e o resultado não foi satisfatório.

    1. quando tento abrir as propriedades da unidade ele reporta que a lixeira está com problemas e sugere apagar o seu conteúdo. o que pode ser esses problema?

    No meu HD onde estão todos os backups da empresa, eu coloquei o grupo de administradores da minha máquina como proprietário, mas ao plugar ele no servidor, não reconhece mais.

    alguma sugestão?

    Será que é seguro rodar os comando que vc sugere nessa unidade?

    No aguardo.


    sexta-feira, 30 de dezembro de 2016 17:07
  • Faça um teste em um pendrive para validar o resutado do reset das permissoes ntfs.

    sexta-feira, 30 de dezembro de 2016 18:14