none
IIS Windows 7 versus IIS Windows Server 2008 R2 RRS feed

  • Pergunta

  • Olá Pessoal!

    Criei um portal que faz integração com o CRM 2011 On-line, publiquei normalmente no IIS do Windows 7 Enterpise, mas no IIS do Windows Server 2008 R2, a mesma publicação não funciona. Só funciona através do MS Visual Studio. Já fiz inúmeras tentativas, mas sem sucesso.

    Como poderia resolver este problema?

    terça-feira, 20 de dezembro de 2011 11:07

Respostas

  • Pessoal,

    Seguindo a resposta do  Claudio Sanchez (http://social.msdn.microsoft.com/Forums/en/Geneva/thread/ad1f7367-7727-4b1a-a190-840ff4ed5709) funcionou:

     

    • Open your IIS Manager
    • Find out what AppPool your application is using by selecting your App, right-click on it, and Select Manage Application -> Advanced Settings.
    • After that, on the top left hand side, select Applications Pools, and go ahead and select the App Pool used by your app.
    • Right-click on it, and select Advanced Settings, Go to the Process Model Section and Find the "Load User Profile" Option and set it to true.

     

     

    terça-feira, 20 de dezembro de 2011 14:12

Todas as Respostas

  • Segue messagem de log:
    The data protection operation was unsuccessful. This may have been caused by not having the user profile loaded for the current thread's user context, which may be the case when the thread is impersonating.
    terça-feira, 20 de dezembro de 2011 13:45
  • Pessoal,

    Seguindo a resposta do  Claudio Sanchez (http://social.msdn.microsoft.com/Forums/en/Geneva/thread/ad1f7367-7727-4b1a-a190-840ff4ed5709) funcionou:

     

    • Open your IIS Manager
    • Find out what AppPool your application is using by selecting your App, right-click on it, and Select Manage Application -> Advanced Settings.
    • After that, on the top left hand side, select Applications Pools, and go ahead and select the App Pool used by your app.
    • Right-click on it, and select Advanced Settings, Go to the Process Model Section and Find the "Load User Profile" Option and set it to true.

     

     

    terça-feira, 20 de dezembro de 2011 14:12