locked
DNS RRS feed

  • Pergunta

  • Ola,

    Pessoal,

    Estou com um problema estranho no meu DNS. Tenho um AD no 2003 SP2, na própria maquina todos os nomes estão sendo resolvidos corretamente porém em algumas maquinas clientes não. Nestas maquinas nomes são resolvidos para um ip totalmente fora da minha rede.

    Após rodar ipconfig /flushdns e reiniciar o serviço "cliente DNS" as maquinas com problemas voltam a resolver corretamente os nomes. Alguma idéia do que pode ser isso?


    Obrigado

    quinta-feira, 1 de novembro de 2012 13:44

Respostas

  • Olá, Fernando Lempê.

    O procedimento de atualizar o cache do DNS e  como consequência o serviço voltar a funcionar normalmente (mesmo que temporariamente), não elimina a possibilidade de haver vírus. Digo isso porque eles podem simplesmente "atrapalhar" o serviço, e ai, quando você atualiza o serviço, ele volta a funcionar, porém, para novamente em seguida.

    Seria ideal e prudente você realizar um scanner em teu server.

    Se quiser, poste aqui o resultado e olhamos junto contigo.

    Espero ter ajudado.

    Abraço.

    Atenciosamente.


    Adriel Gavazza Ventura
    Microsoft Certified Professional
    www.itprogroup.com.br - Comunidade Técnica

    • Marcado como Resposta Richard Juhasz segunda-feira, 12 de novembro de 2012 16:01
    sexta-feira, 9 de novembro de 2012 18:50
  • Olá Fernando Lempê,

    Somente o endereço de DNS mudou? O endereço IP e gateway se mantiveram os mesmos?

    Certifique-se de que o DHCP Server está distribuindo o endereço IP do DNS Server correto. De fato, certifique-se de que as estações de trabalho estão recebendo as configurações de TCP/IP do DHCP Server correto.

    Se os usuários tiverem permissão de administrador local, a alteração pode ter sido manual.

    Por último, pode ser vírus: existem malwares que alteram o DNS Server e o endereço de proxy para manipular os sites que o usuário visitar. Muito utilizado em tentativas de roubo de contas bancárias.



    Caso a reposta tenha resolvido seu problema, por favor marque esse post como "Resposta" para que esse Thread se encerre.

    Espero ter ajudado.

    Atenciosamente,




    Caio Vilas Boas 
    Microsoft Certified Trainer
    www.itprogroup.com.br - Comunidade Técnica

    • Marcado como Resposta Adriel Gavazza terça-feira, 13 de novembro de 2012 15:48
    quinta-feira, 1 de novembro de 2012 15:45
  • Creio que o problema não está em suas estações e sim em seu servidor de Dns. Tente verificar as ordens de sua placa de rede, veja se o seu Dns está aprovado, de uma geral nas entradas de Host (A) e os ponteiro PTR caso você use Dns inverso.

    Post os resultados.

    Vinicius Mozart


    domingo, 11 de novembro de 2012 19:12

Todas as Respostas

  • Olá Fernando Lempê,

    Somente o endereço de DNS mudou? O endereço IP e gateway se mantiveram os mesmos?

    Certifique-se de que o DHCP Server está distribuindo o endereço IP do DNS Server correto. De fato, certifique-se de que as estações de trabalho estão recebendo as configurações de TCP/IP do DHCP Server correto.

    Se os usuários tiverem permissão de administrador local, a alteração pode ter sido manual.

    Por último, pode ser vírus: existem malwares que alteram o DNS Server e o endereço de proxy para manipular os sites que o usuário visitar. Muito utilizado em tentativas de roubo de contas bancárias.



    Caso a reposta tenha resolvido seu problema, por favor marque esse post como "Resposta" para que esse Thread se encerre.

    Espero ter ajudado.

    Atenciosamente,




    Caio Vilas Boas 
    Microsoft Certified Trainer
    www.itprogroup.com.br - Comunidade Técnica

    • Marcado como Resposta Adriel Gavazza terça-feira, 13 de novembro de 2012 15:48
    quinta-feira, 1 de novembro de 2012 15:45
  • Caio,

    Obrigado pelo retorno mas tudo isso ja foi verificado. O dhcp aponta os dns's corretos.

    Os clientes resolvem ips de servidores internos para um outro endereço totalmente diferente. Pensei também na possibilidade de vírus mas como disse antes, ao limpar o cache de DNS e reiniciar o serviço, volta a funcionar normalmente. Após algum tempo, o problema retorna.


    quinta-feira, 1 de novembro de 2012 21:15
  • Boa noite Fernando,

    Verifique nas estações o arquivo hosts no seguinte caminho:

    c:\windows\system32\drivers\etc\hosts

    Abra o arquivo host pelo bloca de notas e visualize se existem entradas diferente de localhost 127.0.0.0. Verifique também o serviço de cliente de Dns em sua estação se está ok.

    Vinicius Mozart

    quinta-feira, 1 de novembro de 2012 21:33
  • Arquivo de hosts sem nenhum problema e o serviço DNS também.

    De qualquer forma, obrigado Vinicius.

    sexta-feira, 2 de novembro de 2012 02:57
  • Olá, Fernando Lempê.

    O procedimento de atualizar o cache do DNS e  como consequência o serviço voltar a funcionar normalmente (mesmo que temporariamente), não elimina a possibilidade de haver vírus. Digo isso porque eles podem simplesmente "atrapalhar" o serviço, e ai, quando você atualiza o serviço, ele volta a funcionar, porém, para novamente em seguida.

    Seria ideal e prudente você realizar um scanner em teu server.

    Se quiser, poste aqui o resultado e olhamos junto contigo.

    Espero ter ajudado.

    Abraço.

    Atenciosamente.


    Adriel Gavazza Ventura
    Microsoft Certified Professional
    www.itprogroup.com.br - Comunidade Técnica

    • Marcado como Resposta Richard Juhasz segunda-feira, 12 de novembro de 2012 16:01
    sexta-feira, 9 de novembro de 2012 18:50
  • Creio que o problema não está em suas estações e sim em seu servidor de Dns. Tente verificar as ordens de sua placa de rede, veja se o seu Dns está aprovado, de uma geral nas entradas de Host (A) e os ponteiro PTR caso você use Dns inverso.

    Post os resultados.

    Vinicius Mozart


    domingo, 11 de novembro de 2012 19:12