none
Altera um valor no resgistro do Windows RRS feed

  • Pergunta

  •  
     Boa tarde!

      Estou tendo uns problemas ao clicar um hyperlink no word que da um erro para contactar um administrador do sistema, encontrei a solução alterando o valor da entrado do registro para "C:\Program Files\Internet Explorer\iexplore. exe" - nohome" só que estou tendo dificuldades de criar um script que altere essa chave.
    Caminho:
    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\htmlfile\shell\open\command
    Alterando para:
    "C:\Program Files\Internet Explorer\iexplore.exe" - nohome

    alguém poderia me ajudar? Aonde posso encontra ensinamentos para altera esse valor no registro?

    Obrigado!

    segunda-feira, 29 de março de 2010 17:10

Respostas

  • Salve o texto abaixo como um arquivo reg, por exemplo iexplore.reg em um local de rede onde todos tenham acesso.

     

    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\htmlfile\shell\open\command]
    @="\"C:\\Program Files\\Internet Explorer\\iexplore.exe\" - nohome"

    E crie um vbs que importa essas configurações de registro, segue o código do vbs:

     

    Set objShell = CreateObject("Wscript.Shell")
    objShell.Run "regedit /s \\server\share\iexplore.reg",hidden

     

    Caso vc queira que um usuário comum rode esse script no logon vc deve dar permissão para ele modificar essa chave de registro, para fazer isso crie uma gpo ou altere uma já existente e faça o seguinte.

    Configuração de Computador -> Configurações do Windows-> Configurações de Segurança, botão direito em registry e "ADD", adicione a chave que você especificou acima e dê permissão para o grupo domain users.

     

    Espero ter ajudado.

     

    Caso seja util marque como resposta.

     

    • Marcado como Resposta B.Root terça-feira, 30 de março de 2010 15:41
    segunda-feira, 29 de março de 2010 21:06
  • Tente adicionado o executavel cscript.exe

    Execute o rsop.msc para ver se a policy realmente está aplicando. Qualquer coisa tente colocar o script nas configurações de computador.

    Gabriel.

     


    Não esqueça de contribuir para organização dos fórusn - Classifique as respostas MCP / MCSA / CCNA
    • Marcado como Resposta B.Root segunda-feira, 5 de abril de 2010 16:31
    quarta-feira, 31 de março de 2010 13:52
  • Você utiliza essa diretiva de executar apenas aplicativos permitidos?
    Gabriel Nascimento MCP / MCSA / CCNA Não esqueça de contribuir para organização dos fóruns - Classifique as respostas
    • Marcado como Resposta B.Root segunda-feira, 5 de abril de 2010 16:32
    quarta-feira, 31 de março de 2010 17:02
  • Você tentou colocar esse script nas configurações de computador da gpo?

     

    Se não teste dessa forma, mas a gpo deve estar aplicada para a OU onde ficam as contas dos computadores.


    Gabriel Nascimento MCP / MCSA / CCNA Não esqueça de contribuir para organização dos fóruns - Classifique as respostas
    • Marcado como Resposta B.Root segunda-feira, 5 de abril de 2010 16:32
    quarta-feira, 31 de março de 2010 18:13
  • Vc tem muitas máquinas no dominio?

    Se não tiver muitas te passo um script que vc executa de sua estação e ele atualiza a reg nas estações, vc ainda consegue ver qual máquina que executou o comando.


    Gabriel Nascimento MCP / MCSA / CCNA Não esqueça de contribuir para organização dos fóruns - Classifique as respostas
    • Marcado como Resposta B.Root segunda-feira, 5 de abril de 2010 16:32
    quinta-feira, 1 de abril de 2010 00:34
  • Você ta adicionando permissões pro usuario alterar a chave de registro?

    Configuração de Computador -> Configurações do Windows-> Configurações de Segurança, botão direito em registry e "ADD", adicione a chave que você especificou acima e dê permissão para o grupo domain users.

     


    Gabriel Nascimento MCP / MCSA / CCNA Não esqueça de contribuir para organização dos fóruns - Classifique as respostas
    • Marcado como Resposta B.Root segunda-feira, 5 de abril de 2010 16:32
    segunda-feira, 5 de abril de 2010 14:29

Todas as Respostas

  • Salve o texto abaixo como um arquivo reg, por exemplo iexplore.reg em um local de rede onde todos tenham acesso.

     

    [HKEY_LOCAL_MACHINE\SOFTWARE\Classes\htmlfile\shell\open\command]
    @="\"C:\\Program Files\\Internet Explorer\\iexplore.exe\" - nohome"

    E crie um vbs que importa essas configurações de registro, segue o código do vbs:

     

    Set objShell = CreateObject("Wscript.Shell")
    objShell.Run "regedit /s \\server\share\iexplore.reg",hidden

     

    Caso vc queira que um usuário comum rode esse script no logon vc deve dar permissão para ele modificar essa chave de registro, para fazer isso crie uma gpo ou altere uma já existente e faça o seguinte.

    Configuração de Computador -> Configurações do Windows-> Configurações de Segurança, botão direito em registry e "ADD", adicione a chave que você especificou acima e dê permissão para o grupo domain users.

     

    Espero ter ajudado.

     

    Caso seja util marque como resposta.

     

    • Marcado como Resposta B.Root terça-feira, 30 de março de 2010 15:41
    segunda-feira, 29 de março de 2010 21:06
  • Gabriel o problema que citei acima é proveniente de ”Mensagem de erro quando você ativar a diretiva "Executar apenas aplicativos do Windows permitidos".
    Pois fiz o que você colocou funciona, mas quando ativo a diretiva de
    "Executar apenas aplicativos do Windows permitidos"
    , ele não executa o script, coloquei o nome do script na lista de “Executar” e mesmo assim não aplica o script para altera o registro.
    Como poderia resolver esse problema?
    Obrigado!

    quarta-feira, 31 de março de 2010 12:59
  • Tente adicionado o executavel cscript.exe

    Execute o rsop.msc para ver se a policy realmente está aplicando. Qualquer coisa tente colocar o script nas configurações de computador.

    Gabriel.

     


    Não esqueça de contribuir para organização dos fórusn - Classifique as respostas MCP / MCSA / CCNA
    • Marcado como Resposta B.Root segunda-feira, 5 de abril de 2010 16:31
    quarta-feira, 31 de março de 2010 13:52
  •  

     Nossa Gabriel ta complicado...
     Fiz os procedimentos acima, situação foi aplicado a diretiva, mas acredito que necessite libera mais alguma coisa.
     Tõ pesquisando aqui e nada, se tiver alguma idéia deixa um recado...

      Valeu cara!

    quarta-feira, 31 de março de 2010 16:50
  • Você utiliza essa diretiva de executar apenas aplicativos permitidos?
    Gabriel Nascimento MCP / MCSA / CCNA Não esqueça de contribuir para organização dos fóruns - Classifique as respostas
    • Marcado como Resposta B.Root segunda-feira, 5 de abril de 2010 16:32
    quarta-feira, 31 de março de 2010 17:02
  •  

     

     Sim...

    quarta-feira, 31 de março de 2010 18:04
  • Você tentou colocar esse script nas configurações de computador da gpo?

     

    Se não teste dessa forma, mas a gpo deve estar aplicada para a OU onde ficam as contas dos computadores.


    Gabriel Nascimento MCP / MCSA / CCNA Não esqueça de contribuir para organização dos fóruns - Classifique as respostas
    • Marcado como Resposta B.Root segunda-feira, 5 de abril de 2010 16:32
    quarta-feira, 31 de março de 2010 18:13
  • Vc tem muitas máquinas no dominio?

    Se não tiver muitas te passo um script que vc executa de sua estação e ele atualiza a reg nas estações, vc ainda consegue ver qual máquina que executou o comando.


    Gabriel Nascimento MCP / MCSA / CCNA Não esqueça de contribuir para organização dos fóruns - Classifique as respostas
    • Marcado como Resposta B.Root segunda-feira, 5 de abril de 2010 16:32
    quinta-feira, 1 de abril de 2010 00:34
  •  

     

     Tenho mais de 50, já fiz esse procedimento acima e não funcionou, pois quando aplico a diretiva de executa apenas aplicativos permitidos o registro não é alterado, acredito que tenho que dar permisão em algum arquivo.
     Se vc passar o scritp seria de grande ajuda.

     

     Obrigado

    segunda-feira, 5 de abril de 2010 11:41
  • Você ta adicionando permissões pro usuario alterar a chave de registro?

    Configuração de Computador -> Configurações do Windows-> Configurações de Segurança, botão direito em registry e "ADD", adicione a chave que você especificou acima e dê permissão para o grupo domain users.

     


    Gabriel Nascimento MCP / MCSA / CCNA Não esqueça de contribuir para organização dos fóruns - Classifique as respostas
    • Marcado como Resposta B.Root segunda-feira, 5 de abril de 2010 16:32
    segunda-feira, 5 de abril de 2010 14:29
  •  

     

     Sim, coloquei usuarios do dominio.

    segunda-feira, 5 de abril de 2010 16:12
  • Ah esqueci de uma coisa....

     

    O script usa o regedit.exe, talvez seja isso.


    Gabriel Nascimento MCP / MCSA / CCNA Não esqueça de contribuir para organização dos fóruns - Classifique as respostas
    segunda-feira, 5 de abril de 2010 19:25
  •  

     Por incrivel que pareça tb já fiz e nada... vou ver se encontro alguma coisa por aqui...

     Valeu!

    terça-feira, 6 de abril de 2010 11:54
  • Tente colocar o script para rodar na inicialização do computador e não nas configurações de usuário.

    Computer Configuration - > Windows Settings -> Scripts -> Startup

    E na pasta de rede que o script estiver de permissão para o grupo authenticated users.

    Assim o script irá rodar na conta do computador.


    Gabriel Nascimento MCP / MCSA / CCNA Não esqueça de contribuir para organização dos fóruns - Classifique as respostas
    terça-feira, 6 de abril de 2010 14:48
  •  

     

     Agora que percebe esse script que vc me passou para colocar na inicialização não tá funcionando, se for digitar no prompt funciona.

    quinta-feira, 8 de abril de 2010 13:12
  • Estou passando pelos mesmos problemas referente ao hyperlink, porém as estações de trabalho esão rodando o windows xp sp2 e sp3 e o caminho do internet explorer é: "C:\Arquivos de programas\Internet Explorer\iexplore.exe"

    Ou seja a chave tem esse caminho e não "C:\\Program Files\\Internet Explorer\\iexplore.exe\" como citarão no fórum...

     

    A única solução no momento foi desabilitar a regra Executar apenas aplicativos do Windows permitidos no windows server 2003. assim Funciona mas não seria o correto.

    Alguem achou a solução???

    terça-feira, 13 de abril de 2010 20:01