none
ADD Grupo Domain User em grupo local da estação. RRS feed

  • Pergunta

  • Ba galera na paz.

    Como faço para pegar o grupo Domain User do AD, e colocar ele como membro de um grupo local na estaçao, tenho que colocar o mesmo em um grupo chamado acesso, e tb no grupo usuarios avançados.

    Abraço galera.
    quinta-feira, 13 de agosto de 2009 00:16

Respostas

  • Testa desta maneira, trocando Dominio pelo nome do seu dominio. Testei aqui e funcionou. Era alguma coisa na formação do nome do Grupo.

    Set objNetwork = CreateObject("WScript.Network")
    strComputer = objNetwork.ComputerName
    strGroup1 = "acesso"
    strGroup2 = "Power Users"

    Set objGroup1 = GetObject("WinNT://" & strComputer & "/" & strGroup1 & ",group")
    objGroup1.Add("WinNT://Dominio/Domain Users, group")

    Set objGroup2 = GetObject("WinNT://" & strComputer & "/" & strGroup2 & ",group")
    objGroup2.Add("WinNT://Dominio/Domain Users, group")

    • Marcado como Resposta Marcelo TI quinta-feira, 13 de agosto de 2009 13:30
    quinta-feira, 13 de agosto de 2009 12:11

Todas as Respostas

  • Segue o script, conforme vc pediu

    ------------------------------------------------------------------------------------------------------

    Set objNetwork = CreateObject("WScript.Network")
    strComputer = objNetwork.ComputerName
    strDomain = objNetwork.UserDomain
    strGroup1 = "acesso"
    strGroup2 = "Usuarios Avancados" ' "Power Users"
    StrDomainGroup = strDomain & "\Domain Users"

    Set objDomainGroup = GetObject("WinNT://" & StrDomainGroup)

    Set objGroup1 = GetObject("WinNT://" & strComputer & "/" & strGroup1 & ",group")
    objGroup1.Add(objDomainGroup.ADsPath)

    Set objGroup2 = GetObject("WinNT://" & strComputer & "/" & strGroup2 & ",group")
    objGroup2.Add(objDomainGroup.ADsPath)

    quinta-feira, 13 de agosto de 2009 06:58
  • Angelo

    Bom dia.

    O mesmo apresenta a seguinte mensagem de erro.
    Erro linha 10 coluna 0
    Nao foi possivel localizar o nome do grupo.
    quinta-feira, 13 de agosto de 2009 11:44
  • Testa desta maneira, trocando Dominio pelo nome do seu dominio. Testei aqui e funcionou. Era alguma coisa na formação do nome do Grupo.

    Set objNetwork = CreateObject("WScript.Network")
    strComputer = objNetwork.ComputerName
    strGroup1 = "acesso"
    strGroup2 = "Power Users"

    Set objGroup1 = GetObject("WinNT://" & strComputer & "/" & strGroup1 & ",group")
    objGroup1.Add("WinNT://Dominio/Domain Users, group")

    Set objGroup2 = GetObject("WinNT://" & strComputer & "/" & strGroup2 & ",group")
    objGroup2.Add("WinNT://Dominio/Domain Users, group")

    • Marcado como Resposta Marcelo TI quinta-feira, 13 de agosto de 2009 13:30
    quinta-feira, 13 de agosto de 2009 12:11
  • Ok Angelo.

    Rolou.
    quinta-feira, 13 de agosto de 2009 13:30