none
DHCP com âmbito divido. RRS feed

  • Pergunta

  • Olá amigos do TechNet,

    Esse é o segundo post sobre esse problema do DHCP com âmbito divido. O primeiro foi fechado por falta de respostas, mas, vou continuar a tentar encontrar uma solução, afinal, não posso deixar o sistema do jeito que está.

    Tenho dois servidores na rede, os dois com Windows Server 2008 R2 e com o DHCP com âmbito divido. Um dos gerenciadores anteriores configurou os servidores dessa forma, portanto não sei se estão configurados corretamente. Não tenho muita experiência, rs.

    Os dois servidores tem acesso à internet sem problemas.

    Os DHCPs possuem scopes diferentes, imagino que isso seja correto, para que não haja conflitos entres os IPs atribuídos por DHCPs diferentes. Mas, quando algum PC recebe o IP do scopo do segundo DHCP ele não tem acesso à internet. Tem acesso a todas as pastas da rede, da pasta partilhada e da pasta atribuída ao usuário. Mas, não sei onde pode estar o problema, com o IP do DHCP secundário não tem acesso à internet, tirando isso, tudo normal.

    Fiz um teste com outros PCs fixando o IP do scopo do DHCP secundário e acontece exatamente a mesma coisa, quando retorno para o IP do scopo do DHCP primário ele volta a ter acesso à internet.

    Verifiquei as configurações que achei poder ter influência, mas, não encontrei nada que poderia estar impedindo o acesso à internet do scopo do DHCP secundário.

    Por favor, ficaria muito agradecido se alguém pudesse me ajudar com alguma informação.

    Desde já agradeço a ajuda e atenção.

    Abraços

    terça-feira, 20 de fevereiro de 2018 01:41

Respostas

  • Olá Felipe, 

    Muito obrigado por estar acompanhando meu problema.

    Consegui ver que o problema não estava nas configurações dos servidores e sim do switch que é gerenciável. Não estava configurado para passar os IPs do scope do DHCP secundário.

    Mas, para responder a sua pergunta sobre o ipconfig /all das estações que recebem IPs dos dois DHCPs a única diferença nos resultados são os valores dos IPs e DHCPs, os da estação que recebe IP do DHCP primário tem os valores de IP e DNS do DHCP primário e o secundário os valores do secundário, tirando esses dois valores todo os outros valores são exatamente iguais. Daí eu não conseguir encontrar uma razão para não ter acesso à net mas ter acesso normal à rede e acesso às pastas compartilhadas.

    Vou ver se mudo as configurações do switch ou mudo o scope do DHCP secundário.

    Muito obrigado pela atenção de todos,

    Abraços

    • Marcado como Resposta Sandro AKKA segunda-feira, 23 de abril de 2018 02:04
    segunda-feira, 23 de abril de 2018 02:04

Todas as Respostas

  • Sandro,

    Pq precisa ter 2 servidores dhcp? pelo seu comentario tem 2 servidores porem todos acessam o mesmo conteudo sem restricao.

    Da um ipconfig /all no cliente dhcp 1 e no 2, o gateway e dns estando os mesmos deveria funcionar, pode ser que haja algum tipo de restricao em outro equipamento da rede.

    veja bem o que vc precisa, talvez vc possa desativar o dhcp 2 e aumentar o range do dhcp 1 se for necessario

    boa sorte.

    terça-feira, 20 de fevereiro de 2018 15:18
  • Sandro, os escopes estão na mesma subnet?

    O fato de ter 2 DHCPs pode ser por estar em Failover (não vamos falar disso agora, depois chegamos nessa etapa).

    Tenta identificar a diferença nos IPs das maquinas que acessam a internet das que não acessam.

    EX: Confere a máscara e gateway. Coloque mais detalhes aqui para visualizarmos seu ambiente, pois podem ser varios fatores que possam estar influenciando disso, desde filtros (DENY) no próprio DHCP Server, pode ser algum bloqueio no seu Firewall.

    Um /24 pode estar "divido" em 2 /25 e uma dessas metades não tem permissão pra navegar, etc...

    Enfim, nos dê mais detalhes do seu ambiente.


    Gustavo Valle | http://grvalle.com
    LinkedInWordPressTwitter

    terça-feira, 20 de fevereiro de 2018 19:13
    Moderador
  • Olá Thiago, obrigado pelo seu comentário.

    Acontece que eu comecei a gerenciar a rede à pouco tempo e a rede já roda assim há muitos anos, acho que uns 7 ou 8 anos. Segundo me disseram rodam com dois por segurança, acho que naquela época poderia ser a única maneira de se prevenir. Os equipamentos estão meio velhos e até a migração para equipamentos novos (não sei prever quando vai acontecer, a situação financeira não está boa...)

    Não temos muitos usuários então, não há necessidade de aumentar o range, mas de vez em quando algum pc recebe o IP do DHCP secundário e tenho que fazer com que volte a receber o IP do DHCP primário.

    Mas, caso o servidor primário quebre ou pare de funcionar por algum problema o segundo DHCP deve estar funcionando.

    Experimentei o ipconfig/all como você me pediu e não tive vi diferença nas configurações, estão iguais, os dois usam o DNS um do outro e o Ad do servidor primário é replicado no servidor secundário.

    A única coisa que reparei é que no Group Policy Management do servidor secundário está vazio. Será que isso pode influenciar? Como não tenho muita experiência estou meio perdido nessas configurações.

    Ficarei muito grato se puder me ajudar.

    Abraço

    quinta-feira, 22 de fevereiro de 2018 06:23
  • Olá Gustavo, obrigado pelo seu comentário.

    Os dois servidores usa o mesmo subnet mask sim. Isso pode estar influenciando o acesso à internet dos pcs com IP do DHCP secundário? O servidor em si não tem problemas em acessar a internet, acessa normalmente.

    Como você mencionou eu verifiquei os IPs que não acessam a internet e elas são os IPs concedidos pelo DHCP secundário, ou seja do segundo servidor.

    No ipconfig /all não vejo diferença nas configurações, só alguns detalhes pequenos como por exemplo:

    -Servidor 1 está com o IPV6 desativado e o servidor 2 está ativado.

    -Servidor 1 tem 3 IPs de DNS server, 1 deles eu desconheço, será que pode ser isso?

    Tirando essas diferenças não tenho mais nenhuma diferença visível.

    Outra coisa que reparei é que o servidor secundário está com o Group Policy Management vazio, isso também pode influenciar?

    Agradeceria se pudesse me ajudar a entender melhor essa situação.

    Se tiver mais alguma informação pode me avisar que verifico.

    Muito obrigado.

    Abraço


    • Editado Sandro AKKA quinta-feira, 22 de fevereiro de 2018 06:33 Adicionar informação
    quinta-feira, 22 de fevereiro de 2018 06:30
  • o gateway estava o mesmo?

    faz teste de ping

    ping 8.8.8.8

    ping google.com

    quinta-feira, 22 de fevereiro de 2018 13:53
  • Olá Thiago,

    Muito obrigado por estar acompanhando o meu problema.

    Fiz o teste do ping 8.8.8.8 e a resposta nos dois servidores é a mesma, eu já havia mencionado que os dois servidores acessam a internet sem problema. Quem não acessa a internet são os pcs que conectam no DHCP do segundo servidor. O DHCP da rede está divido entre os dois servidores por

    segurança. Como usamos o Windows Server 2008 R2 é o único meio de nos prevenir no caso de um dos servidores pararem de trabalhar. 

    Verifiquei e os dois estão no mesmo subnet mask e o mesmo default gateway sim. 

    Por favor, me avise se tiver mais alguma configuração ou informação quer que eu veja.

    Muito obrigado pela ajuda.

    Abraço

    domingo, 25 de fevereiro de 2018 06:19
  • O ideal é desativar o segundo, faça o seguinte cara, fixe o ip do segundo e da um tracert pra ver se ele tem a mesma rota comparando com o primeiro. porque pode ser que o segundo esteja mandando rota pra outro lugar ou no seu firewall não tem uma regra para ele. ja que vocÊ falou que o segundo recebe o mesmo gateway que o primeiro no DHCP. e olhe também o segundo para confirmar em opções de escopos se realmente esta com o mesmo router do primeiro.
    • Editado D13G0INFR4 quarta-feira, 28 de fevereiro de 2018 12:35
    • Marcado como Resposta Filipe B CastroModerator quarta-feira, 28 de fevereiro de 2018 20:42
    • Não Marcado como Resposta Sandro AKKA sexta-feira, 2 de março de 2018 08:43
    quarta-feira, 28 de fevereiro de 2018 12:32
  • Filipe, muito obrigado pelo seu comentário.

    Infelizmente, não vai ser possível desligar um dos servidores, ainda não é possível fazer isso.

    Estou tentando verificar as configurações que você mencionou e parece que estão corretos. O DHCP do primeiro e do segundo servidor estão configurados de forma correta, pelo menos parece. Não fui eu quem fez a divisão, mas, parece que foi feito automaticamente pelo windows server 2008 R2, é uma opção que está tem no menu do DHCP. (split scope). Os escopos estão divididos para que IPs iguais não sejam usados.

    A regra do firewall que você mencionou não deveria impedir o segundo servidor de acessar a internet também? O segundo servidor acessa a internet sem problemas. Somente os IPs atribuídos pelo segundo DHCP não tem acesso à internet.

    Se algumas dessas configurações estiverem erradas ou se houver outras que puder me sugerir para verificar eu ficaria muito agradecido.

    Muito obrigado,

    Abraços

    sexta-feira, 2 de março de 2018 00:24
  • não, porque o segundo ta distribuindo um range de ip, e se não tiver 'router' não tem saida pra internet entendeu?
    sexta-feira, 2 de março de 2018 01:28
  • D13G0lNFR4, obrigado pelo seu comentário.

    Não sei se entendi o seu comentário, você disse "se não tiver 'router' não tem saída para internet, certo? Nesse caso o servidor também não teria acesso à internet? O servidor tem acesso à internet, os pcs que recebem IPs do DHCP do segundo servidor é que não tem acesso à internet.

    Por favor, poderia me especificar onde eu poderia verificar onde deveria haver o 'router' ? Assim eu poderia verificar se os dois servidores tem a mesma configuração. Os dois servidores podem usar o mesmo 'router'? 

    Por favor, seja um pouco mais específico para que eu possa fazer as verificações.

    Muito obrigado.

    sexta-feira, 2 de março de 2018 08:36
  • D13G0lNFR4, obrigado pelo seu comentário.

    Os dois servidores tem os IPs fixos e fiz o teste tracert como você mencionou, mas, os caminhos são iguais.

    O gateway é o mesmo sim, mas os dois servidores tem acesso à internet.

    É possível que tenham criado uma regra que para o DHCP primário e tenham esquecido do secundário? Isso seria terrível, não é mesmo?

    Vou tentar verificar as configurações do firewall também, obrigado.

    Abraço

    sexta-feira, 2 de março de 2018 08:50
  • no dhcp secundario, temos que validar se o router está lá na distribuição provavelmente não está ocasionando isso daí.
    sexta-feira, 2 de março de 2018 12:56
  • D13G0lNFR4, obrigado pelo seu comentário.

    Acho que entendi o que você quis dizer, vou tentar verificar.

    Só mais uma dúvida, onde eu posso verificar se ou qual o  'router' está validado?

    Muito obrigado pela sua ajuda, está me esclarecendo muitas dúvidas.

    Abraços

    segunda-feira, 5 de março de 2018 04:42
  • Estou verificando todas configurações que consigo acessar e estão todas iguais, tirando os IPs atribuídos.

    Abraços

    quarta-feira, 7 de março de 2018 06:14
  • Conseguiu resolver?

    Comeca a postar os prints da configuracao do seu DHCP

    quinta-feira, 8 de março de 2018 13:53
  • Conseguiu resolver?

    Comeca a postar os prints da configuracao do seu DHCP

    Ola Thiago JJ, obrigado por estar acompanhando,

    Ainda não consegui resolver, estou procurando por todos os lados que imagino, mas, ainda não consegui encontrar alguma configuração diferente. Será que existe alguma configuração fora do servidor que está impedindo a conexão? Ainda não consegui encontrar alguma outra configuração.

    Se tiver alguma sugestão, por favor, ficaria muito agradecido se pudesse me ajudar.

    Não tenho nenhum problema em acessar a internet pelo servidor secundário, mas ainda não consigo acessar a internet pelos computadores que recebem IP do DHCP desse servidor. 

    Vou tentar postar alguns prints da configuração, mas, se pudesse me indicar quais configurações seria fácil.

    Muito obrigado, 

    Abraços

    quinta-feira, 15 de março de 2018 13:11
  • Boa tarde,

    Conseguiu algum avanço?

    Se ainda não, o que falta?

    Atenciosamente,

    Filipe B de Castro

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    MSDN Community Support

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    quinta-feira, 29 de março de 2018 21:51
    Moderador
  • Boa tarde,

    Conseguiu algum avanço?

    Se ainda não, o que falta?

    Atenciosamente,

    Filipe B de Castro

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    MSDN Community Support

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    Olá Filipe, tudo bem? Muito obrigado por estar acompanhando problema.

    Ainda não consegui resolver, não estou tendo tempo suficiente para resolver esse problema, mas, continuo procurando. Não sei mais por onde procurar, será que você não teria uma dica que poderia me dar um luz?

    Agradeceria muito se pudesse me dar alguma sugestão, estou realmente em um beco sem saídas.

    Abraços

    segunda-feira, 2 de abril de 2018 02:20
  • Boa tarde,

    Conseguiu algum avanço?

    Se ainda não, o que falta?

    Atenciosamente,


    Filipe B de Castro

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    MSDN Community Support

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    Olá Filipe, tudo bem? Muito obrigado por estar acompanhando problema.

    Ainda não consegui resolver, não estou tendo tempo suficiente para resolver esse problema, mas, continuo procurando. Não sei mais por onde procurar, será que você não teria uma dica que poderia me dar um luz?

    Agradeceria muito se pudesse me dar alguma sugestão, estou realmente em um beco sem saídas.

    Abraços

    Olá Filipe, 

    Verifiquei a roteação dos IPs e também não vi nada que pudesse estar evitando a conexão com a internet do segundo servidor.

    Usei o comando "route print" para conferir se o roteamento dos IPs estava correto e não vi nada de errado, os dois servidores estão idênticos.

    O scope do DHCP primário é de 192.168.1.151 até 250 e o scope do DHCP secundário é de 192.168.2.101 até 140. Será que tem alguma coisa errada nessa configuração?

    Se puder ajudar agradeço.

    Abraço

    quinta-feira, 5 de abril de 2018 04:29
  • Olá amigos do TechNet,

    Esse é o segundo post sobre esse problema do DHCP com âmbito divido. O primeiro foi fechado por falta de respostas, mas, vou continuar a tentar encontrar uma solução, afinal, não posso deixar o sistema do jeito que está.

    Tenho dois servidores na rede, os dois com Windows Server 2008 R2 e com o DHCP com âmbito divido. Um dos gerenciadores anteriores configurou os servidores dessa forma, portanto não sei se estão configurados corretamente. Não tenho muita experiência, rs.

    Os dois servidores tem acesso à internet sem problemas.

    Os DHCPs possuem scopes diferentes, imagino que isso seja correto, para que não haja conflitos entres os IPs atribuídos por DHCPs diferentes. Mas, quando algum PC recebe o IP do scopo do segundo DHCP ele não tem acesso à internet. Tem acesso a todas as pastas da rede, da pasta partilhada e da pasta atribuída ao usuário. Mas, não sei onde pode estar o problema, com o IP do DHCP secundário não tem acesso à internet, tirando isso, tudo normal.

    Fiz um teste com outros PCs fixando o IP do scopo do DHCP secundário e acontece exatamente a mesma coisa, quando retorno para o IP do scopo do DHCP primário ele volta a ter acesso à internet.

    Verifiquei as configurações que achei poder ter influência, mas, não encontrei nada que poderia estar impedindo o acesso à internet do scopo do DHCP secundário.

    Por favor, ficaria muito agradecido se alguém pudesse me ajudar com alguma informação.

    Desde já agradeço a ajuda e atenção.

    Abraços

    Olá pessoal, ainda estou tentando resolver o problema, se alguém estiver acompanhado e tiver alguma dica eu ficarei muito grato pela ajuda.

    Abraço

    segunda-feira, 16 de abril de 2018 02:07
  • Poderia nos repassar o resultado do ipconfig /all de uma estação que recebe configurações do DHCP1 e outra estação que recebe do DHCP2 ?


    Se quiser derrubar uma árvore na metade do tempo, passe o dobro do tempo amolando o machado.

    segunda-feira, 16 de abril de 2018 13:33
    Moderador
  • Olá Felipe, 

    Muito obrigado por estar acompanhando meu problema.

    Consegui ver que o problema não estava nas configurações dos servidores e sim do switch que é gerenciável. Não estava configurado para passar os IPs do scope do DHCP secundário.

    Mas, para responder a sua pergunta sobre o ipconfig /all das estações que recebem IPs dos dois DHCPs a única diferença nos resultados são os valores dos IPs e DHCPs, os da estação que recebe IP do DHCP primário tem os valores de IP e DNS do DHCP primário e o secundário os valores do secundário, tirando esses dois valores todo os outros valores são exatamente iguais. Daí eu não conseguir encontrar uma razão para não ter acesso à net mas ter acesso normal à rede e acesso às pastas compartilhadas.

    Vou ver se mudo as configurações do switch ou mudo o scope do DHCP secundário.

    Muito obrigado pela atenção de todos,

    Abraços

    • Marcado como Resposta Sandro AKKA segunda-feira, 23 de abril de 2018 02:04
    segunda-feira, 23 de abril de 2018 02:04