none
Servidor SMTP externo RRS feed

  • Pergunta

  • É possível utilizar um servidor SMTP externo no WSS 3.0?

    Como fica a configuração, pois colocando simplesmente o nome do servidor (smtp.dominio.com.br) ele envia mensagens apenas para dentro do domínio.

    Obrigado.

    sábado, 28 de fevereiro de 2009 02:53

Respostas

  • Prezados,
       Consegui resolver o meu problema. ;) Vou postar aqui minha solução.

    Seguinte.... Seguindo o artigo da TechNet seu servidor SMTP/SharePoint estará 80% configurado. O que faltou no meu caso foi a seguinte configuração:

       - Realizar a configuracao somente com o dominio padrao nao funciona, entao...;
       - Adicionei um dominio remoto no servidor virtual SMTP do IIS (minhaempresa.com.br);
       - Depois editei as propriedades desse dominio da seguinte forma:
           * Marquei a opção para (Permitir que as mensagens seja retransmitidas para esse dominio);
           * Coloquei o host inteligente para (smtp.task.com.br) Servidor SMTP remoto;
           * Em (Segurança de Saída) marquei (Autenticação Básica) e inseri um email e senha padrao para acesso a email do dominio.
       - No SharePoint o servidor SMTP deve ser o dominio padrao.

    Depois desses passos o resto foi tudo realizado atraves do artigo da TechNet (eu perdi o link, so estou com o .pdf aqui, se alguem puder postar o link do artigo para o resto do pessoal seria bom...)


    Até mais e obrigado. ;D
    sexta-feira, 17 de julho de 2009 13:24
  • Pessoal!!!

    Seguem alguns links oficiais do assunto:

    Configure outgoing e-mail settings (Office SharePoint Server)
    http://technet.microsoft.com/en-us/library/cc263462.aspx

    Configure outgoing e-mail settings for a specific Web application (Office SharePoint Server).
    http://technet.microsoft.com/en-us/library/cc261923.aspx

    Installation Guide for Microsoft Office SharePoint Server 2007
    http://go.microsoft.com/fwlink/?LinkID=106632

    Installation guide for Windows SharePoint Services 3.0
    http://technet.microsoft.com/en-us/library/cc288653.aspx

    Abraços!

    Wagner Amorim
    -
    Sharepoint Specialist
    MSF & SCRUM Practitioner 
    Microsoft MCP, MCTS e MCPD
    -

    http://waamorim.spaces.live.com
    http://www.canalsharepoint.com.br

    Wagner M. Amorim
    sexta-feira, 17 de julho de 2009 16:12

Todas as Respostas

  • Renato Fer disse:

    É possível utilizar um servidor SMTP externo no WSS 3.0?

    Como fica a configuração, pois colocando simplesmente o nome do servidor (smtp.dominio.com.br) ele envia mensagens apenas para dentro do domínio.

    Obrigado.



    Renato, você terá que fazer um relay para o SMTP externo, veja se este artigo te ajuda;

    http://technet.microsoft.com/en-us/library/cc288949.aspx

     


    Your Potential, Our Passion
    sábado, 28 de fevereiro de 2009 21:23
  • Então Douglas,

    Estou usando Server2008 STD com IIS 7.0

    Já configurei o Email SMTP do IIS para "Entregar email ao servidor SMTP", defini o servidor como smtp.DOMINIO.com.br, porta 25 e especifiquei as credenciais conforme a política do provedor.

    Na Central do WSS, configurei o servidor SMTP de saída com o nome do próprio servidor.

    Mas não funcionou. Tem mais algum detalhe?

    Obrigado mais uma vez,
    segunda-feira, 2 de março de 2009 16:20
  • Estou com o mesmo problema
    possuo um server2008 com iis7 e utilizo um servidor webmail externo no kinghost
    já fiz as configurações mas não deu certo
    segunda-feira, 15 de junho de 2009 14:38
  • Do sharepoint Wss apenas precisas do SMTP para direccionar os Emails, ou seja se o acesso ao smtp é "smtp.[dominio].[pt ou br]"  existe um conjunto de regras que precisar definir no teu servidor de email, o manual explica passo a passo o que necessitas para configurar, nao e obrigatorio teres servidor de email microsoft, ja instalei varios wss para outros servidores, "nao microsoft, sem problemas", apenas segui o manual.

    Configure outgoing e-mail settings:

    Uma coisa que podes configurar e que pode ajudar e o incoming, ou seja criar uma document library associado a uma conta de email onde irão cair os email dessa conta, imagina "pedido de reclamaçao", o incoming ira fazer pedido ao servidor dos email dirigidos a ele, caindo em document library com alerta associado ao responsavel dessa area.  

    Espero que ajude.

    André Lage Microsoft SharePoint and CRM Consultant
    Blog:http://aaclage.blogspot.com
    Codeplex:http://spupload.codeplex.com/http://simplecamlsearch.codeplex.com/
    quarta-feira, 1 de julho de 2009 00:43
    Moderador
  • Prezado,
       Voce conseguiu resolver os seu problema? acredito estar com o mesmo problema. Eu estou usando windows server 2003 com o sharepoint 3.0. configurei o email de saida para smtp.task.com.br mais nao recebo os emails.

    Sabe como me ajudar?

    terça-feira, 14 de julho de 2009 14:18
  • http://www.oceanapproach.com.au/blog/Lists/Posts/Post.aspx?ID=44
    da uma olhada nesse link, nele tem como configurar o smtp interno para apontar para um externo para enviar os alertas usando um server 2008.
    creio que se estiver utilizando um 2003 é só utilizar o smtp, mas tem que ver se esse server esta configurado para externo ou só interno. Se tu configuro o smtp pra interno ele só manda pra emails internos. Verifica se tu setou nos usuarios do AD o e-mail deles. Qualquer coisa entra em contato.
    quinta-feira, 16 de julho de 2009 15:07
  • Prezados,
       Consegui resolver o meu problema. ;) Vou postar aqui minha solução.

    Seguinte.... Seguindo o artigo da TechNet seu servidor SMTP/SharePoint estará 80% configurado. O que faltou no meu caso foi a seguinte configuração:

       - Realizar a configuracao somente com o dominio padrao nao funciona, entao...;
       - Adicionei um dominio remoto no servidor virtual SMTP do IIS (minhaempresa.com.br);
       - Depois editei as propriedades desse dominio da seguinte forma:
           * Marquei a opção para (Permitir que as mensagens seja retransmitidas para esse dominio);
           * Coloquei o host inteligente para (smtp.task.com.br) Servidor SMTP remoto;
           * Em (Segurança de Saída) marquei (Autenticação Básica) e inseri um email e senha padrao para acesso a email do dominio.
       - No SharePoint o servidor SMTP deve ser o dominio padrao.

    Depois desses passos o resto foi tudo realizado atraves do artigo da TechNet (eu perdi o link, so estou com o .pdf aqui, se alguem puder postar o link do artigo para o resto do pessoal seria bom...)


    Até mais e obrigado. ;D
    sexta-feira, 17 de julho de 2009 13:24
  • Pessoal!!!

    Seguem alguns links oficiais do assunto:

    Configure outgoing e-mail settings (Office SharePoint Server)
    http://technet.microsoft.com/en-us/library/cc263462.aspx

    Configure outgoing e-mail settings for a specific Web application (Office SharePoint Server).
    http://technet.microsoft.com/en-us/library/cc261923.aspx

    Installation Guide for Microsoft Office SharePoint Server 2007
    http://go.microsoft.com/fwlink/?LinkID=106632

    Installation guide for Windows SharePoint Services 3.0
    http://technet.microsoft.com/en-us/library/cc288653.aspx

    Abraços!

    Wagner Amorim
    -
    Sharepoint Specialist
    MSF & SCRUM Practitioner 
    Microsoft MCP, MCTS e MCPD
    -

    http://waamorim.spaces.live.com
    http://www.canalsharepoint.com.br

    Wagner M. Amorim
    sexta-feira, 17 de julho de 2009 16:12
  • Boa tarde a todos,
    Já tentei todas as configurações possíveis, li e reli os tutoriais e nada resolve...
    Olha o cenário, desenvolvi um site anonimo, e tenho um formulário que os usuários vão preencher, assim que o usuário preencher vai mandar um e-mail para o departamento correspondente analisar o e-mail e consertar o bug relatado. O workflow esta pronto, já testei, mas ele não esta mandando o e-mail. Estou trabalhando com um Windows Server 2008, IIS 7, e Sharepoint Services 3, já instalei o servidor SMTP, já fiz todas as configurações possíveis, mas não está adiantando, o SMTP é de um servidor externo ao que o servidor vai ficar.... Aguardando respostas, de quem teve o mesmo problema...
    Emerson
    quinta-feira, 8 de outubro de 2009 19:49
  • Olá Emerson, como vai ?

    Pois é, sei com é chato fazer todos os passos que o pessoal falou e mesmo assim a janelinha do outlook não pular avisando que chegou um email do wss :( , mas enfim, passei por essa situacao há duas semanas e depois de muita luta e bastante ajuda dos amigos aqui do TechNet deu certo !
    Vou tentar resumir os maximo possivel e tambem posso estar sendo redundante em relacao as respostas acima, em todo caso, foram os passos que segui:

    1) Como o pessoal disse, por estar usando um SMTP externo, a primeira coisa quer precisara é configurar um relay. Após instalado o servico de SMTP, atraves do painel de adminstracao do IIS, clique em "Dominio" e em seguida "Novo" -> "Dominio". Escolha o tipo "Remoto". No nome do dominio, insira o dominio da sua rede local(no meu caso, é o mesmo que o externo, sem problemas). Após isso, o novo dominio sera listado no campo direito. De um clique duplo no novo dominio criado e logo na primeira tela marque a opcao "Permitir que mensagens de entrada sejam retransmitidas para este dominio". Clique agora em "Seguranca de saida" e marque a opcao "Autenticacao Basica" e insira uma conta de e-mail valida para enviar e-mails com seu SMTP externo. Clique em "Ok". Na guia "Dominio da rota" marque a opcao "Encaminhar todas as mensagens para o host inteligente" e digite o endereco do seu servidor SMTP externo. Após isso, clique em "OK". Nao sei se é realmente necessario, mas para evitar duvidas, reinicie o IIS.

    2) No painel de administracao do WSS, clique em Operacoes e na aba " Topologias e Servicos"  clique em definicoes de e-mail de saida. Em servidor SMTP de saida digite o caminho local do servidor que esta configurado com relay (não o endereco do SMTP externo, o caminho para o servidor da sua rede interna).
    Abaixo defina a mesma conta que usou no item 1.
    Em "Conjunto de Caracteres" eu recomendo nao alterar, nao sabia muito bem o que fazia esse campo, alterei e comecei a receber e-mail de um jeito todo louco. Após isso, clique em "OK"

    Agora defini algum alerta em alguam lista ou documento para verificar se os e-mails estao chegando.

    Bom, esses foram os passos que segui para conseguir realizar a configuracao com sucesso, espero que seja util pra voce tambem...

    aguardo seu retorno...


    Um grande abraco
    terça-feira, 13 de outubro de 2009 14:01
  • Pode ser um problema na porta que teu servidor smtp externo usa, quando eu usavado Gmail era a porta 512 ou algo assim, agora uso um servidor que usa porta 25 normal. Verifique se o seu Relay está habilitado para a porta correta, pois quando tive o problema era realmente problema na porta que não estava setada corretamente. Se tu fizeste todas as configurações corretamente no WSS e no Servidor Smtp do IIS tente verificar se não está barrando em alguma porta que não foi aberta.
    Só uma pergunta tu instalo o Servido Smtp do Server 2008 e configurou no IIS 6 ou 7?
    terça-feira, 13 de outubro de 2009 14:06
  • Bom dia a todos,
    Pois é... No meu servidor Windows 2008 Server, tenho o IIS 7 e o IIS 6. No IIS 7 apresenta um ícone de SMTP, e é no IIS 6 que eu estou configurando o SMTP para envio de mensagens... Eu preciso configurar tudo no IIS 7...???
    Emerson
    quarta-feira, 14 de outubro de 2009 12:23
  • Eu "configurei" no II7, mas oque tem que estar configurado é no IIS6.
    quarta-feira, 14 de outubro de 2009 12:42
  • Olá,

    Sobre como configurar SMTP no IIS 7, favor verificar o seguinte artigo:

    IIS 7.0: Configurar email SMTP
    http://technet.microsoft.com/pt-br/library/cc772058(WS.10).aspx

    Já sobre SMTP x SharePoint, esse tópico já foi bastante discutido aqui no Forum, veja as threads:

    http://social.technet.microsoft.com/Forums/pt-BR/wsspt/thread/42c6448d-e5af-466d-980e-e427b3e7586e/
    http://social.technet.microsoft.com/Forums/pt-BR/wsspt/thread/c1cb8709-7ac6-4610-9168-6d77a3c7a6f0
    http://social.technet.microsoft.com/Forums/pt-BR/wsspt/thread/e14ac11c-02e6-4acf-87d8-fce50758a9fa/
    http://social.technet.microsoft.com/Forums/pt-BR/wsspt/thread/de8573cb-ac82-4e23-9e9f-b8950cf6b095

    Veja se com essas informações você já consegue fazer funcionar os alertas, importante dizer que no caso de envio de e-mails pelo SharePoint, 90% dos casos que vejo de dificuldades por aqui no forum são relacionados com a infraestrutura da aplicação, detalhes como Firewall, Antivírus, Relay entre outros devem ter uma atenção especial.

    Abraços!

    Wagner Amorim
    -
    Sharepoint Specialist
    MSF & SCRUM Practitioner 
    Microsoft MCP, MCTS e MCPD
    -

    http://waamorim.spaces.live.com
    http://www.canalsharepoint.com.br


    Wagner M. Amorim
    quarta-feira, 14 de outubro de 2009 17:02
  • Boa tarde para todos,
    Cenário: Windows Server 2008, IIS 7, e IIS 6.
    Já fiz todos os procedimentos descritos acima, e não consigo enviar e-mail do WSS 3.0 para meu e-mail(teste), mas já fiz o teste enviando o e-mail por telnet e vai redondo, mas quando configuro no IIS e no sharepoint não obtenho nada, ele não está enviando...???
    Passos para a configuração:
    Abro o IIS 6, e crio um novo domínio remoto; meu domínio é diferente daquele que vou enviar o e-mail - coloco *dominio.com.br
    Depois configuro as diretivas deste novo dominio, conforme descrito nos posts acima.
    Abro o IIS 7, e configuro lá o e-mail que usei na configuração do servidor remoto, marco usar host local, entro com as credenciais do e-mail e Aplico.
    Vou na Administração Central do Sharepoint - Operações - Definições de e-mail de saída, e coloco o nome do servidor, e o e-mail configurado, dou OK.
    Abro no sharepoint designer o site que estou trabalhando, e faço um workflow na lista que desejo que me envie um e-mail assim que um item for inserido.
    Mas nada nenhuma resposta, assim que termino o workflow, vou testar né!!! Mas nada, não chega nada...???
    O que posso estar fazendo errado....???
    Emerson
    segunda-feira, 16 de novembro de 2009 16:52
  • bom, qual servidor smtp externo você está usando?! Configurou o Smtp Relay para retransmissão do alerta?
    quinta-feira, 19 de novembro de 2009 13:47
  • Boa tarde Beenja,
    Estou tentando configurar para uma conta em nosso servidor aonde o smtp é mail.dominio.com.br, e já fiz todas as configurações possíveis, e nada...
    Como já disse anteriormente já fiz os testes via telnet, e o e-mail foi, mas quando coloco no sharepoint ele não vai...???
    O que posso estar fazendo de errado...???
    Emerson
    quinta-feira, 19 de novembro de 2009 16:51
  • Bom dia Emerson,
    bom, verifique no seu servidor onde está instalado o seviço SMTP a pasta C:\inetpub\mailroot\badmail, é possivel que os alertas estão com algum problema de envio e os mesmos acabam caindo para essa pasta. Caso não tenha, verifique a pasta C:\inetpub\mailroot\queue se há algo nela também. Os usuarios do AD tem o campo de email setado!?   Para enviar um email "teste", adicione um usuario do AD com um email cadastrado em algum grupo do Sharepoint (quando está adicionando um usuario a algum grupo, há um campo que mostra se deseja enviar um email para o usuario)  e veja se o mesmo recebe o mesmo.

    Abraço
    terça-feira, 24 de novembro de 2009 12:01
  • Acho q isso pode te ajudar:

    http://fmuntean.wordpress.com/2008/10/26/how-to-configure-iis-smtp-server-to-forward-emails-using-a-gmail-account/


    Tenta enviar um email via Telnet, se der certo, ve se a conta que sobe o serviço de Timer do SharePoint tem permissão no banco.

    Daniel Fioqui - MCP/MCTS http://blog.projectsa.com.br
    • Sugerido como Resposta Daniel Alvares terça-feira, 1 de dezembro de 2009 17:16
    quinta-feira, 26 de novembro de 2009 23:20