none
Exchange 2010 - Fila de Email RRS feed

  • Pergunta

  • Boa Noite Pessoal,

     

    Estou com um problema de fila de e-mail que ja fiz todos os procedimentos de tópicos anterioes e não consigo resolver meu problema.

     

    Enfim, estou com o Exchange 2010, tenho um dominio.local, e criei um accepted domain para dominio.com.br e coloquei como authoritative.

    Minha estrutura de e-mail é na Locaweb, então criei um send connector para dominio.com.brporem quando vou enviar para outros dominio externos eles ficam na fila e apresentam erro de DNS QUERY FAILED 451 4.4.0

    Já criei relay, já tentei adicionar registro MX, ja adicionei o IP do servidor MX da locaweb no DNS do servidor, ja tentei marcar a opcao de DNS Looktp Externo no Send Connector e até agora não consegi resolver meu problema.

     

    Alguem tem alguma ajuda em que eu possa fazer?

    Obrigado pessoal.

     

    Att,

    Daniel Felipe.

    sábado, 9 de outubro de 2010 22:26

Respostas

  • tenho skype Serve ? fabiano.vespa.projetos 

    verifiquei o seu NS e é da locaweb vai no painel da locaweb e cria um registro A normal para o dominio pls.com.br com o nome SMTP o registro que voce criou pelo que entendi foi no seu dns interno certo ? 

     

    você precisa criar esse registro na locaweb que é o seu DNS externo 


    MCSA + M
    segunda-feira, 11 de outubro de 2010 19:23
  • Opa pessoal,

     

    Descobri o problema junto com o Fabiano.

    O servidor não estava conseguindo resolver nomes internamente.

    Criei um Forwader para o meu roteador e tudo voltou a funcionar!

     

    Obrigado Fabiano.

     

    Abraços!

    quarta-feira, 13 de outubro de 2010 13:38

Todas as Respostas

  • DNS Query Failed isso é problema com resolução de nome o seu send connector está para o que ? entrega para todos os dominios ou pra fazer relay ? pode ser que ele não encontre esse DNS que você colocou como relay 

     

    Mais foque no seu problema em DNS 


    MCSA + M
    segunda-feira, 11 de outubro de 2010 12:31
  • Olá Fabiano.

    No meu send connector eu criei como Smart Host para meu dominio externo hospedado na Locaweb.

    Ele deveria entregar automaticamente não deveria?

    Att,

     

    Daniel Felipe.

    segunda-feira, 11 de outubro de 2010 12:35
  • sim teu DNS interno é .local ou .com.br ? 
    sim provavelmente o teu servidor da locaweb ja está fazendo o relay para vocês né ? 
    MCSA + M
    segunda-feira, 11 de outubro de 2010 16:01
  • meu DNS interno é .local.

    Mais no exchange eu criei um Accepted Domain para .com.br

    Pelo que eu saiba quando eu crio o send connector com smart host ele ja faz o relay automatico nao faz?

     

    Estou desesperado, pois o email do pessoal ta parado e quarta feira a empresa inteira estara em cima de mim querendo enviar emails.

    =/

     

    Att.,

    Daniel Felipe.

    segunda-feira, 11 de outubro de 2010 16:05
  • Se eu coloco o IP do servidor SMTP no send connector as mensagens saem da fila e volta mensagem de erro:

     

     

     

    bart0006.localdomain #503 5.0.3 <unknown[187.38.1.252]>: Client host rejected: Para envio de mensagens e necessaria autenticacao/This mail server requires authentication ##

     

    Mais se eu coloco o smtp.dominio.com.br a mensagem apresenta erro.

     

    O que pode ser?

    segunda-feira, 11 de outubro de 2010 16:40
  • cara liga pra locaweb e pede pra criar um usuario para fazer relay não é automatico 

    Pelo que eu saiba quando eu crio o send connector com smart host ele ja faz o relay automatico nao faz?

    o Smart Host precisa ser configurado para relay.  e aceitar sua conexão seja por IP ou seja por usuario autenticado. ele não pode ser relay aberto que ai a maioria dos servidores bloqueia.

     

    Ja fez um teste sem jogar para algum Smart Host ? faça o teste o teu servidor exchange fazer o roteamento e entrega para os servidores diretamente.

     

    o erro do smtp.dominio.com.br  é porque não deve existir DNS RECORD TYPE A com o nome SMTP.dominio.com.br 



    MCSA + M
    segunda-feira, 11 de outubro de 2010 18:11
  • Ola Fabiano,

     

    obrigado pelas respostas, eu fiz 2 testes aqui:

     

    1 - Eu exclui o send conector e tentei enviar de dominio.local para o gmail.com e ai na fila aparece uma mensagem de "Não foi possível encontrar um conector correspondente para o roteamento do destinatário externo".

     

    2 - No smart host pedi para em vez de usar o smart host fazer a pesquisa nos meus dns internos.

    O email sai da fila mais diz que o servidor recusou a mensagem pois necessita de autenticação.

     

    Eu tenho quase certeza que isso é referente ao meu dns, mais nao estou sabendo como configurar.

    Quais entradas eu adiciono para essas mensagens sairem.

     

    Voce pode me ajudar?

     

    Abraz!

    segunda-feira, 11 de outubro de 2010 18:29
  • 2 - No smart host pedi para em vez de usar o smart host fazer a pesquisa nos meus dns internos.

    O email sai da fila mais diz que o servidor recusou a mensagem pois necessita de autenticação.

     

    Não entendi parece que ele tentou entregar para o teu servidor novamente da locaweb.

     

    deleta  o connector e cria novamente do zero mais sem apontar para o Smart Host so faça connector normal para entrega de e-mail 


    MCSA + M
    segunda-feira, 11 de outubro de 2010 18:34
  • cara me fala o nome do dns que você está tentando configurar 

    eu vou verificar daqui pra você 


    MCSA + M
    segunda-feira, 11 de outubro de 2010 18:35
  • smtp.pls.com.br

     

    Esse é o endereço que eu estou colocando no Smart Host.

     

    Eu to achando que deve estar faltando alguma coisa de registro Tipo A ou Mx no meu dns? Ou estou enganado?

     

    Eu testei aqui sem usar .com.br usando meu dominio.local um email de teste com um send connector seguindo o tutorial do Anderson Patricio : http://www.andersonpatricio.org/Artigos/Artigos.asp?Artigo=30

     

    E a mensagem envia porem retorna este erro:

     

    mx.google.com rejeitou sua mensagem para esses endereços de email:
    mx.google.com gerou este erro:
    [187.38.1.252] The IP you're using to send mail is not authorized to send email directly to our servers. Please use the SMTP relay at your service provider instead. Learn more at http://mail.google.com/support/bin/answer.py?answer=10336 d20si3141211and.93

    A mensagem não foi entregue devido a um problema de permissão ou segurança. Ela pode ter sido rejeitada por um moderador, o endereço pode aceitar email apenas de alguns remetentes ou outras restrições podem estar impedindo a entrega.

     






    Informações de diagnóstico para administradores:
    Gerando servidor: SRVPLS.pls.local
    felipeluchc@gmail.com
    mx.google.com #550-5.7.1 [xxx] The IP you're using to send mail is not authorized to 550-5.7.1 send email directly to our servers. Please use the SMTP relay at your 550-5.7.1 service provider instead. Learn more at 550 5.7.1 http://mail.google.com/support/bin/answer.py?answer=10336 d20si3141211and.93 ##
    Cabeçalhos de mensagem originais:
    Received: from SRVPLS.pls.local ([fe80::51c5:124d:d996:d4bd]) by
     SRVPLS.pls.local ([fe80::51c5:124d:d996:d4bd%11]) with mapi; Mon, 11 Oct 2010
     15:25:16 -0300
    From: teste teste <teste@pls.local>
    To: "felipeluchc@gmail.com" <felipeluchc@gmail.com>
    Subject: 123
    Thread-Topic: 123
    Thread-Index: Actpcaal3o99ExPhSnKzPTxAWoCAmg==
    Date: Mon, 11 Oct 2010 18:25:15 +0000
    Message-ID: <1B3E7C888C6C8E4B80FB4ED596FE281A0F3A2E@SRVPLS.pls.local>
    Accept-Language: pt-BR, en-US
    Content-Language: pt-BR
    X-MS-Has-Attach:
    X-MS-TNEF-Correlator:
    Content-Type: multipart/alternative;
       boundary="_000_1B3E7C888C6C8E4B80FB4ED596FE281A0F3A2ESRVPLSplslocal_"
    MIME-Version: 1.0

    segunda-feira, 11 de outubro de 2010 18:57
  • u to achando que deve estar faltando alguma coisa de registro Tipo A ou Mx no meu dns? Ou estou enganado?

     

    ta faltando o registro TIPO A para o nome  smtp.pls.com.br tente resolver por varios servidores e nenhum conseguiu é so criar no teu DNS externo para o IP do servidor da locaweb e pedir pra locaweb criar ou liberar teu IP totalmente para relay 

     

    abraço


    MCSA + M
    segunda-feira, 11 de outubro de 2010 19:09
  • Ola Fabiano,

     

    voce presta consultoria? tem algum msn pra gente conversar?

     

    Eu criei um registro tipo A para pls.com.br e o fqdn ficou smtp.pls.com.br.pls.local e foi para a pasta

    br > com > pls

     

    E mesmo assim continua o email na fila.

     

    Eu zerei o cache do dns e dei um flushdns e mesmo assim sem sucesso.

     

    Abraço.

    segunda-feira, 11 de outubro de 2010 19:17
  • tenho skype Serve ? fabiano.vespa.projetos 

    verifiquei o seu NS e é da locaweb vai no painel da locaweb e cria um registro A normal para o dominio pls.com.br com o nome SMTP o registro que voce criou pelo que entendi foi no seu dns interno certo ? 

     

    você precisa criar esse registro na locaweb que é o seu DNS externo 


    MCSA + M
    segunda-feira, 11 de outubro de 2010 19:23
  • Ola Fabiano,


    Te add la no skype cra.

    Entao eu vi aqui na Locaweb ja tem um registro CNAME SMTP para mailb.locaweb.com.br

    Se eu criar um registro tipo A nao vai dar nenhum conflito?

    Isso o registro que eu criei foi no DNS interno.

    Mais mesmo assim a mensagem nao sai.

     

    Abraços!

    segunda-feira, 11 de outubro de 2010 19:38
  • Opa pessoal,

     

    Descobri o problema junto com o Fabiano.

    O servidor não estava conseguindo resolver nomes internamente.

    Criei um Forwader para o meu roteador e tudo voltou a funcionar!

     

    Obrigado Fabiano.

     

    Abraços!

    quarta-feira, 13 de outubro de 2010 13:38
  • Senhores, estou com o mesmo problema...alguém pode dar uma luz?

    Grato.

    Fabio

    quinta-feira, 12 de maio de 2011 01:47
  • Olá Fabio,

     

    Voce tentou verificar o DNS se esta resolvendo certo?

    Porque esse meu problema todo foi que o servidor não estava conseguindo resolver o nome e estava barrando.

     

    Descreva mais seu problema, e tenta fazer os passos que estão aqui no Tópico.

     

    Abraços.

    quinta-feira, 12 de maio de 2011 20:58