none
E-Mail em branco RRS feed

  • Pergunta

  • Boa tarde a todos,

    Estou com um problema um tanto quanto estranho, um site hospedado fora aqui da organização utiliza uma conta nossa do Exchange para fazer o envio de um e-mail (do tipo, esqueci minha senha..) Quando envia para um endereço aqui da organização o conteúdo aparece todo em branco, tanto se eu abrir pelo outlook quando pelo webapp, se o site envia para fora (por exemplo uma conta no gmail) o conteúdo do e-mail aparece normalmente.

    Se ao receber a mensagem pelo outlook pedir pra ver o código fonte, está tudo em branco, ao analisar na mensagem recebida pelo gmail, vejo o conteúdo completo. Encontrei algo estranho no cabeçalho do e-mail com a seguinte informação:

    Received-SPF: neutral (google.com: xxx.xxx.xxx.xx is neither permitted nor denied by domain of conta@organizacao.com) client-ip=xxx.xxx.xxx.xx;
    Authentication-Results: mx.google.com; spf=neutral (google.com: xxx.xxx.xxx.xx is neither permitted nor denied by domain of conta@organizacao.com) smtp.mail=conta@organizacao.com

    Alguém vê alguma razão aparente para o e-mail chegar em branco apenas no Outlook? O Exchange pode fazer algum bloqueio relacionado a conteúdo? Lembrando que o endereço do remetente desta mensagem é apenas utilizado para a aplicação do site fazer o envio, trata-se de uma conta da organização.

    Se alguém puder ajudar..
    Obrigado desde já.

    quinta-feira, 24 de maio de 2012 21:03

Respostas

  • Received-SPF: neutral (google.com: xxx.xxx.xxx.xx is neither permitted nor denied by domain of conta@organizacao.com) client-ip=xxx.xxx.xxx.xx;
    Authentication-Results: mx.google.com; spf=neutral (google.com: xxx.xxx.xxx.xx is neither permitted nor denied by domain of conta@organizacao.com) smtp.mail=conta@organizacao.com

    O erro acima acontece porque o domínio organizacao.com não possui o SPF configurado, verifique se existe a possibilidade de configurar o SPF para este domínio, esta configuração deve ser realizado na zona DNS do domínio organizacao.com.

    http://www.microsoft.com/mscorp/safety/content/technologies/senderid/wizard/

    • Marcado como Resposta Wagner dos Santos VasconcellosModerator sexta-feira, 1 de junho de 2012 11:15
    • Não Marcado como Resposta Andre Tx sexta-feira, 1 de junho de 2012 18:07
    • Marcado como Resposta Andre Tx sexta-feira, 1 de junho de 2012 18:08
    • Não Marcado como Resposta Andre Tx sexta-feira, 1 de junho de 2012 18:08
    • Marcado como Resposta Andre Tx segunda-feira, 11 de junho de 2012 13:28
    terça-feira, 29 de maio de 2012 14:35
  • Olá Andre,

    Vamos utilizar o Pipeline Trace para arquivar as mensagens, ele guardará uma cópia original da mensagem, e uma cópia após passar por cada agente de transporte.

    para habilitar execute os cmdlets abaixo:

    Neste 1o cmdlet, vamos escolher qual usuário terá a cópia da mensagem arquivada, pode usar um usuário da organização ou até mesmo um usuário de fora, como em seu caso você utiliza um usuário do Exchange vamos inserilho no campo e-mail.

    Set-TransportServer NomeDoServidor -PipelineTracingSenderAddress EnderecoDeEmail@dominio.com.br

    Neste 2o cmdlet, escolho onde serão salvas as cópias da mensagem, em meu caso escolhi a pasta Pipeline Tracing Logs dentro do C:

    Set-TransportServer NomeDoServidor -PipelineTracingPath "C:\Pipeline Tracing Logs"

    E por último habilitaremos o Pipeline, após ter arquivado cópia das mensagens necessário para o nosso troubleshooting, pode desativar utilizando $False onde está $True.

    Set-TransportServer NomeDoServidor -PipelineTracingEnabled $True

    Serão gerados arquivos .eml para ser abertos com o próprio Outlook, se quiser pode zipar a pasta e me enviar por e-mail robsone.silva@hotmail.com e vamos analisando juntos, tentando determinar o que deixando a mensagem em branco ou se ela está chegando em branco ao Exchange.

    Abaixo um artiguinho maroto que fala sobre o Pipeline Tracing :)

    Enabling Pipeline Tracing

    http://technet.microsoft.com/en-us/library/bb125018.aspx

    Um abraço,
    Robson Silva

    sexta-feira, 8 de junho de 2012 21:10

Todas as Respostas

  • Received-SPF: neutral (google.com: xxx.xxx.xxx.xx is neither permitted nor denied by domain of conta@organizacao.com) client-ip=xxx.xxx.xxx.xx;
    Authentication-Results: mx.google.com; spf=neutral (google.com: xxx.xxx.xxx.xx is neither permitted nor denied by domain of conta@organizacao.com) smtp.mail=conta@organizacao.com

    O erro acima acontece porque o domínio organizacao.com não possui o SPF configurado, verifique se existe a possibilidade de configurar o SPF para este domínio, esta configuração deve ser realizado na zona DNS do domínio organizacao.com.

    http://www.microsoft.com/mscorp/safety/content/technologies/senderid/wizard/

    • Marcado como Resposta Wagner dos Santos VasconcellosModerator sexta-feira, 1 de junho de 2012 11:15
    • Não Marcado como Resposta Andre Tx sexta-feira, 1 de junho de 2012 18:07
    • Marcado como Resposta Andre Tx sexta-feira, 1 de junho de 2012 18:08
    • Não Marcado como Resposta Andre Tx sexta-feira, 1 de junho de 2012 18:08
    • Marcado como Resposta Andre Tx segunda-feira, 11 de junho de 2012 13:28
    terça-feira, 29 de maio de 2012 14:35
  • Obrigado pela resposta Diego,

    Configurei o SPF mas os e-mails continuam vindo em branco.
    Mesmo assim obrigado pela ajuda.

    sexta-feira, 1 de junho de 2012 18:08
  • Andre,

    Qual versão do Exchange você possui, me informe a versão que vou te passar uma forma de arquivar esta mensagem antes dela ser categorizada e processada pelos filtros do Exchange, com isso podemos determinar se a mensagem chegou ruim antes do servidor Exchange, ou se é algum agente do Exchange que está modificando o header dela.

    um abraço,
    Robson

    domingo, 3 de junho de 2012 01:41
  • Robson,

    Exchange 2010
    Obrigado pela ajuda

    Abraço

    terça-feira, 5 de junho de 2012 20:53
  • Olá Andre,

    Vamos utilizar o Pipeline Trace para arquivar as mensagens, ele guardará uma cópia original da mensagem, e uma cópia após passar por cada agente de transporte.

    para habilitar execute os cmdlets abaixo:

    Neste 1o cmdlet, vamos escolher qual usuário terá a cópia da mensagem arquivada, pode usar um usuário da organização ou até mesmo um usuário de fora, como em seu caso você utiliza um usuário do Exchange vamos inserilho no campo e-mail.

    Set-TransportServer NomeDoServidor -PipelineTracingSenderAddress EnderecoDeEmail@dominio.com.br

    Neste 2o cmdlet, escolho onde serão salvas as cópias da mensagem, em meu caso escolhi a pasta Pipeline Tracing Logs dentro do C:

    Set-TransportServer NomeDoServidor -PipelineTracingPath "C:\Pipeline Tracing Logs"

    E por último habilitaremos o Pipeline, após ter arquivado cópia das mensagens necessário para o nosso troubleshooting, pode desativar utilizando $False onde está $True.

    Set-TransportServer NomeDoServidor -PipelineTracingEnabled $True

    Serão gerados arquivos .eml para ser abertos com o próprio Outlook, se quiser pode zipar a pasta e me enviar por e-mail robsone.silva@hotmail.com e vamos analisando juntos, tentando determinar o que deixando a mensagem em branco ou se ela está chegando em branco ao Exchange.

    Abaixo um artiguinho maroto que fala sobre o Pipeline Tracing :)

    Enabling Pipeline Tracing

    http://technet.microsoft.com/en-us/library/bb125018.aspx

    Um abraço,
    Robson Silva

    sexta-feira, 8 de junho de 2012 21:10
  • Robson,

    Muitíssimo obrigado pela ajuda, isso vai me ajudar muito!
    Como estava com o tempo meio apertado, antes de ver sua resposta para o troubleshooting tive que me virar e entrei em contato com o pessoal que fazia o envio do e-mail. Eles usam um servidor do gmail por isso a mensagem chegava na conta do gmail com o conteúdo sem problemas, apenas relatando a falha no spf. Mesmo eles dizendo que autenticavam o envio, insisti com os caras do desenvolvimento e verifiquei que a aplicação deles não fazia autenticação nenhuma. Após configurar o servidor e autenticar recebi a mensagem com o conteúdo normalmente. De qualquer forma, mesmo o problema tendo sido solucionado, vou fazer uso dos comandos que você passou para analisar de que forma está chegando e ficar 100% esclarecido.

    Valeu,

    Abraços

    segunda-feira, 11 de junho de 2012 13:39
  • Andre,

    É sempre um prazer poder ajudar, e conte com o fórum sempre que precisar.

    Um abraço,
    Robson Silva

    segunda-feira, 11 de junho de 2012 15:34