none
Rede ping -t : Esgotado o Tempo Limite do Pedido RRS feed

  • Pergunta

  • Olá, vou tentar ser o o mais breve e o mais esclarecedor possível com meu problema.

    Em uma rede de um consultório médico (4 computadores) uma delas funciona como servidor de um software médico.

    A infra estrutura é Modem da GVT, Switch da D-link (onde está ligado o modem da GVT, um computador (servidor) e uma impressora e mais um cabo para outro switch), Switch da D-link (onde estão ligados 3 computadores).

    Foram colocados 2 switchs pela dificuldade em passar os cabos pela tubulação de lógica do consultório.

    Duas máquinas (Servidor e mais uma) rodam windows 7, e as outras duas rodam Windows 8.

    O software médico acessa o Banco de Dados BDE do computador "servidor" e começou a apresentar alguns erros e travamentos. Consultanod a configuração de todas as máquinas não achei nada de errado e resolvi testar a latência dando ping entre as máquinas.

    Com o ping normal (padrão) ele retorna 100% de sucesso, mas quando uso o ping -t, de vez em quando, sem apresentar um padrão, ele retorna "Esgotado o tempo limite do pedido". Isso acontece para todos os IPS.

    Conversando com o desenvolvedor do software, ele falou que pode ser isso que está causando o erro no software, já que ele permanece conectado direto com o BDE e quando ocorre esta perda de pacotes, ele precisa se reconectar, mas não faz isso porque não possui esse comando.

    Como resolveria esse problema da rede??

    sexta-feira, 10 de maio de 2013 20:20

Respostas

  • Primeira coisa que você tem que fazer é tentar mensurar com maior precisão este "de vez em quando". Deixe o "ping -t" rolando por uma hora, e vá acompanhando pressionando as teclas "ctrl+pause/break", esta combinação de teclas exibe o resultado atual de perda de pacotes, o mesmo que é exibido ao pressionar "ctrl+c", mas não para o comando, apenas exibe o resumo. Verifique a porcentagem de perda de pacotes, pois eventualmente ocorrer perdas de pacotes até pode ser aceitável, mas se este valor estiver acima de 1%, com certeza você tem problemas com os switches e/ou cabos de rede no local.

    Também efetue este teste utilizando diferentes máquinas, ex: maq1 pingando o servidor, maq2 pingando maq3, maq4 pingando o modem, e observe sempre a perda de pacotes em cada caso, se elas forem semelhantes, é problema de interconexão(switch / cabos) com certeza, se os resultados forem diferentes pode indicar problemas na placa de rede, ou outro componente de um dos computadores em particular.

    quarta-feira, 15 de maio de 2013 03:42

Todas as Respostas

  • Primeira coisa que você tem que fazer é tentar mensurar com maior precisão este "de vez em quando". Deixe o "ping -t" rolando por uma hora, e vá acompanhando pressionando as teclas "ctrl+pause/break", esta combinação de teclas exibe o resultado atual de perda de pacotes, o mesmo que é exibido ao pressionar "ctrl+c", mas não para o comando, apenas exibe o resumo. Verifique a porcentagem de perda de pacotes, pois eventualmente ocorrer perdas de pacotes até pode ser aceitável, mas se este valor estiver acima de 1%, com certeza você tem problemas com os switches e/ou cabos de rede no local.

    Também efetue este teste utilizando diferentes máquinas, ex: maq1 pingando o servidor, maq2 pingando maq3, maq4 pingando o modem, e observe sempre a perda de pacotes em cada caso, se elas forem semelhantes, é problema de interconexão(switch / cabos) com certeza, se os resultados forem diferentes pode indicar problemas na placa de rede, ou outro componente de um dos computadores em particular.

    quarta-feira, 15 de maio de 2013 03:42
  • Um taxa de perda de 3% não é aceitável?? Qual o limite aceitável.

    O que ele tem mantido é uma taxa de 3%.


    Luis Eduardo Bornancin

    quarta-feira, 15 de maio de 2013 14:22
  • 3% é baixo, mas eu não diria que é normal, nem aceitável, pois pode causar problemas com diversos tipos de aplicação. Estes testes que você fez, com 3% de perda, ocorrem pingando qualquer equipamento, para qualquer equipamento, o resultado é sempre semelhante? Se for, você tem problemas com os switches e/ou cabeamento.
    quarta-feira, 15 de maio de 2013 15:26