none
Erro de listagem de diretório no FTP RRS feed

  • Pergunta

  • Galera,

    Estou com um problema.

    1. Criei um servidor FTP, criei um grupo no AD e configurei no IIS 7.5 para apontar para tal grupo, configurações NTFS da pasta ok. Loga internamente.

    2. Utilizo o ISA 2006, criei uma Publicação "Publicar Protocolos de Servidor Não da Web" seguindo exatamente o tutorial do Anderson Patricio: http://www.andersonpatricio.org/Tutoriais/Tutoriais.asp?Tut=075

    3. Criei um Host(a) no Dyndns.

    4. Externamente, através do meu computador pessoal, pelo Internet Explorer acesso o link público criado, me pede o login e senha(sinal que está funcionando) após isso dá time-out. Tentei conectar com o programa FileZilla, conectou e na hora de listar o diretório deu erro (Falhou a obtenção da lista de pastas). Fui ao ISA, no protocolo do FTP "Filtro de Acesso ao FTP" está desmarcado, também desmarquei a opção do FTP "Somente leitura". Eu até consigo criar pastas externamente, mas o diretório não lista e não consigo enviar um arquivo para o FTP.

     

    Alguém poderia dar uma luz?

     

    Obrigado!

    quinta-feira, 22 de abril de 2010 19:26

Todas as Respostas

  • Deixe a opção Filtro de Acesso ao FTP marcado!!!

    Deixe somente FTP "Somente leitura" desmarcado!!

    Faça o teste!!!!


    David Dellacenta http://daviddellacenta.spaces.live.com || http://www.andersonpatricio.org || http://www.itcentral.com.br || http://lfdias.mvpbrasil.com.br || http://ffazzani.spaces.live.com
    quinta-feira, 22 de abril de 2010 19:49
  • Amigo,

    Já tentei com Filtro de Acesso ao FTP marcado e desmarcado. Os dois falham na exibição do diretório. Já coloquei o diretório das pastas com permissão total para o grupo Todos e mesmo assim continua com este problema.

     

    Existe alguma outra tentativa que eu possa fazer?

    segunda-feira, 26 de abril de 2010 17:16
  • Só para adicionar, tenho o seguinte erro quando tento conectar através de um programa FTP (FileZilla):


    425 cannot open data connection
    Falhou a obtenção da lista de pastas

    segunda-feira, 26 de abril de 2010 17:30
  • Monitora o trafego, o filezilla utiliza outras portas para conexao;

    Vc ja tentou pelos meu documentos:

    ftp://ftp.dominio.com.br

    Ou ate mesmo pelo IE.....?

     

    E sua regra como esta:

    De: anywhere

    Para: IP do servidor (marque a opção Requests appear to come from the original client )

    All users

     

    Fez o monitoramento??? Oq retornou?

    Esse servidor FTP o ideal e deixar fora do dominio e em uma DMZ e utilizar conta local!


    David Dellacenta http://daviddellacenta.spaces.live.com || http://www.andersonpatricio.org || http://www.itcentral.com.br || http://lfdias.mvpbrasil.com.br || http://ffazzani.spaces.live.com
    segunda-feira, 26 de abril de 2010 17:49
  • Pelo navegador dá a seguinte mensagem: 500 The server returned invalid response for PASV command.

    Pelo Windows Explorer loga normalmente, porém não lista nenhum diretório e também não consigo criar nenhuma pasta.

    Pelo FileZilla ele também não lista diretório algum. Baixei o SmartFTP, ele loga, lista diretório, consigo criar pasta, faço upload de arquivos porém não consigo criar um simples arquivo. Mesmo assim não é o ideal, é preciso ter acesso através do navegador.

    A publicação no ISA está correto, segui exatamente o tutorial feito pelo Anderson Patrício.

     

    segunda-feira, 26 de abril de 2010 18:50
  • Vc fez o monitoramento???

    De um print na tela e post para vermos o erro!!!

     

    Ja verificou as permissões ja que esta autenticando no AD?


    David Dellacenta http://daviddellacenta.spaces.live.com || http://www.andersonpatricio.org || http://www.itcentral.com.br || http://lfdias.mvpbrasil.com.br || http://ffazzani.spaces.live.com
    segunda-feira, 26 de abril de 2010 19:05
  • Monitorei pelo ISA, está aparecendo Conexão Iniciada para o meu IP externo (estou testando do meu computador pessoal, em casa).

    Erro quando tento conectar pelo navegador:

    http://img690.imageshack.us/img690/4899/navegadorerro.jpg

    Esse erro é após logar com meu usuário e senha do domínio (O diretório default do meu FTP está com permissão Controle Total para o grupo que criei especialmente para o FTP, onde está meu usuário).

     

    Erro quando tento acessar através do Windows Explorer:

    http://img231.imageshack.us/img231/8079/errowinexplorer.jpg

    Já tentei configurando no IIS 7.5 para todos os usuários, obviamente não pediu login e senha, entrou direto, porém não listou diretório. E nas permissões NTFS do diretório Default do FTP coloquei permissão de controle total para Todos. Mesmo problema.

     

    E obrigado pela paciência e atenção. ;)

    segunda-feira, 26 de abril de 2010 19:45
  • Alguma outra tentativa que posso testar?

     

    Obrigado.

    terça-feira, 27 de abril de 2010 13:25
  • Marque para aceitar anonimos veja se funciona!!


    David Dellacenta http://daviddellacenta.spaces.live.com || http://www.andersonpatricio.org || http://www.itcentral.com.br || http://lfdias.mvpbrasil.com.br || http://ffazzani.spaces.live.com
    terça-feira, 27 de abril de 2010 13:29
  • De uma olhada aki:

     

    http://social.technet.microsoft.com/Forums/pt-BR/isa2006pt/thread/507c808d-1b0a-49c6-a898-3089e47ad59b


    David Dellacenta http://daviddellacenta.spaces.live.com || http://www.andersonpatricio.org || http://www.itcentral.com.br || http://lfdias.mvpbrasil.com.br || http://ffazzani.spaces.live.com
    terça-feira, 27 de abril de 2010 14:08
  • Fiz tudo amigo.

    Eu estou com o IIS 7.0 e FTP 7.5 em um servidor Windows Server 2008 SP1 (não é R2), com Firewall desabilitado e mesmo assim não funciona.

     

    Resolvi então testar com o IIS 6.0 em um servidor Windows Server 2003 e pimba, funcionou perfeitamente. Agora não sei se o problema está no IIS 7.0, no FTP 7.5 ou no Windows Server 2008 SP1.

     

    De qualquer forma esta solução já resolve meu problema, mas fica aí uma dúvida para quem souber ou já passou por isso.

     

    Muito obrigado David pela sua atenção e paciência.

    terça-feira, 27 de abril de 2010 14:52
  • Harter,

    Tenho o Server 2008 R2 e o IIS 6.0 e estou com o mesmo problema de listar diretórios.

    Poderia me ajudar? O que posso fazer.

    Abs.

    quarta-feira, 12 de setembro de 2018 19:39