locked
Spams Crescem cada vez mais RRS feed

  • Pergunta

  • Bom dia,

    Estou recebendo muitos spams, ja tenho implementado as seguintes carecteristicas no meu servidor e acho que deve ter alguma coisa errada, já que a quantidade de spam esta cada vez maior:

    IMF V2
    Sender ID
    Tarpit
    RBLs configuradas zen.spamhaus.org e
    Fiz o teste de Relay pelo mxtoolbox.com e o mesmo esta fechado.

    No meu conector e SMTP permito o relay apenas para usuários autenticados. Esta certo???

    Quando dou o telnet para o servidor e faço testes consigo colocar um email que não existe no mail from e
    enviar. Já percebi que em servidores de terceiros não consigo fazer isso.

    Como consigo barrar isso, acredito que o problema esteja ai??


    Rafael Cristian
    segunda-feira, 9 de agosto de 2010 12:06

Respostas

Todas as Respostas

  • Rafael,

    no smtp virtual server, vc tem que permitir o envio apenas de usuários autenticados, assim um usuário de fora da sua rede não vai usar o seu servidor para enviar e-mails.

    No recebimento vc tem que proibir o envio para contas que não existem no seu AD, e não permitir o envio de NDR para endereços externos.

    A configuração depende da sua ferramenta anti-spam, se vc ta usando o do próprio exchange, pode usar esse passo-a-passo aqui:

    http://www.andersonpatricio.org/Tutoriais/Tutoriais.asp?Tut=013

    Testa e posta ae o resultado, abs.


    JATOBA - Qualquer criança brinca, qualquer criança se diverte! Texto meramente ilustrativo! haushuda
    segunda-feira, 9 de agosto de 2010 13:05
    Moderador
  • OK..

    Eu já implementei o que você solicitou, mas mesmo assim consigo dar um telnet para o meu servidor e colocar mail from: um email externo que não existe

    rcpt to:um email que existe no meu servidor

    e depois consigo enviar uma mensagem.

    Já que implentei o SenderID o exchange não deveria verificar se o email (mail from) existe e bloquear????

     

     

     


    Rafael Cristian
    segunda-feira, 9 de agosto de 2010 15:20
  • Rafael,

    vc conectar no seu servidor e colocar uma conta qualquer no mailfrom, OK, ele aceita, a menos que este sender esteja em uma blacklist.

    rcpt to:email existente no domínio, ele aceita, OK, porque o filtro bloqueia pras contas inexistentes.

    vc não pode bloquear o mailfrom, senão o seu servidor não vai aceitar mensagens externa, porque os servidores externos, não se autenticam, a conexão é anônima.

    entendeu? o,0


    JATOBA - Qualquer criança brinca, qualquer criança se diverte! Texto meramente ilustrativo! haushuda
    segunda-feira, 9 de agosto de 2010 15:43
    Moderador
  • OK.

    Entendi achei que o Exchange conseguia validar se fosse um email inexistente.....

    Nesse caso existe alguma ferramenta de terceiros que eu consiga fazer isso ??? Acho que so assim vou acabar com os spams


    Rafael Cristian
    segunda-feira, 9 de agosto de 2010 16:14
  • Rafael,

    se você priobir que usuários que não existem no AD enviem e-mails pra sua organização, você vai parar de receber e-mails externos, isso tá certo, um servidor de fora quando vem te mandar e-mails ele não se autentica, a conexão é anônima, menos que seja um servidor parceiro, que vcs tenham trocado PSK ou Certificados TLS, aí sim ele autentica.

    O que vc pode fazer, é rever a sua ferramenta anti-spam, enquanto isso bloquear o sender nos filtros anti-spam do exchange.


    JATOBA - Qualquer criança brinca, qualquer criança se diverte! Texto meramente ilustrativo! haushuda
    segunda-feira, 9 de agosto de 2010 17:19
    Moderador
  • Filipe,

    Acho que você não entendeu eu não quero proibir dos usuários que não existem no AD enviem email, eu quero que o exchange valide quando alguem der no meu servidor um mail from:xxx@xxx.xx ele valide se o dominio @xxx.xx existe, ou então melhor se xxx@xxx.xx existe. Acho que isso é possivel, pois dei o comando mail from: colocando um dominio que não existe ou um email que não existe em diversos servidores de terceiros e ele não permite.  

     


    Rafael Cristian
    segunda-feira, 9 de agosto de 2010 18:08
  • Rafael,

    blz, agora eu entendi o que vc quer, isso vc pode fazer, com reverse lookup, mas vc tem que conferir se a sua configuração de dns tá perfeita!

    Pra habilitar isso vc vai nas propriedades do SMTP Connector dentro do system manager, na guia "delivery" clica no botão "advanced", e habilita a opção: "perform reverse dns lookup on incoming messages", e configura os external dns que vc quer que o servidor cosulte.

    Testa ae.

    abs


    JATOBA - Qualquer criança brinca, qualquer criança se diverte! Texto meramente ilustrativo! haushuda
    segunda-feira, 9 de agosto de 2010 18:19
    Moderador
  • Valeu, Filipe , so mais uma dúvida. Meu exchange também é servidor de DNS posso colocar ele mesmo nos external DNS ???


    Rafael Cristian
    segunda-feira, 9 de agosto de 2010 18:21
  • Pode,

    se vc consegue consultar endereços externo normalmente com ele, ou seja, se ele faz forward pra outros servidores, pode usar ele normal.

    abs


    JATOBA - Qualquer criança brinca, qualquer criança se diverte! Texto meramente ilustrativo! haushuda
    segunda-feira, 9 de agosto de 2010 18:29
    Moderador
  • Filipe,

    Fiz o teste e mesmo assim continua não bloqueando emails quando faz o teste do Reverso.
    O que pode ser, estou testando da seguinte forma:

    telnet servidor 25
    ehlo nomequalquer.dominioqualquer.com.br
    mail from:emailqualquer@dominioqualquer.com.br

    Apos isso acredito que tinha q ter dado erro já que configurei a opção , mas ele da ok..
    "perform reverse dns lookup on incoming messages"

     


    Rafael Cristian
    sexta-feira, 13 de agosto de 2010 19:44
  • Rafael,

    desculpa erro meu cara.

    Essa configuração é pra checagem de "helo" dá uma olhada aqui: http://support.microsoft.com/kb/297412/en-us

    O que você pode fazer, é confgurar o "Sender ID Filtering" pra ele fazer checagem de spf :

    http://www.msexchange.org/tutorials/Configuring-enabling-Sender-ID-filtering-Exchange-2003-SP2.html

    E ir adicionando os caras na blacklist cara.

    Eu cometi esse erro porque não uso muito esse anti-spam do exchange, tem outras soluções pagas que atendem melhor.

    abs


    JATOBA - Qualquer criança brinca, qualquer criança se diverte! Texto meramente ilustrativo! haushuda
    • Marcado como Resposta Rafael Cristian terça-feira, 17 de agosto de 2010 14:34
    sexta-feira, 13 de agosto de 2010 19:58
    Moderador
  • Filipe,

    Primeiramente muito obrigado você tem me ajudado bastante. Agora como eu faço para colocar exceções isso porque quando habilitei os usuários que possuem blackberry e estão configurados pelo serviço de blackberry da operadora não conseguiram mais enviar mensagens ????

    Já no caso do ehlo li o KB mas pelo KB e nos testes que fiz apenas informa que será adicionado no cabeçalho do email a mensagem RDNS failed, mas isso não faz com que a mensagem seja bloqueada, existe alguma configuração que deve ser feita no exchange além da definição dos dns a consultar no system manager, para habilitar o bloqueio destas mensagens quando a consulta ao reverse dns falhar ou seja quando o cabeçalho da mensagem estiver com RDNS Failed?? .

    Por enquanto voltei o meu Sender ID filter para a condição de Accept. 


    Rafael Cristian
    terça-feira, 17 de agosto de 2010 14:34
  • Então...

    o anti-spam do exchange é muito limitado, o ideal mesmo infelizmente é ter uma solução de terceiros, tipo um IMSS, ForeFront, IronPort, etc...

    Mas o que aconteceu com os blackberrys?

    E o action do Sender você configura nele mesmo, como accept, nesse caso ele só marca a mensagem, e se você tiver o JunkFilter habilitado no e-mail, outlook, ou webmail, ele manda pro junkmail, a ação delete apaga a mensagem sem mandar NDR que é o IDEAL em questão de segurança, ou Reject, que não é recomendado porque manda um NDR pro remetente dizendo porque foi recusado.

     


    JATOBA - Qualquer criança brinca, qualquer criança se diverte! Texto meramente ilustrativo! haushuda
    terça-feira, 17 de agosto de 2010 15:18
    Moderador
  • No caso dos blackberrys os usuários não conseguiram mais enviar mensagem retorna a seguinte mensagem para os mesmos.

    The reason for the problem:
    5.3.0 - Other mail system problem 550-'5.7.1 Sender ID (PRA) Not Permitted'

    Parece que o blackberry utiliza o proprio provedor da operadora para enviar e ai como o email de não é o mesmo do dominio de ele bloqueia pelo senderid, ou seja precisaria de colocar algumas exceções no sender id...

    Quanto as soluções de terceiro ainda não tenho esta certeza, pois parece que o meu JunkFilter ainda não esta habilitado no email, outlook ou webmail, como faço para configurar já estou com IMF configurado mas não tenho certeza se isso esta funcionando, acredito que não pois não recebo nada na pasta junk.


    Rafael Cristian
    terça-feira, 17 de agosto de 2010 15:42
  • Vamos lá...

    no webmail é só ir em opções, e habilitar o lixo eletrônico pra filtrar automaticamente, as mensagens vão pra pras junk, de acordo com a classificação do IMF.

    E sobre os blackberrys, adiciona o domínio / usuários nas exceptions neste caminho:

    exchange system manager -  Global Settings - Message Delivery - right click - properties-  Connection Filtering.

    Esta é uma lista global, e vai ser processada antes das demais.

    abs


    JATOBA - Qualquer criança brinca, qualquer criança se diverte! Texto meramente ilustrativo! haushuda
    terça-feira, 17 de agosto de 2010 15:55
    Moderador