locked
Erro ao criar gpo de proxy por usuários RRS feed

  • Pergunta

  • Bom dia pessoal,

    eu já havia criado uma gpo de configuração do proxy por usuário. O mesmo estava funcionando normalmente, porém a regra parou de ser aplicada em alguns computadores. Qndo rodo o comando "gpresult /r" ele diz que motivo da regra não se aplicar é desconhecido. 

    Tentei reconfigurar a regra, porém não estou mais localizando as opção de "Manutenção do Internet Explorer" nas configurações dos usuários.

    Existe alguma maneira de localizar essa opção de configuração? Se não, algum .bat para configurar o proxy por usuário.

    Agradeço a atenção de todos.

    Att,


    quinta-feira, 12 de setembro de 2013 13:13

Respostas

  • Olá Kleber

    Com a atualização do IE 10 ocorreram algumas alterações na forma de aplicar proxy via GPO. Você deve utilizar o recurso Group Police Preferences para distribuir as configurações de proxy, conforme indicado no artigo abaixo:

    http://blogs.technet.com/b/grouppolicy/archive/2008/10/13/red-green-gp-preferences-doesn-t-work-even-though-the-policy-applied-and-after-gpupdate-force.aspx

    Caso necessite de um script para configuração, segue exeplo:

    1 - Crie um arquivo .vbs com o seguinte conteudo
    'PROXY IE
    set wshshell = createobject("Wscript.shell")
    WSHShell.RegWrite "HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings\ProxyEnable", 1, "REG_DWORD"
    WSHShell.RegWrite "HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings\ProxyServer","192.168.18.90:8080"
    WSHShell.RegWrite "HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings\ProxyOverride","<local>"
    WSHShell.RegWrite "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa =dword:00000001"
    WSHShell.RegWrite "HKCU\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa LmCompatibilityLevel=dword:00000001"
    OBS: Mude apenas a linha em negrito, que é o endereço do seu proxy.
    2 - Coloque este arquivo no NETLOGON (\\NOME_DO_DC\NETLOGON)

    3 - Vá em um usuário e coloque em Propriedade > Perfil > Script de Logon O .VBS cirado

    Espero ter ajudado!

    Abraço.


    Fernando Henrique da Silva – Microsoft Contingent Staff

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita.

    TechNet Community Support

    Por favor, lembre-se de “Marcar como Resposta” as respostas que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    quinta-feira, 12 de setembro de 2013 14:01