none
somase com data e hora RRS feed

  • Pergunta

  • Ola, estou montando um controle de horas basicamente com duas planilhas em um mesmo documento.

    Na Aba 1 tenho um Sumario do Dia, a Aba2 tenho o detalhe do apontamento de horas do dia.

    Basicamente quero que na aba 1, para uma determinada data,  a somatória de todo o apontamento de horas

    que lancei para o mesmo dia na aba 2.

    Na Planilha 1 na coluna B (B1:B347) tenho as datas, na aba 2 na coluna B (B1:B2064) tenho as mesmas datas porem repetidas varias vezes, ainda na aba2 nas colunas D e E tenho respectivamente hora Inicio e Hora Fim e ainda na mesma aba tenho a coluna F tenho a uma formula basica de subtração (=E2-D2).

    Neste contexto eu queria somar as horas da Coluna F, de acordo com sua data e representar a somatória na aba 1 na linha da data correspondente.

    Utilizando a formula somase o valor da somatória é sempre zero.

    A formula fica conforme abaixo

    =SOMASE(B2:B347;'Apontamento Chamados'!B2:B2064='Hora Entrada x Consolid. Horas'!B2:B347;'Apontamento Chamados'!F2:F2064)

    Certamente estou fazendo algo errado.


    Roberto Velasco - Analista Oracle EBS


    segunda-feira, 25 de janeiro de 2016 22:37

Todas as Respostas

  • Boa noite Roberto

    Para facilitar poste um exemplo da tua planilha, num site gratuito como:

    www.sendspace.com

    Depois cole o link da planilha aqui, que eu resolvo e posto novamente.

    []s

    segunda-feira, 25 de janeiro de 2016 22:55
  • Obrigado pelo retorno.

    Segue link:

    https://www.sendspace.com/file/ejidv8


    Roberto Velasco - Analista Oracle EBS


    terça-feira, 26 de janeiro de 2016 11:32
  • Roberto

    A tua montagem da fórmula com a função SOMASE estava errada.

    No critério só vai o endereço de uma célula, não pode colocar um intervalo, pois ao arrastarmos a fórmulas para as outras linhas, vai atualizando a célula com o critério (que no caso é a data)

    Outra coisa eu melhorei as fórmulas das outras colunas e apaguei os textos que vc digitou em várias colunas, pois assim,  permitiu que eu usava o intervalo todo na fórmula, sem retornar erro. (Não use texto em colunas que são usadas em fórmulas).

    Confira na planilha.

    https://www.sendspace.com/file/x843tj

    Dê retorno.

    []s

    • Sugerido como Resposta Patropi segunda-feira, 1 de fevereiro de 2016 20:53
    terça-feira, 26 de janeiro de 2016 15:02
  • Perfeito.

    Eu estava com um entendimento incorreto quanto ao funcionamento da formula. Abri a planilha, entendi a formula, como você aplicou, e consegui aplicar aos controles que estou realizando.

    Obrigado pelo apoio e dicas.


    Roberto Velasco - Analista Oracle EBS


    terça-feira, 26 de janeiro de 2016 16:26