none
Problemas c/ registro de DLLs RRS feed

  • Pergunta

  •  

    bom dia, estou c/ um probleminha na minha maquina se vcs puderem me ajudar ficarei agradecido.

    é o seguinte...

    comprei um notebook  e c/ ele veio o windows media center edition v 2002

    eu instalei varios programas e rodou normal

    porem qdo tento instalar o visual studio 6 ou algum programa desenvolvido p/ ele

    retorna algumas mensagens de erro dizendo q nao foi possivel registrar determinadas dlls

    nem registrando separadamente c/ um programa de regitro de dll ele consegue registar.

    mensagem de erro: dllregisterServer in DAO350.DLL failed return code was: 0x8002801c

    quarta-feira, 31 de janeiro de 2007 13:11

Respostas

  • Oi Reginaldo!

    Hmm, acho que nesse problema vou poder te ajudar, ou tentar.
    Na empresa onde trabalho agente teve que instalar o Visual Studio 2005 na máquina do cliente, porém o erro de registro de dll's sempre ocorria, agente podia colocar pra ignorar os erros, mas quando executava o aplicativo vinha cheio de bugs. Nisso gravamos em CD (estava na rede) e nada, sendo que apenas nessa máquina apresentava problema.

    No fim descobrimos que o grande vilão era ninguem menos que o Windows Installer. Fomos a base de conhecimentos da Microsoft, aprendemos e retirar a versão do windows installer completamente, baixamos a versão atualizada e nada, reiniciamos o serviço do Windows Installer. NADA!

    No fim desistimos e formatamos o equipamento, contra vontade pois tinham muitooos programas tensos instalados.

    Cara não sei se esse é o mesmo problema que está acontecendo com você, mas não descarte essa hipótese de forma alguma. Tente essa parte, no seu caso pode resolver.

    AH, após formatado funciono!

    Atenciosamente [].

     

    • Marcado como Resposta Sandro Caiado terça-feira, 30 de outubro de 2012 11:58
    quarta-feira, 31 de janeiro de 2007 17:18

Todas as Respostas

  • Fala Reginaldo,

    Tente instalar o net.framework ou o vbruntime, que neles contem essa dll podendo resolver seu problema.

    http://www.microsoft.com/downloads/details.aspx?FamilyID=0856eacb-4362-4b0d-8edd-aab15c5e04f5&DisplayLang=en

    http://www.microsoft.com/downloads/details.aspx?familyid=BA9D7924-4122-44AF-8AB4-7C039D9BF629&displaylang=en

     

     

    Qualquer coisa é só falar..

    abraços..

    quarta-feira, 31 de janeiro de 2007 14:30
  • obrigado pela dika porém naum deu certo.
    o framework 2.0 eu ja tenho instalado, rodei o vbruntime + continua c/ o problema de registro e naum axou a dll esta faltando p/ rodar o vb (dll citada na pergunta).
    Será q pode ser algum bloqueio sei lá, ou alguma incompatibilidade da dlls do vb c/ alguma koisa q instalei ou veio instalado c/ o XP  ou c/  o proprio XP media center edition?.
    quarta-feira, 31 de janeiro de 2007 14:56
  • obrigado pela dika porém naum deu certo.
    o framework 2.0 eu ja tenho instalado, rodei o
    vbruntime + continua c/ o problema de registro e naum axou a dll esta faltando p/ rodar o vb (dll citada na pergunta).
    Será q pode ser algum bloqueio sei lá, ou alguma incompatibilidade da dlls do vb c/ alguma koisa q instalei ou veio instalado c/ o XP  ou c/  o proprio XP media center edition?.
    quarta-feira, 31 de janeiro de 2007 14:58
  • Oi Reginaldo!

    Hmm, acho que nesse problema vou poder te ajudar, ou tentar.
    Na empresa onde trabalho agente teve que instalar o Visual Studio 2005 na máquina do cliente, porém o erro de registro de dll's sempre ocorria, agente podia colocar pra ignorar os erros, mas quando executava o aplicativo vinha cheio de bugs. Nisso gravamos em CD (estava na rede) e nada, sendo que apenas nessa máquina apresentava problema.

    No fim descobrimos que o grande vilão era ninguem menos que o Windows Installer. Fomos a base de conhecimentos da Microsoft, aprendemos e retirar a versão do windows installer completamente, baixamos a versão atualizada e nada, reiniciamos o serviço do Windows Installer. NADA!

    No fim desistimos e formatamos o equipamento, contra vontade pois tinham muitooos programas tensos instalados.

    Cara não sei se esse é o mesmo problema que está acontecendo com você, mas não descarte essa hipótese de forma alguma. Tente essa parte, no seu caso pode resolver.

    AH, após formatado funciono!

    Atenciosamente [].

     

    • Marcado como Resposta Sandro Caiado terça-feira, 30 de outubro de 2012 11:58
    quarta-feira, 31 de janeiro de 2007 17:18
  • valeu vo tentar reinstalar o windows installer p/ ver se funciona.
    Se nao funcionar eu formato o bicho
    quarta-feira, 31 de janeiro de 2007 17:28