none
erro após sp3 (xp) RRS feed

  • Pergunta

  •  

    apos instalar o sp3 percebi que não podia mais acessar o adicionar/remover componentes do windows.

    porem desinstalando tudo voltava ao normal.

    menssagem do erro: (não foi possível carregar a biblioteca de instalação msgrocm.dll ou encontrar a função Ocentry.) (entre em contato com o administrador de sistema. O código de erro especifico é 0x7e.)

     

    depois disso substitui a dll referida, mas ao tentar entrar no adicionar/remover componentes do windows...

    a mesma mensagem foi exibida só que dizendo não ter encontrado uma outra outra dll,

    mais uma vez substitui a dita , e o mesmo aconteceu so que faltava outra dll

    Ou seja cada vez q reparava uma , faltava outra,

    lembrando q ao retornar ao sp2 , tudo ficava normal.

    alguem tem alguma idéia ?

    desde já obrigado.

    sexta-feira, 6 de junho de 2008 22:06

Respostas

  • Olá Galera!!!

    Então vou tentar ajudar vocês pois também estive o mesmo problema!!!
    Coisa bem simples...

    Com o CD de Instalação do Windows XP no Drive execute estes comandos no Prompt de Command (Dos):

    expand X:\i386\sysoc.in_ -r c:\windows\inf

    "Sendo que o X refere-se a letra da Unidade do CD-Rom".

    Também funciona se caso tiver a Cópia da Instalação no HD...
    Depois desses passos o meu Painel de Controle voltou ao normal.

    Espero ter ajudado a Galera!!

    Atenciosamente,

    Isaac Benevides
    isaacbenevides1012@gmail.com
    • Marcado como Resposta Sandro Caiado terça-feira, 11 de outubro de 2011 17:58
    segunda-feira, 6 de abril de 2009 21:54

Todas as Respostas

  •  

    Olá,

     

    Você notou alguma mensagem de erro durante a instalação? Talvez não poderia o instalador (arquivo que Vc baixou da Microsoft) estar com problemas?

     

    Faça o seguinte, estando com o SP3 instalado, no prompt do DOS execute o comando: sfc /scannow ou somente sfc

     

    O comando irá recuperar todas as DLL's danificadas ou faltantes.

     

    Um abraço,

     

    Tiago.

    sexta-feira, 6 de junho de 2008 22:47
  •  

    A/C

     

        Alliens

     

          Alem de seguir a ajuda que foi postada no forum, caso isso resolva seu caso faça o ponto de restauro, isso ajudará em 85% no seu dia dia.
         Caso você tenha habilitado o Restauração do Sistema podera recupera na data que estava tudo ocorrendo bem.
         Uma das medidas a serem tomandas é verificar o SFC /Scannow isso recupera as DLL, ou ate mesmo poderá ser encotradas na Web.
         Procure adquirir o SP3 do Site da Microsoft é mais seguro, para maiores informáções acesse o KB da Microsoft, é um site de ajuda para administradores e usuários. Também Veja o My Live Spaces sempre tem alguma matéria de segurança e suporte a Windows XP...

     

     

    Obs.: Espero ter ajudado. Marque como Resposta caso tenha desempenhado com êxito isso ajudará outros usuários.. Duvidas post aqui ou entre em contato por e-mail.

     

     

     

       Rodrigo Soares
     
    Suporte Técnica Informática e Redes
    Suporte Técnico Telecomunicações fixa
    Certificando-se em  MCDST



    Skype   
     rodrigotecnico
    mail       rodrigodptotecnico@msn.com
    mail      
    rodrigowebmaster@ibest.com.br  
    Home     http://atcdsa.spaces.live.com  
    Help       55 + 11-9677 6504
    SP Acesso Remoto RJ
                
    Conectando

    sábado, 7 de junho de 2008 00:25
  •  

    Olá !

    Então tiago, fiz oq sugeriu(sfc / scannow),(sfc) mas infelizmente tbm não funcionou.
    mas mesmo assim obrigado pela atenção despendida.

    sábado, 7 de junho de 2008 06:30
  •  

    Olá rodrigo, eu sempre crio um ponto de restauração, e eu baixei, salvei, e instalei o sp3 direto
    do site do tio bill.porem como postei, ao restaurar o sistema ele volta ao sp2 e tudo fica normal.
    mas obrigado.
    sábado, 7 de junho de 2008 06:30
  • Oi, alliens, eu criei um pacote que repõe alguns dos arquivos que ficam faltando depois da instalação do Windows XP SP3. Eu estava com o mesmo problema que vc ( Adicionar / Remover componentes do Windows ) e depois que recoloquei estes arquivos resolveu. É só executar e clicar em instalar. O pacote tb deixa uma cópia do arquivo  GDI32.DLL  antigo em "c:\windows", pq vi que muita gente teve problemas de tela azul com esse arquivo depois de instalar o SP3. Caso alguém tenha esse problema é só copiá-lo p/ "c:/windows/system32", substituindo o novo. Como alguém possa notar, há vários arquivos repetidos neste pacote, isso pq deixei cópias em pastas onde o windows normalmente procura arquivos necessários.

     

    Obs. Depois que o "Adicionar / Remover componentes do Windows" volta a funcionar, reparei que as opções "Windows Messenger" e "MSN Explorer" (!!!) (alguém lembra dele?)  aparecem marcadas. Recomendo desmarcá-las (se vc não os usa, obviamente).

     

    Baixar pacote: (Removido pela Moderacao)

     

     

     

    Baixar Torrent: (Removido pela Moderacao)

     

     

    Espero que ajude.

     

     

    Em inglês, caso algum gringo tb esteja precisando:

     

     I created a package that replaces some of the files missing after XP SP3 installation. It Solves the "Add/Remove Windows components" error ( msgrocm.dll ) and others. Just run it and click install. It also leaves a copy of old  GDI32.DLL  file at "c:\windows", as many people had problems with this file after installing SP3. If you have this problem, just copy it to "c:\wndows\system32", replacing the new file. As someone can notice, there are duplicated files in this package, that's because I let copies on folders where Windows usually seek for necessary files.

     

    Ps. After " Add/Remove Windows components" back to work, i noticed that "Windows Messenger" e "MSN Explorer" (!!!) were checked. I recomend uncheking it ( if you dont´t use it, of course).

     

    Hope it´s useful.

     

    Download package:  (Removido pela Moderacao)

     


    Download Torrent: (Removido pela Moderacao)

     


    • Sugerido como Resposta Jubionico terça-feira, 11 de agosto de 2009 00:24
    • Editado Sandro Caiado terça-feira, 11 de outubro de 2011 17:57 Link Proibido
    sábado, 21 de junho de 2008 06:36
  • Agumas pessoas tb relataram que seus PCs começaram a reiniciar várias vezes aleatoriamente depois de instalar o XP SP3, principalmente PCs da HP com processadores AMD. Um ex-programador da Microsoft, Jesper Johansson, desenvolveu um fix p/ esse problema:  https://msinfluentials.com/blogs/jesper/attachment/7647.ashx

     

    (Removido pela Moderacao)

     

     

     

    Some people also reported that their PCs start to reboot randonmly several times after installing XP SP3, mainly HP PCs with AMD processors. A former Microsoft Programmer,  Jesper Johansson, developed a fix for this problem:  https://msinfluentials.com/blogs/jesper/attachment/7647.ashx

     

     

     


    • Editado Sandro Caiado terça-feira, 11 de outubro de 2011 17:57 Link Proibido
    sábado, 21 de junho de 2008 16:10
  • Pessoal ,

    boa tarde. vou testar agora a solução apresentada pelo colega. Algum tem alguma solução oficial? Já procurei pelos KB e nda.


    sds


    Cleyton Santana de Sousa
    terça-feira, 29 de julho de 2008 16:20
  •  fabriciomonzi wrote:

    Oi, alliens, eu criei um pacote que repõe alguns dos arquivos que ficam faltando depois da instalação do Windows XP SP3. Eu estava com o mesmo problema que vc ( Adicionar / Remover componentes do Windows ) e depois que recoloquei estes arquivos resolveu. É só executar e clicar em instalar. O pacote tb deixa uma cópia do arquivo  GDI32.DLL  antigo em "c:\windows", pq vi que muita gente teve problemas de tela azul com esse arquivo depois de instalar o SP3. Caso alguém tenha esse problema é só copiá-lo p/ "c:/windows/system32", substituindo o novo. Como alguém possa notar, há vários arquivos repetidos neste pacote, isso pq deixei cópias em pastas onde o windows normalmente procura arquivos necessários.

     

    Obs. Depois que o "Adicionar / Remover componentes do Windows" volta a funcionar, reparei que as opções "Windows Messenger" e "MSN Explorer" (!!!) (alguém lembra dele?)  aparecem marcadas. Recomendo desmarcá-las (se vc não os usa, obviamente).

     

    Baixar pacote: (Removido pela Moderacao)

     

    Baixar Torrent: (Removido pela Moderacao)

     

     

    Espero que ajude.

     

     

    Em inglês, caso algum gringo tb esteja precisando:

     

     I created a package that replaces some of the files missing after XP SP3 installation. It Solves the "Add/Remove Windows components" error ( msgrocm.dll ) and others. Just run it and click install. It also leaves a copy of old  GDI32.DLL  file at "c:\windows", as many people had problems with this file after installing SP3. If you have this problem, just copy it to "c:\wndows\system32", replacing the new file. As someone can notice, there are duplicated files in this package, that's because I let copies on folders where Windows usually seek for necessary files.

     

    Ps. After " Add/Remove Windows components" back to work, i noticed that "Windows Messenger" e "MSN Explorer" (!!!) were checked. I recomend uncheking it ( if you dont´t use it, of course).

     

    Hope it´s useful.

     

    Download package: (Removido pela Moderacao)



    Download Torrent: (Removido pela Moderacao)

     

     


     



    Depois que eu fiz esse procedimento do fabricio, não aparece a mesma mensagem de erro, ams aparece outra:
    "o programa de instalação não pôde abrir o arquivo de informações communic.inf".

    • Editado Sandro Caiado terça-feira, 11 de outubro de 2011 17:58 Link Proibido
    terça-feira, 5 de agosto de 2008 15:54
  • Olá Galera!!!

    Então vou tentar ajudar vocês pois também estive o mesmo problema!!!
    Coisa bem simples...

    Com o CD de Instalação do Windows XP no Drive execute estes comandos no Prompt de Command (Dos):

    expand X:\i386\sysoc.in_ -r c:\windows\inf

    "Sendo que o X refere-se a letra da Unidade do CD-Rom".

    Também funciona se caso tiver a Cópia da Instalação no HD...
    Depois desses passos o meu Painel de Controle voltou ao normal.

    Espero ter ajudado a Galera!!

    Atenciosamente,

    Isaac Benevides
    isaacbenevides1012@gmail.com
    • Marcado como Resposta Sandro Caiado terça-feira, 11 de outubro de 2011 17:58
    segunda-feira, 6 de abril de 2009 21:54
  • Com o CD de Instalação do Windows XP no Drive execute estes comandos no Prompt de Command (Dos):

    expand X:\i386\sysoc.in_ -r c:\windows\inf

    "Sendo que o X refere-se a letra da Unidade do CD-Rom".

    Também funciona se caso tiver a Cópia da Instalação no HD...
    Depois desses passos o meu Painel de Controle voltou ao normal.


         A instrução do Isaac Benevides funcionou comigo.

         Obrigado Isaac.

          João Roberto
    sexta-feira, 8 de maio de 2009 16:48
  • Olá pessoal! Realmente tais soluções não funcionaram para mim... mas pesquisando muito descobri que o executável responsável pelo "adicionar/remover componentes do windows é o sysocmgr.exe que fica na pasta systen32. Ele não queria funcionar e dava os erros relatados. Buscando pelas DLLs e arquivos inf faltantes (das mensagens de erro) em outro PC, fui copiando os arquivos para o meu micro até o negócio funcionar.
    Agora eu pergunto: COMO É QUE DLL'S E ARQUIVOS INF E PNF PODEM DESAPARECER DO MEU PC? Será que é pq eu uso o GlaryUtilities (limpador de registro) ???
    Abraços
    quinta-feira, 11 de março de 2010 05:12
  • Olá,

    Você fez este procedimento?

    Com o CD de Instalação do Windows XP no Drive execute estes comandos no Prompt de Command (Dos):

    expand X:\i386\sysoc.in_ -r c:\windows\inf

    "Sendo que o X refere-se a letra da Unidade do CD-Rom".

    E mesmo assim não funcionou?

    Att Isaac Benevides
    sexta-feira, 12 de março de 2010 15:23
  • Isaac, fiz como sugeriu e resolveu o problema!

    Obrigado!

    quinta-feira, 6 de outubro de 2011 23:27
  • Isaac, valeu mas não resolveu.
    quinta-feira, 31 de maio de 2012 17:17