none
Erro de Active Desktop no Domínio RRS feed

  • Pergunta

  • Boa Tarde.

    Possuo um DC com Windows Standard 2003 rodando os seguintes serviços: AD, DHCP, TS. Meu problema é o seguinte: Apliquei uma gpo no domínio para usúário referente a papel de parede, onde todas as estações aplicacem o mesmo papel de parede. Coloquei no Servidor uma imagem em JPG numa pasta compartilhada, desativei o cache dessa pasta (segundo um post que encontrei aqui), mas mesmo assim algumas máquinas ensistem em dar o erro de active Desktop e não a jeito de voltar, o único método que encontrei foi mudando os valores de  duas chaves no registro, mas é temporário pq funciona uns dias e depois acontece novamente. Ja visualizei todos os posts que tem aqui no forum mas nenhu mresolveu meu problema definitivamente. Gostaria de saber se alguem ja enfrentou esse problema e tem algumas dicas para compartilhar. Desde ja agradeço a todos.

    Obrigado

    quinta-feira, 2 de dezembro de 2010 18:16

Respostas

  • Vc fez os 2 procedimentos? Tente então separado, so o primeiro: Marque a opção Desabilitar Active Desktop


    O papel de parede vc deixa como estava antes, sem ser centralizado e veja se funciona.

    se não der certo, tente somente a segunda dica isolada, deixe o Active desktop ativado e o papel de parede como centralizado.


    Diego Piffaretti- www.mundotecnologico.net
    • Sugerido como Resposta Diego Piffaretti quarta-feira, 8 de dezembro de 2010 11:21
    • Marcado como Resposta Richard Juhasz sexta-feira, 10 de dezembro de 2010 16:15
    sexta-feira, 3 de dezembro de 2010 12:39
  • Rodrigo, bom dia!

    O que o Diego falou tem que funcionar, é a opção correta para parar de dar o erro.

    Porém como está perdendo algum tempo com este problema, vou passar uma solução que eu utilizo e que acho melhor que a GPO.

    Apenas uma forma alternativa de solucionar o problema.

    1. Baixe o aplicativo chamado BGinfo ele pode ser econtrado no sysinternals

    2. Crie uma pasta dentro do netlogon, com o nome "Support"

    3. 'Papel de Parede

    Set WshShell = WScript.CreateObject("WScript.Shell")
    WshShell.run   "\\nomedoservidor\netlogon\Support\bginfo\Bginfo.exe \\nomedoservidor\netlogon\Support\bginfo\BGinfo.bgi /timer:0 /SILENT /nolicprompt"

    4. Salve o arquivo em .VBS, se já possuir um script em vbs, apenas insira a linha, caso tenha um .BAT, utilize este script dentro do seu .Bat para chamar o .VBS e evitar de precisar trocar o nome do script no logon dos usuários.

    5. Chamar vbs no bat \\servidor\compartilhamento\nomedovbs.vbs

    Qualquer dúvida estou a disposição!

    abs


    ..::.. Carlos Henrique | MCSA WINDOWS SERVER 2003 ..::..
    • Sugerido como Resposta Diego Piffaretti quarta-feira, 8 de dezembro de 2010 11:21
    • Marcado como Resposta Richard Juhasz sexta-feira, 10 de dezembro de 2010 16:15
    quarta-feira, 8 de dezembro de 2010 11:18

Todas as Respostas

  • Boa noite Rodrigo!

    Na configuração da GPO você indica o local do papel de parede (.jpg) e também configura para ativar o active desktop para poder usar a extensão .jpg ?

    Já tentou fazer um teste e colocar um papel de parede com a extensão  .bmp para ver se funciona?

    O caminho onde você disponibiliza essa imagem todos os usários tem permissão de leitura?

     

    Abraço

     

    quinta-feira, 2 de dezembro de 2010 23:57
  • os clioentes com problema para receber os papeis de parede sao oq? Xp, vista, seven?
    Diego Piffaretti- www.mundotecnologico.net
    sexta-feira, 3 de dezembro de 2010 00:06
  • Klebinho

    Sim indico o caminho, ativo a opçao active desktop para usar jpg. Sim todos usuários tem permissão de leitura.

     

    Obrigado.

     

    sexta-feira, 3 de dezembro de 2010 11:03
  • Diego

    Todos clietes são Windows XP Professional SP3.

     

    Obrigado.

    sexta-feira, 3 de dezembro de 2010 11:04
  • Rodrigo , faça estas tentativas:

    -Marque a opção Desabilitar Active Desktop como  Desabilitado na policy do seu DC, e faça um teste.

    - Coloque o paple de parede como CENTRALIZADO na sua GPO.

     

    Post aqui os resultados.


    Diego Piffaretti- www.mundotecnologico.net
    • Sugerido como Resposta Diego Piffaretti quarta-feira, 8 de dezembro de 2010 11:21
    sexta-feira, 3 de dezembro de 2010 11:37
  • Fiz o teste aqui em uma estação que esta normal, o papel de parede esta aplicando corretamente, só que agora começou a ficar pela metade o papel de parede, somente depóis de pressionar F5 varias vezes o papel de parede aplica corretamente.
    sexta-feira, 3 de dezembro de 2010 12:35
  • Vc fez os 2 procedimentos? Tente então separado, so o primeiro: Marque a opção Desabilitar Active Desktop


    O papel de parede vc deixa como estava antes, sem ser centralizado e veja se funciona.

    se não der certo, tente somente a segunda dica isolada, deixe o Active desktop ativado e o papel de parede como centralizado.


    Diego Piffaretti- www.mundotecnologico.net
    • Sugerido como Resposta Diego Piffaretti quarta-feira, 8 de dezembro de 2010 11:21
    • Marcado como Resposta Richard Juhasz sexta-feira, 10 de dezembro de 2010 16:15
    sexta-feira, 3 de dezembro de 2010 12:39
  • Outro detalhe: Veja qual resolução do seu wallpaper, se está como 800 x 600 ou 1024 x 768 ... mude esta resolução e veja se funciona.
    Diego Piffaretti- www.mundotecnologico.net
    sexta-feira, 3 de dezembro de 2010 12:40
  • boa Tarde Diego. Fiz os procedimentos acima e continua o mesmo geito, testei com duas imagens uma  800x600 e 1024x768, mas ainda continua dando o problema de carregar só um comecinho e depois tudo preto, após pressionar F5 umas vezes ai carrega por completo. Fiz teste com arquivo .bmp, ai ficou pior ainda não carregou nada e fiou um x o canto da tela, memso pressionando F5 não carregava.

     

    Obrigado

    sexta-feira, 3 de dezembro de 2010 18:57
  • Olá Rodrigo.

    Isso só ocorre para os clientes XP SP3? Já tentou outros clientes? Ocorre o mesmo problema?

     

    Abraço.

     


    Richard Juhasz
    terça-feira, 7 de dezembro de 2010 17:51
  • Boa Tarde Richard.

    Sim clientes XP PRO SP3, tenho uns clientes Windows 7 e um deles a tela ficou preta ou pela metade. Mas o maiior problema tem sido com os clientes XP.

    terça-feira, 7 de dezembro de 2010 17:55
  • Rodrigo, bom dia!

    O que o Diego falou tem que funcionar, é a opção correta para parar de dar o erro.

    Porém como está perdendo algum tempo com este problema, vou passar uma solução que eu utilizo e que acho melhor que a GPO.

    Apenas uma forma alternativa de solucionar o problema.

    1. Baixe o aplicativo chamado BGinfo ele pode ser econtrado no sysinternals

    2. Crie uma pasta dentro do netlogon, com o nome "Support"

    3. 'Papel de Parede

    Set WshShell = WScript.CreateObject("WScript.Shell")
    WshShell.run   "\\nomedoservidor\netlogon\Support\bginfo\Bginfo.exe \\nomedoservidor\netlogon\Support\bginfo\BGinfo.bgi /timer:0 /SILENT /nolicprompt"

    4. Salve o arquivo em .VBS, se já possuir um script em vbs, apenas insira a linha, caso tenha um .BAT, utilize este script dentro do seu .Bat para chamar o .VBS e evitar de precisar trocar o nome do script no logon dos usuários.

    5. Chamar vbs no bat \\servidor\compartilhamento\nomedovbs.vbs

    Qualquer dúvida estou a disposição!

    abs


    ..::.. Carlos Henrique | MCSA WINDOWS SERVER 2003 ..::..
    • Sugerido como Resposta Diego Piffaretti quarta-feira, 8 de dezembro de 2010 11:21
    • Marcado como Resposta Richard Juhasz sexta-feira, 10 de dezembro de 2010 16:15
    quarta-feira, 8 de dezembro de 2010 11:18