none
Problema redirecionamento Interno RRS feed

  • Pergunta

  • Criei um no-ip para publicar um site da minha rede interna para Externa, externamente funciona que é uma beleza:

    http://xxx.no-ip.org:9090/

    Porém internamente ele não funciona...

    Já adicionei o dominio do no-ip como confiável, porém ainda não está funcionando...

    Alguma idéia?

    Desde já agradeço :)

    quarta-feira, 20 de março de 2013 19:54

Respostas

  • Oi Douglas, muito obrigado..funcionou :)

    Porém, notei que todos meus redirecionamentos estão com esse mesmo problema (Acesso remoto e algumas portas especificas de sistemas dentro da empresa). Olhando o log ele fica assim:

    Exemplo: fiz um redirecionamento de acesso remoto (3389), externamente funciona e internamente não. Tenho uma regra "liberação geral" e lá fica todos os protocolos que ficam liberado na minha rede, quando tento acessar internamente e fico acompanhando o log, ele fica "iniciando" e "encerrando" dentro da regra "liberação geral, ou seja..nem passa pelo redirecionamento".

    Parece que tem que liberar alguma coisa no Isa...

    • Marcado como Resposta Antonio Castro12 quinta-feira, 21 de março de 2013 17:45
    quinta-feira, 21 de março de 2013 12:37
  • Bom dia!

    Se não me engano, as melhores práticas do Windows dizem pra usar o DNS nesse caso, dai você não precisa criar mais uma regra. Dessa forma ele nem passa pelo seu ISA, ou seja, seu tráfego não "vai-e-volta". Bem provavel que vai melhorar a latencia internamente também.

    Seria só acessar seu DNS interno (provavelmente seu AD se for uma rede pequena), entrar no DNS e adicionar um foward lookup zone com o dominio que voce utiliza (no-ip.org), e adicionar um HOST A com o seu endereço http:\\xxxx (ele ja completa com o no-ip.org) e colocar como destino seu ip INTERNO exemplo 192.168.1.50 (seu servidor interno).

    Abraços!!

    Felipo Gonçalves
    Microsoft Contingent Staff

    • Marcado como Resposta Antonio Castro12 quinta-feira, 21 de março de 2013 17:47
    quinta-feira, 21 de março de 2013 13:55

Todas as Respostas

  • Pessoal é Isa Server 2006, muito obrigado!
    quarta-feira, 20 de março de 2013 19:55
  • Boa noite!

    Tu publicou liberando de Externo para sua aplicação. O que podes fazer internamente é:

    Create Access Rule

    Ação: Deny (Redirect: http://ip_interno_da_sua_aplicacao)

    Protocolo: HTTP

    De: Internal / Local Host

    Para: (URL Sets) Aqui tu crias a url com o endereço externo

    Usuário: All Users

    Veja se, quando da sua rede, tu digitar o mesmo nome que usa externamente, ele vai negar e te redirecionar para a url da aplicação interna..


    Douglas Urbano

    quinta-feira, 21 de março de 2013 01:29
  • Oi Douglas, muito obrigado..funcionou :)

    Porém, notei que todos meus redirecionamentos estão com esse mesmo problema (Acesso remoto e algumas portas especificas de sistemas dentro da empresa). Olhando o log ele fica assim:

    Exemplo: fiz um redirecionamento de acesso remoto (3389), externamente funciona e internamente não. Tenho uma regra "liberação geral" e lá fica todos os protocolos que ficam liberado na minha rede, quando tento acessar internamente e fico acompanhando o log, ele fica "iniciando" e "encerrando" dentro da regra "liberação geral, ou seja..nem passa pelo redirecionamento".

    Parece que tem que liberar alguma coisa no Isa...

    • Marcado como Resposta Antonio Castro12 quinta-feira, 21 de março de 2013 17:45
    quinta-feira, 21 de março de 2013 12:37
  • Bom dia, Antonio!

    Que bom que funcionou, marque como resposta o que lhe ajudou para que possa servir de exemplo para outros.

    Quanto aos problemas de redirecionamentos da porta 3389, você quer fazer como? Redirecionar o acesso para uma máquina (servidor) especifico?

    Ou você tenta acessar interno seu server pelo remoto e não funciona? me explique que te ajudo.


    Douglas Urbano

    quinta-feira, 21 de março de 2013 12:48
  • Bom dia!

    Se não me engano, as melhores práticas do Windows dizem pra usar o DNS nesse caso, dai você não precisa criar mais uma regra. Dessa forma ele nem passa pelo seu ISA, ou seja, seu tráfego não "vai-e-volta". Bem provavel que vai melhorar a latencia internamente também.

    Seria só acessar seu DNS interno (provavelmente seu AD se for uma rede pequena), entrar no DNS e adicionar um foward lookup zone com o dominio que voce utiliza (no-ip.org), e adicionar um HOST A com o seu endereço http:\\xxxx (ele ja completa com o no-ip.org) e colocar como destino seu ip INTERNO exemplo 192.168.1.50 (seu servidor interno).

    Abraços!!

    Felipo Gonçalves
    Microsoft Contingent Staff

    • Marcado como Resposta Antonio Castro12 quinta-feira, 21 de março de 2013 17:47
    quinta-feira, 21 de março de 2013 13:55
  • Bom dia, Felipo!

    Você não esta enganado não, ele pode sim, fazer exatamente igual estas falando, vai funcionar também, basta criar uma entrada com o Host. Solução que funciona corretamente também.

    Abraços


    Douglas Urbano

    quinta-feira, 21 de março de 2013 14:16
  • Uhul! Duas soluções para nosso amigo! ;)

    Att,
    Felipo Gonçalves
    Microsoft Contingent Staff

    quinta-feira, 21 de março de 2013 14:23
  • Essa do DNS eu tentei, eu pingava no no-ip ele mandava para o IP interno, porém quando eu colocava na URL ele mandava a solicitação pro Proxy...

    Outro problema que eu tenho é por exemplo, temos um sistema que é um Client que utiliza 2 portas para conexão (4081 e 3550), eu faço o redirecionamento de externa para o IP interno da máquina (192.168.4.2), de externo para interno funciona, mas se eu estou no range da interna ele não funciona..

    quinta-feira, 21 de março de 2013 17:49
  • Pra resolver o problema do proxy só arruma na sua GPO para não usar proxy para endereços locais, e se quiser garantir coloca o endereço do serviço nas exceções ;)

    Deve resolver seu segundo problema também.

    Abraços!

    Felipo Gonçalves
    Microsoft Contingent Staff

    quinta-feira, 21 de março de 2013 17:58
  • Boa tarde,

    Mas nesta regra que tu criou, tu colocou De: Externa Para: Aplicação, ou colocou De: Externa / Interna também. Usou a opção que te passei acima?


    Douglas Urbano

    quinta-feira, 21 de março de 2013 18:13
  • Mas Felipo, e se aplicaçao da rede interna começar por http???

    que é meu caso...

    msmo desativando proxy local o isa envia para fora da rede


    Server 2008......show!!!!

    segunda-feira, 19 de maio de 2014 00:41
  • Colega bom dia,

    Essa solução resolve meu problema, mas cria outro. Temos o serviço de E-mail gerenciado por um parceiro, que fornece via pop pra gente. Fazendo essa zona, e configurando o servidor com um serviço especifico, o e-mail para de funcionar.

    Att,

    sexta-feira, 11 de maio de 2018 12:14