locked
Enumeração baseada em acesso não oculta pastas sem direito RRS feed

  • Pergunta

  • Boa Tarde,

    Tenho um servidor de arquivos com Windows Server 2012 R2 Datacenter (maquina virtual Hyper-V) e estou tentando habilitar a enumeração baseada em acesso para ocultar as pastas que os usuários não tem acesso, copiei a estrutura de pastas de um servidor Windows Server 2008 R2 (servidor físico) que estava ocultando perfeitamente as pastas com os mesmos direitos, mesmo criando uma pasta nova com direito somente para SYSTEM e Domain Admins também não oculta, sendo que a enumeração baseada em acesso esta habilitada no compartilhamento do DFS Namespaces, alguém tem alguma ideia?

    terça-feira, 8 de agosto de 2017 16:49

Respostas

Todas as Respostas

  • Olá Claudio,

    Quantos membros existem neste seu DFS? A função de Access Based Enumeration está habilitada em todos os servidores membros deste DFS?

    A disposição,

    Marcos Roberto de Lima
    MCT-MCTS-MCITP-MCP

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    terça-feira, 8 de agosto de 2017 18:11
  • Boa tarde Marcos,

    Somente 1 membro, o servidor antigo 2008 R2 foi removido do DFS Namespaces.

    terça-feira, 8 de agosto de 2017 18:23
  • Olá,

    Sendo assim, tente fazer a configuração direto no compartilhamento do servidor e não no DFS.

    A disposição,

    Marcos Roberto de Lima
    MCT-MCTS-MCITP-MCP

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    terça-feira, 8 de agosto de 2017 18:32
  • Marcos,

    Eu já criei uma pasta nova com compartilhamento novo sem usar o DFS Namespaces e mesmo assim nessa estrutura também não oculta as pastas sem direito de acesso do usuário conectado.

    terça-feira, 8 de agosto de 2017 18:51
  • Olá,

    Você chegou "Quebrar a Herança" das Permissões NTFS do Compartilhamento mais alto?

    A disposição,

    Marcos Roberto de Lima
    MCT-MCTS-MCITP-MCP

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    terça-feira, 8 de agosto de 2017 19:00
  • Marcos,

    Eu quebrei a herança da pasta e deixei acesso somente para "SYSTEM" e "Administrator", e mesmo assim não oculta a pasta.

    terça-feira, 8 de agosto de 2017 19:09
  • Olá,

    Você pode me descrever como você está fazendo o teste?

    A disposição,

    Marcos Roberto de Lima
    MCT-MCTS-MCITP-MCP

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    terça-feira, 8 de agosto de 2017 19:12
  • Marcos,

    Criei uma pasta E:\teste com direito System, Administrator e Usuário (list somente nesta pasta), compartilhada como teste e acesso usuários alteração

    Subpasta E:\teste\teste0 com direito System e Administrator

    Subpasta E:\teste\teste1 com direito System, Administrator e Usuário (alteração)

    Conectado com usuário deveria ver somente a pasta E:\teste\teste1, mas ele esta vendo a pasta teste0 também

    terça-feira, 8 de agosto de 2017 19:22
  • Olá Claudio,

    Pelo que você está me dizendo, se eu entendi direito você está conectando diretamente na console do servidor com um usuários com direitos de usuário para utilizar a função, é isso mesmo? A funcionalidade de Access Based Enumeration funciona apenas quando o usuário acessa o recurso através de \\servidor\compartihamento de outra estação de trabalho.

    A disposição,

    Marcos Roberto de Lima
    MCT-MCTS-MCITP-MCP

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    terça-feira, 8 de agosto de 2017 19:37
  • Marcos,

    Estou acessando o compartilhamento de uma estação e não do servidor.

    terça-feira, 8 de agosto de 2017 19:45
  • Claudio,

    Faça o seguinte, na pasta Teste deixe apenas as permissões NTFS para SYSTEM e Administrator. Logue na estação de trabalho e me diga o resultado.

    A disposição,

    Marcos Roberto de Lima
    MCT-MCTS-MCITP-MCP

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    terça-feira, 8 de agosto de 2017 19:51
  • Marcos,

    Quando faço isso ele nem acessa o compartilhamento.

    quarta-feira, 9 de agosto de 2017 18:56
  • Claudio,

    Ótimo, era justamente isso que eu queria!!!

    Agora você vai fazer o seguinte: Vá até a pasta Raiz, adicione o grupo "Domain Users" e de a permissão de apenas "Listar o Conteúdo de Pastas", depois disso clique em "Avançadas" clique no botão "Alterar Permissões" sobre o grupo "Domain Users" clique em "Editar" na opção Aplicar em: Altere para somente esta pasta.

    Depois disso, os usuários já poderão acessar o Compartilhamento.

    Agora Crie um grupo Pasta1 e outro Pasta2, coloque o usuários de deste apenas no grupo Pasta1, crie as pastas Pasta1 e Pasta2 dentro da Raiz do Compartilhamento.

    Na Pasta1 de permissões de Leitura para o Grupo Pasta1 e não faça nada com a Pasta2.

    Provavelmente, o usuário irá ver apenas a Pasta1 e não conseguira ver a Pasta2.

    Faça esse teste e nos fale sobre o resultado.

    A disposição,

    Marcos Roberto de Lima
    MCT-MCTS-MCITP-MCP

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    quarta-feira, 9 de agosto de 2017 19:30
  • Marcos,

    Efetuei os testes que você solicitou e o problema de ocultar as pastas continua, o servidor 2008 R2 (servidor Fisico) tem a mesma configuração e esta funcionando, o servidor 2012 R2 esta em ambiente virtualizado, os VHDs em storage conexão fibra, o AD esta modo funcional Windows 2008 e o controlador de domínio 2008 R2.

    quinta-feira, 10 de agosto de 2017 12:52
  • Olá Claudio,

    Reproduzi o seu ambiente aqui no meu Lab e a função de Access Based Enumeration funcionou corretamente.

    Existe alguma outra variável no seu ambiente? Pois consegui utilizar a função aqui no Lab sem problemas.

    A disposição,

    Marcos Roberto de Lima
    MCT-MCTS-MCITP-MCP

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    quinta-feira, 10 de agosto de 2017 12:56
  • Marcos,

    Já efetuei esse tipo de migração varias vezes e não tive esse problema, o servidor antigo era 2008 R2 controlador de domínio e o novo 2012  R2 não.

    quinta-feira, 10 de agosto de 2017 13:16
  • Marcos,

    Um detalhe novo que estou usando nesse ambiente é o time de placas de rede do próprio S.O. do servidor físico sendo que cada placa esta ligada em um switch diferente.

    Eu já tive problemas em alguns ambientes com a opção "Virtual Machine Queues" ativa nas placas de rede, nesse caso deixei ativa, você costuma deixar ativa essa opção? referente ao time de placas de rede você já teve algum problema?

    quinta-feira, 10 de agosto de 2017 13:29
  • Claudio,

    Não, nunca tive problema relacionado ao Nic Team do Windows 2012 R2.

    Voltando ao seu caso, voltando ao ponto onde você removeu as permissões NTFS da pasta e o Usuário não acessava mais... Na pasta Raiz, você deu a permissão de "List Folders" para Domain Users e modificou a permissão para "Apenas essa Pasta"?

    A disposição,

    Marcos Roberto de Lima
    MCT-MCTS-MCITP-MCP

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    quinta-feira, 10 de agosto de 2017 14:27
  • Marcos.

    Isso mesmo, mas o que esta acontecendo é que essa função não esta funcionando no servidor.

    quinta-feira, 10 de agosto de 2017 14:35
  • Claudio,

    Você pode me passar o seu Skype, estou muito intrigado com esse seu caso.

    A disposição,

    Marcos Roberto de Lima
    MCT-MCTS-MCITP-MCP

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    quinta-feira, 10 de agosto de 2017 14:54
  • Marcos,

    Fiz a estrutura de pastas em outros servidores e acabei de descobrir que só esta funcionando nas pastas compartilhadas nos controladores de domínio, em qualquer outro servidor que não seja controlador de domínio não funciona.

    quinta-feira, 10 de agosto de 2017 19:38
  • Claudio,

    Sendo assim, vejo que podemos encerrar esse caso, pois o recurso Access Based Enumeration funciona corretamente, porem existe algum ponto em sua Infra o qual deve ser verificado, pois esta função funciona corretamente em qual servidores sem a necessidade de ser um DC.

    Sugiro que você comece a sua verificação pelos seus Controladores de Dominio.

    Por favor, não esqueça de Marcar como Resposta, pois isso é muito importante para Comunidade e faz com que nós estejamos aqui para ajudar sem que possível.

    A disposição,

    Marcos Roberto de Lima
    MCT-MCTS-MCITP-MCP

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    quinta-feira, 10 de agosto de 2017 19:47
  • Resolvido,

    GPO configurada que dava acesso ao usuários de fazer backup, solução encontrada no link abaixo:

    Computer Settings -> Policies -> Windows Settings -> Security Settings -> Local Policies -> User Rights Assignment "Back up files and directories"

    https://social.technet.microsoft.com/Forums/windowsserver/en-US/e507c5db-3dd0-4635-b58b-4930a065ddc3/what-would-cause-access-based-enumeration-not-to-work-i-have-a-problem-which-is-driving-me-crazy?forum=winserverfiles

    • Marcado como Resposta Claudio R70 quinta-feira, 10 de agosto de 2017 21:51
    quinta-feira, 10 de agosto de 2017 21:51