none
Configuração de rede do Windows Server 2003 SBS com Link ADSL pela Brasil Telecom RRS feed

  • Pergunta

  •  

    Boa noite a todos!!!!!

    Antes de mais nada, venho a homenagear o fórum.

    Sou leitor a alguns anos e sempre que procuro sanar minhas dúvidas recorro a esta fantástica ferramenta!!!

    Vou tentar ser o mais claro possível no meu problema...

    Dúvida: Tenho a necessidade de configurar a placa de rede de um servidor ( Windows 2003 SBS ( Small Business Server ) + Exchange + Aplicação
    Interna em SQL ) com o IP Público ( IP WAN ) fornecido pela Brasil Telecom usando um MODEM ADSL D-link 500B. O IP é Fixo , por ADSL. O Servidor possui
    duas placas de rede, uma ligada ao link de internet ( Placa Externa, ou Placa WAN ) e outra ligada a rede interna através de Switch distribuindo internet
    a rede interna ( Placa Interna, ou Placa LAN )


    Por que preciso configurar o IP Público direto na placa de rede=> Na empresa tentamos configurar com algum IP Interno que o D link fornece,
    mais aí não conseguimos acessar de fora da empresa.Desta forma usamos o serviço da Virtua por cable modem que nos fornece o IP Público direto.

     

    Meu Ambiente:

     

    Na verdade hoje temos um link pela Virtua com CABLE MODEM ( Usando o equipamento Motorola SB5100 ) que nos fornece um IP Público direto na placa de rede ( no server )que é ligada a internet.

    Desta forma segue as minhas dúvidas:

     

    1 ) Gostaria de saber se existe alguma configuração no D-Link 500B que possa fazer para que ao invés do modem D-link 500B me largar algum IP Privado do
    tipo 10.1.x.x ou 192.168.x.x me largar o IP Público de forma que possa configurar a placa de rede externa com o IP Público.

    2 ) Tenho uma aplicação que roda Banco de Dados ( Em Firebird ) no Windows 2003 SBS na qual tenho um acesso Web pela URL http://<ip publico>:7080/diretorio/index.php? e também o acesso ao Exchange ( E-mail ) pelo https://ip publico/exchange.

    Como os acessos ao Banco de Dados e ao Exchange sempre foram feitos desta forma, tenho receio em trocar o Link ( Virtua pela Brt ) e configurar a placa de rede para um "IP não público" ( Que seria os IP's Privados, certo ) e estes dois serviços não funcionarem, sendo que são serviços crucias para a empresa.

    Agradeço a todos pela ajuda.

     

    terça-feira, 13 de janeiro de 2009 01:00

Respostas

  • Olá,

     

    não tem problema  o modem te dar um ip privado. O que vai ser necessário é configurar o modem para fazer o roteamento ( modo bridge) e mapear as portas que você precisa para o servidor.

     

    Outra solução: compre um roteador (Dlink, Linksys) ou de outro fabricante e o configure para fazer o roteamento.

     

    Sendo assim não precisará mexer no modem.

     

    As placas de rede poderão ficar assim:

     

    Rede Interna: 192.168.0.1

    Rede Externa: 10.0.0.1

     

    Ai vc roda o wizard do SBS de configuração de email e internet e informa qual é a rede interna e a rede externa.

     

    Lembre de abrir as portas no roteador para as aplicações que vc precisa: BD, Exchange, OWA, etc

     

    sds,

    terça-feira, 13 de janeiro de 2009 19:10
    Moderador
  •  

    olá,

     

    as portas necesárias: 25 e 443

     

    zona reversa: deve estar configurado com a faixa de ip de sua rede, exemplo: se sua rede for 192.168.0.0 a zona reversa será 192.168.0

     

    mx: é necessário apontar para que os outros servidores possam enviar emails pra vc. isso é alterado no seu provedor de internet. basta ligar pra eles e pedir para apontar o mx para o seu ip publico ( internet)

     

    sds,

     

     

    quarta-feira, 14 de janeiro de 2009 00:52
    Moderador
  • Olá,

     

    1- Dentro da rede para acessar o OWA vc terá que usar o ip da sua rede interna mesmo, está correto. Somento fora que você usará o IP publico/exchange.

     

    2- Fora da rede use sempre o IP público.

     

    3- Se os usuários do exchange não estão recebendo email você precisa configurar o MX apontando para o seu IP público. Lembre de abrir a porta 25 no roteador.

     

    Abraço

    sábado, 17 de janeiro de 2009 17:36
    Moderador
  • Olá,

     

     

    Quanto ao ping, vc precisa configurar o seu DNS público com o novo IP da Brasil Telecom. Se seu DNS público (.com.br) ficar dentro da empresa, você mesmo configura, se ficar externo, solicite a configuração. O endereço mail.nomedaempresa.com.br tem que apontar para o novo IP da Brasil Telecom.

     

    Emails: Os emails só chegarão ao destino conforme relatado acima apartir do momento que você apontar o MX para o novo IP da Brasil Telecom.

     

    Abraço

    segunda-feira, 19 de janeiro de 2009 12:34
    Moderador

Todas as Respostas

  • Olá,

     

    não tem problema  o modem te dar um ip privado. O que vai ser necessário é configurar o modem para fazer o roteamento ( modo bridge) e mapear as portas que você precisa para o servidor.

     

    Outra solução: compre um roteador (Dlink, Linksys) ou de outro fabricante e o configure para fazer o roteamento.

     

    Sendo assim não precisará mexer no modem.

     

    As placas de rede poderão ficar assim:

     

    Rede Interna: 192.168.0.1

    Rede Externa: 10.0.0.1

     

    Ai vc roda o wizard do SBS de configuração de email e internet e informa qual é a rede interna e a rede externa.

     

    Lembre de abrir as portas no roteador para as aplicações que vc precisa: BD, Exchange, OWA, etc

     

    sds,

    terça-feira, 13 de janeiro de 2009 19:10
    Moderador
  • Boa noite,

     

    Daniel,

     

    Agradeço pelos esclarecimentos. Foram muito bem vindos!!!!!!!!!!!

     

    Tenho algumas dúvidas ainda que estava vendo hoje.

     

    1 ) Hoje uso o Exchange como ferramenta de e-mail. Quais as portas necessárias devo liberar no Modem ( D Link 500B ) para o funcionamento correto do Exchange e o OWA tanto na rede interna quanto para rede externa ( Diga-se rede externa se tento enviar um e-mail do meu dominio ( fulano@dominioempresa.com.br ) para ciclano@gmail.com ) As portas que ja liberei são as seguintes: 25 ( TCP/UDP ), 50389 (TCP/UDP )*, 50636 ( TCP/UDP )*,110 ( TCP/UDP ) e 443 ( TCP/UDP ). Devo fazer alguma liberação no Windows Server também?

     

    2 ) Estive notando que existe as seguintes configurações no DNS: Caminho: DNS -> nome_dominio -> Zonas de Pesquisas Inversa -> Uma pasta com a rede interna ( 192.168.0.x Subnet ) e Uma pasta com o IP da Rede Externa ( <03 primeiros números do IP Publico que possuo>.x Subnet ).

    Pergunto: Devo criar uma nova Zona? Se sim, existe algum tutorial com os passos corretos?

     

    3 ) Em varios sites li que devo mudar "Os M'xs"

    O que são?

    Para que servem?

    Realmente devo mudar?

    Em alguns sites com tutorial li que tinha que mudar, mais náo dizia como...

     

    Agradeço toda a ajuda.

     

    Obrigado

     

    Mantovani

     

     

     

     

     

     

    quarta-feira, 14 de janeiro de 2009 00:19
  •  

    olá,

     

    as portas necesárias: 25 e 443

     

    zona reversa: deve estar configurado com a faixa de ip de sua rede, exemplo: se sua rede for 192.168.0.0 a zona reversa será 192.168.0

     

    mx: é necessário apontar para que os outros servidores possam enviar emails pra vc. isso é alterado no seu provedor de internet. basta ligar pra eles e pedir para apontar o mx para o seu ip publico ( internet)

     

    sds,

     

     

    quarta-feira, 14 de janeiro de 2009 00:52
    Moderador
  •  Daniel C. Santos wrote:

    Olá,

     

    não tem problema  o modem te dar um ip privado. O que vai ser necessário é configurar o modem para fazer o roteamento ( modo bridge) e mapear as portas que você precisa para o servidor.

     

    Outra solução: compre um roteador (Dlink, Linksys) ou de outro fabricante e o configure para fazer o roteamento.

     

    Sendo assim não precisará mexer no modem.

     

    As placas de rede poderão ficar assim:

     

    Rede Interna: 192.168.0.1

    Rede Externa: 10.0.0.1

     

    Ai vc roda o wizard do SBS de configuração de email e internet e informa qual é a rede interna e a rede externa.

     

    Lembre de abrir as portas no roteador para as aplicações que vc precisa: BD, Exchange, OWA, etc

     

    sds,

    sexta-feira, 16 de janeiro de 2009 02:09
  • Estarei testando todas estas dicas e informações e estarei postando os resultados.

     

    Obrigado

    sexta-feira, 16 de janeiro de 2009 02:13
  •  

    Boa noite a todos!!!!!

    Desculpe a demora em postar o meu retorno, pois fiz a troca do Link hoje ao final do expediente

     

    Estarei postando todos os meus resultados, até por que outras pessoas podem estar passando ou algum dia tenham que passar por esta situação... 

     

    Meu Ambiente:

     

    O que tinha.

    - 01 Link Cable MODEM pela virtua com IP Fixo ligado diretamente ( Placa de Rede Externa ou WAN ) em um servidor rodando o SBS 2003 ( Small Business Server )  Standart SP2 + uma placa de rede interna ( Para a rede interna )

     

    O que tenho agora

    - 01 Link ADSL ( Não é IP Turbo, é ADSL residencial mesmo ) com IP Pixo pela Brasil Telecom ligado em um MODEM/ROTEADOR D link 500b em um servidor rodando o SBS 2003 ( Small Business Server )  Standart SP2 + uma placa de rede interna ( Para a rede interna )

     

    Para tornar o post mais dinâmico e objetivo vou colocar as minhas dúvidas e como solucionei.

     

    1 ) Gostaria de saber se existe alguma configuração no D-Link 500B que possa fazer para que ao invés do modem D-link 500B me largar algum IP Privado do
    tipo 10.1.x.x ou 192.168.x.x me largar o IP Público de forma que possa configurar a placa de rede externa com o IP Público.

     

    R: Perfeita observação do Daniel, configurei meu modem/roteador D Link 500B com IP para a rede interna de gateway 10.1.1.1, liguei na placa de rede externa com IP Fixo de 10.1.1.x / Mascara: 255.0.0.0 / Gateway: 10.1.1.1 e na outra placa de rede ( Interna ou LAN ) como 192.168.0.x ( Segmentos de rede diferentes ) e o meu acesso a interne foi perfeito J

     

     

    Bom, como nem tudo são flores, vai alguns problemas que encontrei.

     

    1 ) Dentro da minha rede interna, quando vou tentar acessar o OWA através do novo ip publico ( http://<novo_ip_publico_brt>/exchange ) não consigo da o seguinte erro.

    404 Not Found

    File not found.

     


    micro_httpd

    Suspeita.

     

    A Placa de rede externa esta configura da seguinte forma.

    IP: O IP 10.1.1.x ( para conectar com o modem )

    Mascara: OK

    Gateway: 10.1.1.1

    No DNS Principal coloquei o IP Interno do Servidor... Ou Coloco os DNS Principal e secundarios passado pela BrT. Esta certo? Pode ser por causa disto?

     

     

     

    2 )  Apenas consigo acesso pelo ip da rede http://192.168.0.1/exchange, porem de qualquer rede for a da empresa ( Na minha casa por exemplo ) consigo acessar pelo novo ip publico ( http://<novo_ip_publico_brt>/exchange )

     

    Se envio e-mail de fulano@dominioempresa.com.br para ciclano@dominioempresa.com.br => Ok, ambos recebem

    Se envio de fulano@dominioempresa.com para alguém@gmail.com Ok, o algum recebe.

    Mas se o alguém@gmail.com envia para o fulano@dominioempresa.com o fulano não esta recebendo

     

    Vou colocar como está a minha configuração na Zona de pesquisa direta

     

    DNS -> Nome_do_micro_controlador_de_dominio -> Zona de pesquisa direta -> nome_do_dominio

     

    Companyweb                             alias (CNAME )                          nome_servidor

    Mail                                          Servidor de Mensagens (MX )       [10] mail.<nome_empresa>.com.br

    Servidor                                     host(a)                                      10.1.1.x ( IP da Placa de rede externa que está ligada no MODEM )

    Servidor                                     host(a)                                      192.168.0.x ( IP da Placa de rede Interna que vai para a rede interna )

     

    DNS -> Nome_do_micro_controlador_de_dominio -> Zona de pesquisa Inversa -> nome_do_dominio

     

    Tenho as seguintes Zonas

    192.168.0.x Subnet

    <03_primeiro_numeros_do_ip_publico_virtua_antigo>xSubnet  ( Processo parado:Botao direto -> Propriedades -> Status -> Parado )

    <03_primeiro_numeros_do_ip_publico_BRT_novo>xSubnet

    (igual a pasta pai )                      inicio de autoridade(SOA)                             Music nome_do_micro, hostmaster.<nome_empresa>

    (igual a pasta pai )                      Servidor de nome(NS)                                 nome_servidor

    ip_publico_BRT_novo                  ponteiro(PTR)                                             <nome_servidor>.com.br

     

    Suspeita.

     

    Agradeço toda a ajuda a desvendar estes mistérios.

     

    Caso precisem de mais dados para resolver o problema, estou disponivel

    sábado, 17 de janeiro de 2009 03:22
  • Olá,

     

    1- Dentro da rede para acessar o OWA vc terá que usar o ip da sua rede interna mesmo, está correto. Somento fora que você usará o IP publico/exchange.

     

    2- Fora da rede use sempre o IP público.

     

    3- Se os usuários do exchange não estão recebendo email você precisa configurar o MX apontando para o seu IP público. Lembre de abrir a porta 25 no roteador.

     

    Abraço

    sábado, 17 de janeiro de 2009 17:36
    Moderador
  • Boa noite a todos,

     

    Valeu por todas estas informações!!!!!!!!!!!!!  Estão sendo de grande valia mesmo...

     

    Acho que a dica do MX é valida mesmo!!!!!!!!!!!!!!! ( Pois deixei liberado a porta 25 no roteador tanto para TCP quanto UDP )

     

    So me tira uma dúvida, Daniel...

     

    Antes se eu pingava de fora da rede da empresa o mail.nomeempresa.com.br ele me direcionava para o ip da virtua( IP pùblico antigo  ). Tranquilo!!!!!!!!

     

    Agora se faço o mesmo ping para mail.nomeempresa.com.br  ele continua me direcionando para o IP da virtua, so que agora da esgotado o tempo limite e tal......

     

    Como mudei o IP Publico de virtua para Brasil Telecom está evidente que tenho que pedir para o meu provedor para mudar o MX do mail.nomeempresa.com.br para o novo IP da Brasil Telecom( Desculpe ser tão repetitivo nesta parte, é que neste sentido tenho pouca experiência )


    Para ilustrar melhor o problema ao enviar e-mail de alguem@gmail.com para o fulano@dominioempresa.com.br segue o e-mail de erro que voltou


    "This is an automatically generated Delivery Status Notification

    THIS IS A WARNING MESSAGE ONLY.

    YOU DO NOT NEED TO RESEND YOUR MESSAGE.

    Delivery to the following recipient has been delayed:

        fulano@dominioempresa.com.br

    Message will be retried for 2 more day(s)

    Technical details of temporary failure:
    The recipient server did not accept our requests to connect. Learn more at http://mail.google.com/support/bin/answer.py?answer=7720
    [mail.nomeempresa.com.br. (10): Connection timed out]"


     

    Muito obrigado pela contribuição

     

    Att

    domingo, 18 de janeiro de 2009 00:08
  • Olá,

     

     

    Quanto ao ping, vc precisa configurar o seu DNS público com o novo IP da Brasil Telecom. Se seu DNS público (.com.br) ficar dentro da empresa, você mesmo configura, se ficar externo, solicite a configuração. O endereço mail.nomedaempresa.com.br tem que apontar para o novo IP da Brasil Telecom.

     

    Emails: Os emails só chegarão ao destino conforme relatado acima apartir do momento que você apontar o MX para o novo IP da Brasil Telecom.

     

    Abraço

    segunda-feira, 19 de janeiro de 2009 12:34
    Moderador
  • Bom antes de mais nada...

    Muito obrigado Daniel!!!!!!!!!!!!!!!!!!!!!!!!!

    A Dica do MX funcionou perfeitamente... Liguei para o meu provedor pedi para mudar o Mx que estava apontando o mail.nomeempresa.com.br de ip virtua ( IP Antigo ) para o IP Brasil Telecom ( Novo ), fiz o teste de ping... Assim que pingou ja estava conseguindo receber os e-mail externos...


    Venho a fechar este post e garantir que nesta situação que passei, cada passo discutido neste tópico funcionou perfeitamente....

    Grande abraço a todos!!!!!!!!!!!!

    segunda-feira, 19 de janeiro de 2009 19:16