none
Erro LDIFDE RRS feed

  • Pergunta

  • Boa tarde pessoal,

    Pretendo alterar o campo e-mail de varios contatos de uma determinada OU, foram preenchidos erroneamente.

    Para isso pretendo utilizar o LDIFDE com a opção modify (porque tenho que corrigir este campo em mais de 2000 usuarios) porém esta dando o seguinte erro:

    "Importing directory from file "teste_importacao.ldf"
    Loading entries.
    There is a syntax error in the input file
    Failed on line 3.  The last token starts with 'o'.
    0 entries modified successfully.
    An error has occurred in the program"

     

    O arquivo LDIF que criei esta assim:

     

    dn: CN=NOME,OU=unidadeorganizacional,DC=dominio,DC=com,DC=br
    changetype:modify
    objectClass:contact
    cn: NOME
    description: Atendente
    distinguishedName: CN=NOME,OU=DOMINIO,DC=dominio,DC=com,DC=br
    displayName: NOME
    targetAddress: ENDEREÇOCERTO@DOMINIO.com.br
    name: NOME
    mail: EMAILCORRIGIDO@DOMINIO.COM.BR (Este é o campo onde insiro o que deve aparecer corretamente)


     

     

    O campo que eu quero que fique certo é o campo E-mail

     

    Meu arquivo LDIF esta correto, o que deveria ser alterado? O comando que estou usando é:

     

    ldifde -i -f arquivo.ldf

     

    Obrigado a todos.


    Carlos Eduardo Consultor Técnico MCTS Windows Server 2008 Networking Infrastructure Configuration MCTS Windows Server 2008 Application Infrastructure Configuration ITIL V3 Fondation Certified

    quinta-feira, 5 de janeiro de 2012 15:49

Respostas

  • Bom dia Erick,

     

    Achei o erro, o problema foi que não havia especificado, parametros relativos ao exchange para que ja criasse uma conta de email vinculada ao contato.

     

    Apos isso funcionou com sucesso.

     

    Grato.


    Carlos Eduardo Consultor Técnico MCTS Windows Server 2008 Networking Infrastructure Configuration MCTS Windows Server 2008 Application Infrastructure Configuration ITIL V3 Fondation Certified
    segunda-feira, 9 de janeiro de 2012 10:30

Todas as Respostas

  • Vc poder te errado em algum CN e/ou DN... veja se o usuário, dominio e etc, estão corretos :-)

     

    []s


    Erick Albuquerque | Microsoft MVP
    MVP Profile | Twitter | Linkedin | http://iisbrasil.wordpress.com
    sexta-feira, 6 de janeiro de 2012 18:04
    Moderador
  • Bom dia Erick,

     

    Achei o erro, o problema foi que não havia especificado, parametros relativos ao exchange para que ja criasse uma conta de email vinculada ao contato.

     

    Apos isso funcionou com sucesso.

     

    Grato.


    Carlos Eduardo Consultor Técnico MCTS Windows Server 2008 Networking Infrastructure Configuration MCTS Windows Server 2008 Application Infrastructure Configuration ITIL V3 Fondation Certified
    segunda-feira, 9 de janeiro de 2012 10:30