none
Conexao SQL 2008 RRS feed

  • Pergunta

  • Estou vivendo um drama, estamos mudando o bando de SQL 2000 para SQL Express 2008 e nao consigo fazer a conexao com  o banco a partir das estações, ou seja :

    O firewal do servidor esta com as portas liberadas, SQL rodando, o Client 10 esta instalado nas estações, ping ok, e mesmo assim não consigo conectar ao banco.

     

    Grato pela atenção.

    segunda-feira, 23 de maio de 2011 13:37

Respostas

  • Se você tiver usando SQLAutentication não é necessário, mas como Windows Authentication sim. O PortQry não retornou nenhuma mensagem de erro?
    Tks. Fausto Fiorese Branco MCTS, MCITP/DBA 2005 | MCITP/DBA 2008 São Paulo - Brasil * http://www.linkedin.com/in/faustobranco
    segunda-feira, 23 de maio de 2011 14:29

Todas as Respostas

  • Ricardo. Revise tambem os protocolos habilitados no servidor, normalmente o Named Pipes vez desabilitado e faz falta. O Ping não vai te ajudar, para esse tipo de verificação com o SQLServer/porta/protocolo utilize o PortQry da MS.

     

    http://www.microsoft.com/downloads/en/details.aspx?FamilyID=89811747-C74B-4638-A2D5-AC828BDC6983

     

    http://support.microsoft.com/kb/310456/pt

     

     


    Tks. Fausto Fiorese Branco MCTS, MCITP/DBA 2005 | MCITP/DBA 2008 São Paulo - Brasil * http://www.linkedin.com/in/faustobranco
    segunda-feira, 23 de maio de 2011 13:41
  • ja fiz tudo isto e revisei passo a passo, so uma curiosidade, é preciso dominio pra autenticar no sql 2008, nao usamos dominio aqui.

     

    segunda-feira, 23 de maio de 2011 14:25
  • Se você tiver usando SQLAutentication não é necessário, mas como Windows Authentication sim. O PortQry não retornou nenhuma mensagem de erro?
    Tks. Fausto Fiorese Branco MCTS, MCITP/DBA 2005 | MCITP/DBA 2008 São Paulo - Brasil * http://www.linkedin.com/in/faustobranco
    segunda-feira, 23 de maio de 2011 14:29
  • Tudo ok com portqry

    querying ...

    TCP port 1433 (ms-sql-s service) Listening

    UDP port 1433 (ms-sql-s service) Listening e filtered

    e adbc nada nas estaçoes, no servidor esta funciona

    segunda-feira, 23 de maio de 2011 15:07
  • Fausto, deu certo aqui. Exclui o Alias no banco. 

    valeu pela atençao, muito obrigado e otima semana, que elea seja iluminada e abençoada.

    segunda-feira, 23 de maio de 2011 15:15