none
Problema com atualização de oab RRS feed

  • Pergunta

  • Olá pessoal, dúvida nova no ar.

     

    A questão refere-se a atualização da oab. Alguns usuários (menos de 3%) não estão sendo listados na oab, porém na lista All users são exibidos.

     

    Utilizei o cmd-let:

     

    Code Snippet
    get-offlineaddressbook | update-offlineaddressbook

     

     

    sem sucesso.

     

    O detalhe é que fizemos uma correção de grande porte neste ambiente no último fim de semana, o mesmo estava com nome de domínio incorreto (ex: domain) e alteramos para o recomendado (ex: domain.corp).

     

    Verifiquei também se os endereços smtp dos usuários estavam corretos, tudo ok.

     

    Validei os tutorias do Anderson...mas nada ainda...

     

    Obrigado.

    quarta-feira, 13 de agosto de 2008 21:06

Respostas

Todas as Respostas

  •  

    Ola Deivid,

     

    Via OWA eles aparecem? Se sim eles podem ter algum problema para valdiar habilita o debug da oab (tem la no site como habilitar o debug) olha os logs do eventviewer apos forçar a atualizacao e ai tem um kb para os erros no site da ms.

     

    quarta-feira, 13 de agosto de 2008 23:08
  • Após efetuar o procedimento de atualização ocorre o seguinte erro:

     

    Event Type: Warning
    Event Source: MSExchangeSA
    Event Category: OAL Generator
    Event ID: 9327
    Date:  13/8/2008
    Time:  18:43:26
    User:  N/A
    Computer: BRMS0301
    Description:
    OALGen skipped some entries in the offline address list '\Global Address List'.  To see which entries are affected, event logging for the OAL Generator must be set to at least medium.
    - Default Offline Address Book

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

     

    Não consegui compreender qual o serviço na lista retornada através do comando Get-EventLogLevel está relacionado com a oab. E depois de ativado, onde ocorre a saída do debug?

     

    Obrigado.

    quarta-feira, 13 de agosto de 2008 23:50
  • Ola Deivid,

     

    Esse teu Exchange 2007 está com o SP1?

    E quanto ao problema do log, veja esse tutorial: http://www.andersonpatricio.org/tutoriais/tutoriais.asp?tut=844

    E veja também esse artigo para lhe ajudar: http://blogs.msdn.com/dgoldman/archive/2005/07/16/How-to-troubleshoot-the-OAB-Generation-process.aspx

     

    Abs.

     

    quinta-feira, 14 de agosto de 2008 00:10
  • Não possui SP1 ainda, estamos planejando a implantação. Bom, na realidade os endereços passaram a serem listados. Não fiz nada além do Get-OffLineAddressBook | Update-OffLineAddressBook.

     

     

    Obrigado pela ajuda, os procedimentos passados por você já estão nos "Favoritos". Valeu.

     

    quinta-feira, 14 de agosto de 2008 00:15
  • Esta atualização demora em média quanto tempo em um ambiente com umas 150 mailbox?

    Pois percebi que meu OAB estava no servidor com Exchange 2003 e movi para o 2007. Mesmo assim os Outlooks 2003 e 2007 continuam dando erro ao tentar abixar Catalogo.

    As alterações que fiz referente a um ambiente funcional foi retirar o https do OWA.

    Alguem pode dar uma luz?

    Obrigado,
    Luiz Sérgio
    sexta-feira, 26 de junho de 2009 18:37
  • Ola Luiz,

    A atualizacao é rapida, mas para forçar, tu tem que dar um update na OAB (como o Deivid Foggi escreveu) depois ir no cliente outlook e baixar o catalogo de endereços, ai tu tem certeza que está atualizado.

    Para que isso ocorra depende tb da versao do office como esta  configuracao da oab (se pf ou Web services).
    Grande abraço, Anderson Patricio http://www.andersonpatricio.org .:. http://blog.andersonpatricio.org http://msmvps.org/blogs/andersonpatricio
    sexta-feira, 26 de junho de 2009 18:52