none
Maquinas não se comunicam internamente no Hyper-V RRS feed

  • Pergunta

  • Pessoal, boa tarde!!

    Meu problema é o seguinte:

    Criei 3 maquinas virtuais no Hyper-V: A, B e C.

    Configurei os vSwitches e as placas de rede. Foi criado um vSwitch privado para as maquinas se falarem internamente.

    Aí é que vem o problema.

    Eu consigo pingar a partir da maquina B e C para a maquina A, porém, não consigo pingar a partir da maquina A para nenhuma das demais, além disso, as maquinas B e C não pingam entre si.

    quinta-feira, 7 de abril de 2016 16:43

Respostas

  • Boa tarde,

    Vamos lá...

    Para a comunicação apenas entre VMs, você precisa apenas de um virtual switch (private), nada mais.

    Após atribuir as nics das VMs a este virtual switch, você deve entrar em cada uma delas e configurar a NIC das mesmas com um IP de mesmo range para as três, gateway não é necessário, exemplo:

    VM1 - 192.168.10.1

    VM2 - 192.168.10.2

    VM3 - 192.168.10.3

    Máscara 255.255.255.0 para todas

    Quanto ao Ping (ICMP), verifique no firewall do Windows se o mesmo não esta bloqueado, para testar, pode desabilitar de forma temporária.


    Erik R. Filippini - MCP | MTA | SEC | ITIL V3 ** Caso responda sua pergunta, favor marcar como resposta, se for útil, favor votar, isso ajuda na indexação do fórum, obrigado **

    • Sugerido como Resposta Erik Filippini quinta-feira, 7 de abril de 2016 18:45
    • Marcado como Resposta Linc0 quinta-feira, 7 de abril de 2016 18:48
    quinta-feira, 7 de abril de 2016 18:04

Todas as Respostas

  • Boa tarde Linc0,

    Você usou o mesmo gateway e máscara para as 3 máquinas?

    Abraço.

    quinta-feira, 7 de abril de 2016 17:18
  • As Vm estão com DHCP automático?

    Jessian Bayard
    MCP, MCSA, MCSE, MCTS, MCITP, MCT
    www.tiespecialista.com.br

    quinta-feira, 7 de abril de 2016 17:22
  • Ambas estão com o mesmo gateway de rede sim. Mas ainda tenho uma dúvida a respeito do gateway. Quem deveria ser o gateway delas, eu configurei para ser a placa virtual que foi criada (vSwitch), isso está certo??

    Julgando que é uma conexão interna apenas entre as VMs achei que nem seria necessário isso.

    Mas como configurei ambas as placas (maquinas A, B e C) com a mesma configuração (exceção para os IPs claro) achei que não teria problemas.

    quinta-feira, 7 de abril de 2016 17:58
  • Não. Elas estão com IP estático.
    quinta-feira, 7 de abril de 2016 17:59
  • Boa tarde,

    Vamos lá...

    Para a comunicação apenas entre VMs, você precisa apenas de um virtual switch (private), nada mais.

    Após atribuir as nics das VMs a este virtual switch, você deve entrar em cada uma delas e configurar a NIC das mesmas com um IP de mesmo range para as três, gateway não é necessário, exemplo:

    VM1 - 192.168.10.1

    VM2 - 192.168.10.2

    VM3 - 192.168.10.3

    Máscara 255.255.255.0 para todas

    Quanto ao Ping (ICMP), verifique no firewall do Windows se o mesmo não esta bloqueado, para testar, pode desabilitar de forma temporária.


    Erik R. Filippini - MCP | MTA | SEC | ITIL V3 ** Caso responda sua pergunta, favor marcar como resposta, se for útil, favor votar, isso ajuda na indexação do fórum, obrigado **

    • Sugerido como Resposta Erik Filippini quinta-feira, 7 de abril de 2016 18:45
    • Marcado como Resposta Linc0 quinta-feira, 7 de abril de 2016 18:48
    quinta-feira, 7 de abril de 2016 18:04
  • Lá está assim:

    A: 10.1.15.10

    B: 10.1.15.11

    C: 10.1.15.12

    Mascara de ambas 255.255.252.0

    Está correto?

    quinta-feira, 7 de abril de 2016 18:21
  • Quando criei o vSwitch para acesso à rede externa o Hyper-V limpou a configuração do adaptador (ainda consigo acessar a rede normalmente com o host).

    As features, até onde sei, não precisa de nenhuma além do próprio Hyper-V, certo?

    quinta-feira, 7 de abril de 2016 18:23
  • Boa tarde Linc.

    Seguindo a linha na qual o Erik Filippini comentou, se por acaso suas configuracoes estiverem da maneira como ele colocou o que pode estar causando esse bloqueio de comunicao creio que seja o firewall de suas VMs, cheque se estao ON caso estejam coloque todos como OFF e faca os testes.

    Abraco!

    Por favor, marque como resposta caso tenha lhe ajudado.

    Rogerio Dias - MCT, MCSA, MCITP, MCTS, MCP, MS & ITIL


    Roger Dias MCTS - Microsoft Certified Technology specialist MCITP - Server Administrator

    quinta-feira, 7 de abril de 2016 18:35
  • Roger, assim que o Erik respondeu eu fui verificar. Era isso mesmo!

    Até estranhei, pois, o firewall da máquina A estava ativo mas ela recebia ping mesmo assim, enquanto as outras não.

    Agradeço a todos que deram atenção a este post.

    Muito obrigado!!

    Questão resolvida!


    • Editado Linc0 quinta-feira, 7 de abril de 2016 18:45
    quinta-feira, 7 de abril de 2016 18:41
  • Perfeito!

    Estamos à disposição.


    Erik R. Filippini - MCP | MTA | SEC | ITIL V3 ** Caso responda sua pergunta, favor marcar como resposta, se for útil, favor votar, isso ajuda na indexação do fórum, obrigado **

    quinta-feira, 7 de abril de 2016 18:44