locked
Ping muito alto - Lentidão na Rede RRS feed

  • Pergunta

  • Boa tarde pessoal,
     
    Estou com um problema em uma rede de um cliente no qual gostaria da ajuda de vocês. Segue abaixo o pequeno resumo de meu problema:
     
    O cliente está reclamando de lentidão na rede e com isso pude observar que ao pingar de algumas estações para o Servidor o tempo de resposta de cada pacote fica na média de 13ms (que ao meu ver é absurdamente alto, tendo em vista que o normal é >1ms). Sendo que ao pingar do Server para a Estação, o ping fica em uma média de 3ms. Fiz o teste em outras estações porem o problema persistiu. Já troquei a placa de rede da estação o Switch e nada. Diante disso minha pergunta é existe algum software ou ferramenta (baixo custo) que consiga detectar onde está o gargalo?
     
    Obs.: Segue abaixo o link das 2 imagens do ping.
     
     
     
    Fico no aguardo.
    Grato,

    Vanderson Cahet - MCSA 2003
    segunda-feira, 21 de dezembro de 2009 18:41

Respostas

  • Vanderson,

    Deveria ser feito como na possibilidade 1, não teria a necessidade de colocar o wireshark no serveidor você poderia colocar uma outra máquina qualquer ligada no hub para fazer essa analise.
    Estava lendo um material sobre esse switch que o seu cliente possui e esse switch não é gerenciável, não posibilitando espelhar as portas.
    Então faça como citei no post anterior faça uma análise dos pacotes que estão entrando e saindo do servidor, você terá uma idéia do tráfego da rede.
    Depois classifique as respostas e nos mantenha informados sobre a situação. 

    Espero ter Ajudado.
    • Marcado como Resposta Richard Juhasz segunda-feira, 28 de dezembro de 2009 15:15
    quarta-feira, 23 de dezembro de 2009 23:25

Todas as Respostas

  • Vanderson,

              Verifique o ponto de rede, pois pode ter algum mal contato.
              Verifique se a vírus no servidor ou em alguma estação.
              Use algum sniffer de rede para analisar o tráfego.

    Espero ter ajudado.


    Leonardo Sousa
    segunda-feira, 21 de dezembro de 2009 19:39
  • Vanderson,

           Verifique primeiramente o cabeamento e equipamentos de rede, passe por alguns pontos da rede e verifique se nenhuma fonte de energia ou equipamento que possua campo maguinético foi colocado próximo ao cabeamento ou equipamentos de rede.
           Se a rede estiver ligada apenas com hubs verificar a quantidade de máquinas ligadas o problema pode estar acontecendo por excesso de broadcast na rede, verifique a possibilidade de trocar os hubs por switchs.
           Se não houver nenhuma interferencia externa e a rede possui switchs verifique o trafego de rede pelo servidor com um sniffer para que você tenha uma ideia pacotes estão entrando e saindo do servidor, caso aja pacotes estranhos passar um bom antivirus no servidor e nos clientes para que seja feita a remoção de qualquer ameaça que possa estar causando o problema.
           Se você não notar nada de estranho nos pacotes  faça uma analise com o performace monitor no servidor utilizando contadores de processador, disco leitura e escrita, paginação de memória e interface de rede pacotes recebidos por segundo, a lentidão pode estar acontecendo devido gargalo no servidor.

    Espero ter ajudado.

    terça-feira, 22 de dezembro de 2009 03:04
  • Bom dia Rafael e Leo,

    Primeiramente gostaria de agradecer o fato de tentar ajudar respondendo minha dúvida.
    O Cliente entrou em recesso e com isso só poderei tentar algo somente a partir de Janeiro. Mas de qualquer forma irei verificar todos os pontos propostos até aqui por vocês, porem já posso adiantar em relação a fonte de energia perto do rack existe o Nobreak (no Chão) e o filtro de linha que está preso no Rack.
    Quanto a parte de Equipamentos, utilizamos Switches e não Hub.
    Quanto a analise de performance do servidor, utilizando como base os contadores da Microsoft descrito no link: http://support.microsoft.com/default.aspx/kb/146005/pt-br , ele se encontra em perfeita conformidade.
    O teste do ping que executei, não foram somente de uma única estação para o Servidor e sim de algumas estções (cerca de 5) localizadas em diferentes setores da empresa. Cheguei a substituir a placa de rede em uma das estações, porem o problema persistiu. Pingando nesse momento do Servidor para o Router (o ping está absoulutamente normal - Ressaltando que todas as estações de trabalho estão desligadas) e com isso tudo indica que pode ser os seguintes fatores que estão provacando o gargalo na rede:

    1- Cabeamento (nesse caso teria que ser o cabeamento de praticamente toda empresa);
    2- Algum ponto de rede com cabeamento danificado e quando liga a estação nesse ponto, pode estar provocando esse gargalo;
    3- Alguma estação de trabalho está com vírus e com isso provocando esse gargalo (P.s: Todas as estações possuem antivírus SEP rigorosamente atualizado);
    4-  Vou utilizar o Microsoft Network Monitor para fazer a analise do trafego.

    Caso esqueci de algo, favor me avisem

    Desde já agradeço,
    Vanderson Cahet - MCSA 2003
    terça-feira, 22 de dezembro de 2009 12:44
  • Vanderson,

    O nobreak e o filtro de linha não são problemas a não ser que estejam com algum tipo de defeito.
    Você disse que pingou do servidor para o roteador e estava tudo normal, então as máquinas estão em subredes diferentes ou esse roteador é o que vai para internet?
    Se estiver em subredes diferentes é só testar das estações de trabalho para o roteador verifique se está tudo normal, caso tenha algum problema é só ir issolando do roteador para as estações de trabalho.
    O Microsoft Network Monitor não é tão bom assim tenta usar o wireshark um otimo snnifer grátis e que tem várias opções.
    Quando conseguir resolver poste para que possamos saber o que você fez.

    Espero ter ajudado.
    quarta-feira, 23 de dezembro de 2009 02:42
  • Vanderson

    Como citado pelo Rafael, o Wireshark é um analisador de rede legal para ser utilizado desde que você utilize uma porta "mirror" de seu switch ou sua estrutura de rede seja em hub. Caso seu switch não permita fazer tal configuração, sugiro a utilização de hubs para a coleta de informações do Wireshark.

    Abraço
    Carlos
    quarta-feira, 23 de dezembro de 2009 11:14
  • Boa Tarde Rafael e Carlos,

    Mais uma vez agradeço a vocês por estarem me ajudando na resolução desse problema.

    Quanto ao Nobreak e o filtro de linha eu já sabia que não seriam o causador desse gargalo (apenas quiz passar o ambiente da forma mais completa possivel).
    Quanto ao Router ele é o Gateway (O diagrama de rede do cliente está assim: Router > Switch > Server + Estações).
    Quanto ao Wireshark assim que puder irei experimentá-lo.

    Uma dúvida: Ao uilizar switches na rede, eu consigo analisar o trafego de toda minha rede usando o Wireshark, instalando-o somente em uma estação ou Servidor?
    Obs.: Esse cliente utiliza switches 3Com 2824.

    Desde já agradeço,

    Vanderson Cahet - MCSA 2003
    quarta-feira, 23 de dezembro de 2009 15:50
  • Vanderson,

    Para que você consiga analisar toda a rede você precisa de um switch configurável, onde você consiga espelhar as portas, (Como você deve saber, cada porta de um switch é um domínio de colisão então se as portas não estiverem espelhadas você só ira ver o tráfego que entra e sai da máquina que está com o Wireshark), você teria que ligar um hub na porta do switch que vocês está usando para espelhar as demais portas e uma máquina com o wireshark nesse hub, assim você conseguria ver os pacotes entrando e saindo de todas as máquinas de sua rede.
    Acredito que o switch que você usa não seja gerenciável então para fazer essa análise em toda rede você teria que ligar tudo com hub o que acredito que como em todos os ambientes de rede essa solução seria inviável.
    Então tente fazer uma verificação dos pacotes chegando e saindo do servidor acho que já deve te dar uma ideia do que está acontecendo na sua rede.

    Espero ter ajudado.
    quarta-feira, 23 de dezembro de 2009 16:45
  • Vanderson

    Tava dando uma lida no datasheet do seu switch e não consegui verificar que ele possui a funcionalidade de fazer portas espelhadas. A melhor forma de fazer esta atividade seria como o Rafael comentou em seu post.
    Carlos
    quarta-feira, 23 de dezembro de 2009 18:15
  • Boa Tarde Rafael e Carlos,

    O Switch não é gerenciável.
    Rafael me tira uma dúvida: Quando você informa "você teria que ligar um hub na porta do switch que vocês está usando para espelhar as demais portas e uma máquina com o wireshark nesse hub, assim você conseguria ver os pacotes entrando e saindo de todas as máquinas de sua rede.", Qual das possibilidades você está querendo dizer? Segue o link: http://uploaddeimagens.com.br/imagem/ver/Analise-de-Trafego.jpg

    Bom Natal para todos.

    Desde já agradeço,

    Vanderson Cahet - MCSA 2003
    quarta-feira, 23 de dezembro de 2009 19:51
  • Vanderson,

    Deveria ser feito como na possibilidade 1, não teria a necessidade de colocar o wireshark no serveidor você poderia colocar uma outra máquina qualquer ligada no hub para fazer essa analise.
    Estava lendo um material sobre esse switch que o seu cliente possui e esse switch não é gerenciável, não posibilitando espelhar as portas.
    Então faça como citei no post anterior faça uma análise dos pacotes que estão entrando e saindo do servidor, você terá uma idéia do tráfego da rede.
    Depois classifique as respostas e nos mantenha informados sobre a situação. 

    Espero ter Ajudado.
    • Marcado como Resposta Richard Juhasz segunda-feira, 28 de dezembro de 2009 15:15
    quarta-feira, 23 de dezembro de 2009 23:25
  • Olá amigos.

    Estou com o mesmo problema e notei que nas  maquinas que estão lentas, quando dou  um ping no server ou em qq outra maquina da rede a resposta é em 15ms em média, mas se eu fizer o teste ao contrario, a resposta ér de 1ms.

    troquei switch, placa de rede, desabilitei antivirus e nada resolveu.

    então formatei a cpu e problema resolvido.  não sei o que causou o problema mas só consegui resolver com a formatação.

    alguem tem ideia de como solucionar o problema sem formatar a maquina? Ou pelo menos tem idéia de o que esteja causando o problema?

    Att

    Alex

    terça-feira, 21 de agosto de 2012 20:34
  • Bem, esta noite eu tive uma luz sobre o que seria o problema e depois de um teste se confirmou.

    O problema de lentidão na rede e tempo alto de ping é causado por um plugin que os bancos estão impondo aos clientes, chamado GBPlugin.

    Esse Aplicativo é conhecido como módulo de segurança, guardião,  etc e em alguns computadores com windows xp  causa lentidão, alto  consumo de processamento e agora percebi que causa lentidão na rede.

    Para solucionar o problema provisóriamente, basta remover o GBPlugin através de um disco de Boot.

    Inicialize o computador com  algum liveCD, vá em  c:\arquivos de Programas\ e apague a pasta GBPlugin.

    Inicie o computador normalmente e use o ccleaner para remover as chaves de regisro que se referem a ele. Reinicie o computador novamente e pronto, problema resolvido provisóriamente.

    O problema é que quando o usuário acessar o banco novamente,  o plugin será instalado novamente e o problema volta.

    Não descobri o que causa este problema, pois nem todos os computadores com XP apresetam este problema, mas  não vi nenhum com w7 apresentando ainda.

    Caso alguem descubra a causa real do problema e uma solução definitva, agradeço.

     

    quarta-feira, 22 de agosto de 2012 17:18
  • Estava com o mesmo problema, resolvi desativando a placa de rede e ativando novamente.

    O ping voltou ao normal, problema de lentidão resolvido.


    acclaro

    quinta-feira, 23 de agosto de 2012 19:07